1. The forum software has recently been updated. If you have comments or feedback, please let us know HERE! If you have arrived via a Google search, please use the forum search feature to locate specific information.

    Best wishes,
    The NI Team

5.9 here - but it won't install on Mac OS 10.6.8 or Windows XP

Discussion in 'REAKTOR' started by mpl, Oct 24, 2013.

  1. mpl

    mpl NI Product Owner

    Messages:
    131
    just to say 5.9 update is available
    mike
    Just tried to install-needs 10.7+,I'm still on 10.6.8 and it won't install.
    Last edited: Oct 24, 2013
  2. herw

    herw NI Product Owner

    Messages:
    4,892
    so now we can speculate:

    next minorupdate is a majorupdate REAKTOR 6 or it is the end of REAKTOR :( or a new software will come (core based :) )?

    Nevertheless R5.9.0 ist the best one ever.

    ciao herw
  3. sowari

    sowari Moderator

    Messages:
    24,611
    all future NI products will need 10.7 and above.

    btw, Maverick is a free install and you can install on a Mac with 10.6.8.

    sowari
  4. jes

    jes NI Product Owner

    Messages:
    37
    I think it's sort of annoying, myself. My studio MacPro is running 10.6.8, and that's where I end up with all the sessions that use Reaktor. It's not like I'm going to update it just to run Reaktor with my ProTools system. What's the big difference that makes it only work at 10.7 and above?
  5. sowari

    sowari Moderator

    Messages:
    24,611
    NI has not supported Mac OS 10.6.8 for a year now, and neither does Apple. that means it does not make sense to release or test on it.

    fwiw, Pro Tools 11 does not run on 10.6.8 - unless you prove me wrong.

    sowari
  6. salamanderanagram

    salamanderanagram NI Product Owner

    Messages:
    1,993
    yeah, once apple stops supporting something, you can't expect NI to have different codebases for everybody who doesn't feel like upgrading.
  7. jes

    jes NI Product Owner

    Messages:
    37
    Of course, everybody is expected buy new computers. In my experience, most professional studios don't upgrade things that are stable unless they absolutely have to. I upgrade NI applications usually because I know that they will be, in fact, better.
    Most of the professional studios I have worked in in the past few years are running Pro Tools 9, or even 8 (not to make this thread about Pro Tools, but I run PT 10, and don't really want to upgrade to 11 due to a loss of investment in RTAS plugins.)

    But that's what I'm wondering, how or why is the codebase so different for 10.6.8 and 11? Many other audio software makers support everything above 10.6.8. (in my personal experience, anyway.)
  8. Quietschboy

    Quietschboy Forum Member

    Messages:
    100
    Nooooooooo!!!!
    2013-10-24_193700.jpg

    yes, 5.8.0 didn´t support XP too, but it runs.
  9. magneson

    magneson Forum Member

    Messages:
    313
    @Jes

    I have a MBP from mid 2009, still running strong, with the latest (and free) OSX. I don't care as much with this computer, but the norm still is to be one version number behind the current release, which would be 10.8, which again will support Reaktor.
  10. EvilDragon

    EvilDragon NI Product Owner

    Messages:
    6,649

    You can always try and extract the EXE and DLL from the setup file using Universal Extractor, and use that instead.
  11. salamanderanagram

    salamanderanagram NI Product Owner

    Messages:
    1,993
    sorry, but a free upgrade to an operating system is not a new computer. nobody but NI can say why their products now require 10.7, but as i indicated above, it's probably because supporting 10.6 would require a separate code base, which seems pointless to support a product that apple themselves no longer support.
    Last edited: Oct 24, 2013
  12. argosound

    argosound New Member

    Messages:
    14
    sorry to bother with that, but why aren't there any infos? what's new about 5.9?am i missing something?
  13. EvilDragon

    EvilDragon NI Product Owner

    Messages:
    6,649
    From Readme.txt:

    Version 5.9.0
    What's new:
    - Advanced integration in MASCHINE 2.0 host software
    - Support for AAX2 - Avid's 64-bit plug-in target for Pro Tools 11
    - QuickBus Highlighting
    - Default if Missing Property
    - Show Ensemble in Finder/Explorer
    - Removed limitations for several moduls (Contol Rate, Clock Type, Info Type)
    - Core Quickbus highlighting

    Fixes:
    - Advanced integration in MASCHINE 2.0 host software
    - Replacing actual selected sample in sampler module does crash Reaktor
    - Certain WAV files can not be loaded to sample map
    - Event Tables: "Backup Data with Module" doesn´t work anymore in 5.8.0
    - There is no IC Send menu entry for root ensemble level
    - Wrong number formatting for tune in sample map editor
    - Midi clock stop command not received
    - Sending program changes to Reaktor Plugin does cause serious CPU spikes
    - Midi assignment for snapshot morph broken
    - Crash with audio smoother calculating high numbers
    - Miscellaneous bug fixes
  14. glyngad

    glyngad Forum Member

    Messages:
    23
    I am still stuck in the dark age`s on Xp service pack3 and i still don`t max it out but it seems my best toy`s new upgrade running on windows 7 or higher is forcing me to upgrade everything I own.Although I am pretty hacked about it I can understand why NI and other companies are no longer supporting older platforms but it does force a lot of people to spend money on upgrades to their software they probably can`t really afford.cheers Glyn.
  15. Vadim_K

    Vadim_K Forum Member

    Messages:
    100
    Respect NI for stop supporting the XP :) It becomes so sorrowfully to me when I still see XP anywhere :D
  16. Michael O'Hagan

    Michael O'Hagan Forum Member

    Messages:
    260
    what does "quickbus highlighting" mean?
  17. arachnaut

    arachnaut NI Product Owner

    Messages:
    2,947
    See Reaktor 5 Manual Addendum page 8

    "1.3 QuickBus Highlighting in Core Structures
    To make it easier to navigate and edit Core structures, QuickBus highlighting has been added.
    When you select any QuickBus connection, all connections to that same QuickBus will be underlined."
  18. colB

    colB NI Product Owner

    Messages:
    832
    It is for me!

    Mac OS 10.7 won't install on my Macbook2.1. Apple have decided that I should buy new hardware!
    My Macbook is plenty good enough for all the things I need to use it for (apart from latency problems that are a hardware/driver issue that Apple choose to deny) - why should I throw it away and spend $$$?
    Oh yes, because Apple (like most other manufacturers) love artificial obsolescence.

    It's a shame that NI have gone along with that. It's going to be tricky keeping up with discussions here on the forum when I can't run any of the uploaded examples because my Reaktor is out of date.
  19. salamanderanagram

    salamanderanagram NI Product Owner

    Messages:
    1,993
    well, that's a bummer, but your beef is with apple not NI, as i see it. i do doubt that NI is just adding in a piece of code that makes it not work on 10.6.8 just for the sake of it, though.
  20. Michael O'Hagan

    Michael O'Hagan Forum Member

    Messages:
    260
    Same here, I've got an early 2008 white macbook 2.1 core 2 duo, plenty of power for all my programs and plenty for the OS, but its not compatable with mavericks.

    I was actually thinking about getting a new comp around christmas or early next year, I just don't like a perfectly good computer being abandoned, this also lowers the resale value should I sell it towards the upgrade.

Share This Page