1. The forum software has recently been updated. If you have comments or feedback, please let us know HERE! If you have arrived via a Google search, please use the forum search feature to locate specific information.

    Best wishes,
    The NI Team

Maschine Controller Dropping Out of Midi Mode In Traktor But Not Maschine

Discussion in 'TRAKTOR PRO / TRAKTOR SCRATCH PRO' started by Intandem, Jul 10, 2012.

  1. Intandem

    Intandem Forum Member

    Messages:
    32
    Hi, I am having problems with Maschine dropping out after anywhere from 10 seconds to 5 minutes of playing! This is really frustrating and annoying and impedes any kind of live performance.

    I have deleted my settings, deleted my mappings, and have reimported my tsi files yet I'm still faced with the same problem! I corrected this issue originally by deleting a duplicate tsi mapping but when I upgraded to 2.5 this problem resurfaced so I deleted 2.5 and rolled back to 2.0.3 yet the problem remains arggggh! This is the most frustrating issue I have come across as the only way to temporarily fix the problem is by unplugging the maschine and replugging it in, but this only lasts for a couple minutes (if I'm lucky) and then it craps out again. What's going on? Can anyone help me please?

    I can't play live like this and it's really dampening my @ home sessions... I don't understand why NI would have difficulty such as this with their OWN hardware?
  2. DJ Freshfluke

    DJ Freshfluke Moderator

    Messages:
    25,385
    what exactly do you mean by "dropping out"? are you using it directly on the computer or via hub? usb3.0? what system? more info pls.
  3. Sparksta

    Sparksta NI Product Owner

    Messages:
    228
    had the same problem...

    guess you midi clocked maschine to traktor?

    open the controller editor and play teaktor like you do...

    now see that there is a consant in or out blinking dont remember (right upper corner) on the teaktor template.

    there is some kind of midi loop.

    at least that was my case.

    i dont know the exact setup but i tryed pretty much everything...

    virtual port, external cable...

    i think traktor is sending midi clock to all selected midi devices so maschine simply gets confused. in my case the editor would show input (and after all blinking) when i press a pad but traktor would not respond at all after the midi dropout

    without midi clock it wont dropout

    if your just in midi mode without midi clock and you dont use traktor and maschine at the same time i have no idea what could be wrong :(
  4. Intandem

    Intandem Forum Member

    Messages:
    32
    Sparksta that's pretty much exactly what I'm experiencing! The controller editor will show midi out and the pads light up and respond but traktor doesn't and the midi in drops out!

    Maschine software is fully controllable, no drop out, so it can't be a usb problem. I'm using a 2011 Macbook Pro 13" i7 usb 2.0 I think.
  5. Intandem

    Intandem Forum Member

    Messages:
    32
    Yeah I'm not sure what the problem is, I've removed the Midi Clock TSI and have turned off Midi sync yet I still have the same drop out problem.

    By drop out I mean that traktor 2.0.3 (or any version for that matter) stops responding to the midi messages from the Maschine. The Maschine Midi out is still flashing in the controller editor but the Midi In stops. I don't understand why... Maschine software works perfectly for hours uninterrupted but not Traktor, I can barely get 3 mins into a track before it drops out!

    This is really really frustrating. I originally corrected the issue by deleting a duplicate mapping but when I upgraded to 2.5 the issue resurfaced so I've rolled back to 2.0.3 and the problem remains in 2.0.3 aswell! What the heck?

    Btw I am using Maschine to control Traktor separate from the Maschine Software.
  6. Sparksta

    Sparksta NI Product Owner

    Messages:
    228
    that its still happening without midi clock is strange....

    have you also disabled the virtual traktor in out in maschine?

    if not try that one...

    otherwise im out of ideas :(
  7. Zac Kyoti

    Zac Kyoti NI Product Owner

    Messages:
    416
    Guys, the issue is a longstanding and well known bug unrelated to choice of additional software. It's got to do with Maschine in midi mode. After a random amount of time the NIusbservice agent crashes, and makes maschine unresponsive or ineffective. Engineering is aware of the situation but has not offered an estimated fix time. Do a search on something like "midi mode stops working" and you'll find plenty of info.

    And yeah, it really sucks in terms of workflow.

    EDIT: Just to make sure I'm clear - the crash has nothing to do with Traktor, your tsi, or midi clock. It will happen just as readily using a standalone softsynth, drum maschine or anything else you might use in midi mode.
  8. Intandem

    Intandem Forum Member

    Messages:
    32
    So why hasn't NI taken care of this problem? I can't even bring my maschine out live with me... I have to use other people's controllers/mixers because the maschine drops out. My hercules has no problem with traktor, nor any other controller I've used, this is frustrating me!

    I somehow fixed the problem a couple months ago but it returned when I upgraded which prompted me to roll back to a previous version yet the problem persists, ugggh!
  9. Intandem

    Intandem Forum Member

    Messages:
    32
    Is there any kind of work around or fix to this issue? This is THE MOST ANNOYING issue I have EVER come across. I might as well switch to another DJ software such as serato FFS.
    ---
    The problem just seems to be getting worse, more frequent drop outs ever since I updated to 2.5 GODDAMN YOU 2.5
  10. Intandem

    Intandem Forum Member

    Messages:
    32
    Any ideas at all? The Maschine is a Native Instruments hardware, so I'm not sure why Maschine and Traktor aren't compatible? I would assume that they would be closely integrated.
  11. Zac Kyoti

    Zac Kyoti NI Product Owner

    Messages:
    416
    Did you check out my comment above? It's not a maschine/tractor issue, it's a maschine issue with any software in midi mode. We're still waiting on a fix. :(
  12. Intandem

    Intandem Forum Member

    Messages:
    32
    Any update on this issue, wtf is going on with development?
  13. Zac Kyoti

    Zac Kyoti NI Product Owner

    Messages:
    416
    No updates on progress AFAIK. Still waiting on NI to even publicly acknowledge the problem. Transparent customer service goes a long way towards retaining customers, and ensuring positive recommendations of NI products to potential customers. (Hint Hint) :(
  14. DJ Freshfluke

    DJ Freshfluke Moderator

    Messages:
    25,385
    have you been in contact with support?
  15. Zac Kyoti

    Zac Kyoti NI Product Owner

    Messages:
    416
    I can't speak for Intandem, but I myself have been in contact with support extensively. There are many others who have as well. Big, big problem, for going on about a year now. Only boilerplate responses from NI, "known issue, no estimated time for a fix", etc. I've gotten a ticket, sent crashlogs, used the NISupport Tool, you name it, I've done it. Freshfluke, look in Maschine forums/Technical issues>Ableton and Maschine MIDI mode stops working, to familiarize yourself with the problem. You know, the thread with like 13k views? Don't worry about the "Ableton" in the title; its not software specific.

    Really the main thing people want is a simple public acknowledgement, and confirmation that the issue is being worked on. I can't even begin to express how good this would be for NI's customer relations right now.
  16. DJ Freshfluke

    DJ Freshfluke Moderator

    Messages:
    25,385
    i cant speak for maschine nor am i in this issue enough to comment on it - so if this is a known maschine issue, it should be discussed there, right? and i cant do here on the traktor side, do i see that correctly?
  17. Zac Kyoti

    Zac Kyoti NI Product Owner

    Messages:
    416
    You are correct. ;)

Share This Page