rig control cry wah how? ... please help

Discussion in 'GUITAR RIG' started by didierlux, Sep 29, 2011.

  1. didierlux

    didierlux New Member

    Messages:
    5
    hello,
    I'm a guitar rig newcomer. I've purchased guitar rig 5 pro with the rig controler.

    I would like to control the "cry wah" filter with rig control "RK PEDAL" but how ..... I was not able to find any newbie help in the doc that was really helpfull to me.

    here is what I did ... with for example the:
    - guitar amps -> lead 800 --> "008 800 Clean" preset.

    I've inserted the "cry wah" filter, with F3 I'm displaying the rig control.
    a) I dragged the "rk pedal" label into the "cry wah" component
    b) the "rk pedal" label now shows that "cry wah pedal" was assigned to it
    With the mouse, I can indeed do up and down moves on the pedal in the software, you can herel the wah modulation change and the bar in cry wah moves up and down. BUT .... when I use the hardware pedal it doesn't work, no modulation happens it is like nothing is assigned to it ...

    thank you very much for any help

    Attached Files:

    • wah.jpg
      wah.jpg
      File size:
      185.2 KB
      Views:
      90
  2. Roming22

    Roming22 Forum Member

    Messages:
    339
    Hi

    First check that using the hardware pedal makes the red indicator of the pedal move up and down.

    If the indicator doesn't move but that the other switches work fine, it is a hardware issue.

    If the indicator does move, then remove everything from the preset by clicking on the top left X, under the NI logo.

    Add just the wah pedal component. Right-click on the component slider and select Learn from the drop down menu.
    Move the hardware pedal, check that the wah slider is moving as well.

    Cheers
  3. didierlux

    didierlux New Member

    Messages:
    5
    Thanks a lot for answering.
    Which indicator do you mean, the red slider bar in the (red) rectangle at the right bottom of my screenshot? This one is actually "not" moving when using the hardware pedal ....

    It is a brand new control ... unpacked a few hours ago ... do you mean the rig control could be damaged?
    :(
  4. SloobyJane

    SloobyJane NI Product Owner

    Messages:
    234
    Something that I've seen people miss is in the Guitar Rig VST, you have to click on the pedal board to connect it.

    1. Display the Pedal Board in Guitar Rig.
    2. In the upper left hand corner of the Pedal Board there is a 'connect' light.
    3. Click the light to connect, the light will turn bright red.

    Hope this helps.

    OK, I took a look at your screen shot, it appears you do have it on, my bad. I'll see if I can replicate this situation on mine.
    Last edited: Sep 30, 2011
  5. Roming22

    Roming22 Forum Member

    Messages:
    339
    I'll assume you were able to make the switches work. Please confirm.

    Make sure that the pedal is calibrated (Options -> Preferences).

    Remove the screws at the bottom of the unit.
    Look at the pedal. It works with a reflective surface moved by the pedal away/closer to a receptor. Identify the receptor and the reflective surface. Check if there's anything in the way (like a lose cable). Try moving a piece of paper in front of the receptor.

    If you still can't manage to make the red indicator move, you should contact NI support, as your unit is probably defective.

    Cheers
  6. didierlux

    didierlux New Member

    Messages:
    5
    hello ... sorry to reply so late but I have a severe stomach flu .... unfortunately I'm stuck at home, I have the pedal at my work location, I'll test it as soon as possible and come back to the forum to communicate the results.
    many thanks for your help!
  7. didierlux

    didierlux New Member

    Messages:
    5
    Hmm .... nothing to do pedal isn't reacting ... :( :angry:
    I tried for hours now (calibration reset via options-preferences etc) ....

    Anyway thanks for helping, I really think the device isn't working ...

    I purchased this a few days ago:
    1) I had a problem with the DVD it contained an update instead of full version .... so I was no able to install it, NI sent me a link where I was able to download the full install and now:
    2) pedal is not working correctly ... I paid +/- 380€, it is really it is really disappointing ...
  8. SloobyJane

    SloobyJane NI Product Owner

    Messages:
    234
    I have WIndows 7 64bit machine, one thing that I have to remember is to NOT plug in the USB cable coming from the Kontrol until after Guitar Rig is opened up. SOmetimes if the cable is already in it doesn't allow connection to the pedal board.
  9. didierlux

    didierlux New Member

    Messages:
    5
    Thanks for your help.

    I contacted NI support on this issue, it looks like, after a few days of troubleshooting, that it is indeed a hardware issue ....
  10. Roming22

    Roming22 Forum Member

    Messages:
    339
    Sorry to hear that. :(

Share This Page