1. The forum software has recently been updated. If you have comments or feedback, please let us know HERE! If you have arrived via a Google search, please use the forum search feature to locate specific information.

    Best wishes,
    The NI Team

TP2 missing .tsi?

Discussion in 'KONTROL S2 / KONTROL S4' started by MixTure, Apr 16, 2011.

Thread Status:
Not open for further replies.
  1. MixTure

    MixTure New Member

    Messages:
    9
    my TP2 software keeps telling that I'm missing traktor's .tsi...-.-
    Never had that problem with the S4 software, but after installing TP2 the same message pops up when running the it.

    Every time I start up the controller with one of the 2 softwares in need to make a mapping of some kind to let it work. Seems like it is missing the factory settings so i don't have custom layout's... but If I look in my native instruments map I can see the .tsi file with my own eyes=/

    Anyone had this problem before?
    all advice is welcome!

    greetz
  2. dannybyrne29

    dannybyrne29 NI Product Owner

    Messages:
    2,331
    have ya tried resetting your S4 in preferences to rewrite the TSI's...!
  3. MixTure

    MixTure New Member

    Messages:
    9
    No i haven't tried that yet.
    So how do can I do that?
  4. dannybyrne29

    dannybyrne29 NI Product Owner

    Messages:
    2,331
    preferences /traktor s4 /restore defaults... just clutching at straws really but it might work
  5. MixTure

    MixTure New Member

    Messages:
    9
    tried it, but it doesn't change anything when it comes to the TP2 software :/

    It's like I'm missing the tsi file for it, but if I look in the TP2 folder it's there...
    really don't know what I did wrong :/

    Also, every folder that's in the TP2 map under documents is empty...
    Reinstalled over and over...

    Thnx a lot btw :)
  6. dannybyrne29

    dannybyrne29 NI Product Owner

    Messages:
    2,331
    maybe the TSI is corrupted.... might be worth uninstalling all Traktor software and deleting the Native Instruments file in My Documents (Make A back up of it first)and then download the demo from NI web site and reactivate it with your new serial number with your service centre..!
  7. Karlos Santos

    Karlos Santos Moderator

    Messages:
    10,457
    What is the exact message?

    Look in the Native Instruments>Traktor folder and do you see a file called: Traktor Settings.tsi

    If so shut Traktor down and then copy it and save it somewhere safe and then delete it from the Traktor folder.
    Then restart Traktor and it will create a new file. You will have to re-do your favourites and layouts but it may fix the issue.
  8. MixTure

    MixTure New Member

    Messages:
    9
    well, when i open TP2, the following message always appears: "could not read the default settings file for audio auto configuration. please rerun the installer"
    I'ff I press ok, that one disappears and the software starts as normal and the messga esaying "missing controller TSis" appears

    I also get an error message in the bottom of the screen saying: "WARNING: could not locate factory settings folder:C:\ProgramData\Native Instruments\Traktor 2\Factory Settings\2.0.1\Default Settings\!Please Reinstall"

    Thnx for your help!
  9. Karlos Santos

    Karlos Santos Moderator

    Messages:
    10,457
    Then I think you need to reinstall the application.
    Are you installing from the DVD?
  10. MixTure

    MixTure New Member

    Messages:
    9
    nope, i got the free update because I bought the s4 a while ago...
    Will it make any difference iff i put it on one? :)

    And I already installed it a couple of times... still nothing changed :/

    thnx a lot!
Thread Status:
Not open for further replies.

Share This Page