Blocks MIDI Out

Converts Blocks Pitch and Gate to MIDI Pitch and Gate

(11 Votes)
2.0 (Updated 3 years ago)
794.2kB
October 06, 2015
Reaktor 6
Blocks User Blocks

DESCRIPTION

This is a work in progress but it does seem to work. The audio file demonstrates using the enclosed Ensemble to send MIDI to an instance of the (Arturia) Oberheim SEM synth placed on another MIDI track in Ableton Live.

The upload includes an Ensemble and the .ism. For convenience you can see the notes that are being send out using an R6 Library Note Display macro.

This is nothing special but it works.



Btw, this does use Peter Dine's MIDI Out macro, that does make sure there are note off commands. So a big thanks to Peter for sharing that!

Version 2.0 now works with Velocity - Many thanks to Emm@ Em for this. I have used Emm@ Em's Channel Message Macro and other changes found here: https://www.native-instruments.com/forum/threads/euclidean-rotator-midi-implementation-request-for-help.267129/page-4#post-1452385

COMMENTS  (15)

Federico Giraldo
1 year ago
I can't manage to use it in Logic, any idea?
ian nickus
3 years ago
thanks so much for posting this.
Joe Kaczmarek
3 years ago
Thanks so much for this great module! Maybe you or someone can help me with a patching challenge using this Block and Michael Hetrick's 8 way switch. or maybe there's a bug. I'm trying to chain three Bento Box 8 Steps in series such that a single clock plays 8 steps from Sequencer A, followed 8 steps from Sequencer B and finally 8 steps from Sequencer C. I'm routing the clock into a clock divider, followed by the 8 way switch set for 3 steps. Gate outputs 1, 2 and 3 of the divider are set to 1 step and routed to inputs 1, 2 and 3 of the switch respectively and then onto the respective gates for each of the 3 sequencers. Gate 4 from the divider is set to 8 steps and routed to the switch's gate input. Gates 1, 2 and 3 of the switch are routed to the reset input for Sequencers A, B and C respectively. I'm routing the sequencers' gate, pitch and velocity output to your MIDI Out module. Overall, the patch works fine, except on the clock tick whenever the switch changes clock routing to the next sequencer every 8 steps. Whenever the switch changes outputs, the gate for the first step of the sequence lasts two clock cycles such that the first note of the sequence lasts twice as long as it should. If I disable the first note of each of the 3 sequencers, then the second note plays correctly. If I replace your MIDI Out module with a VCO+ADSR+VCA, then the entire patch works correctly. Can you look into what might be happening here?
Phil Durrant
3 years ago
An updated version of this can be found here: http://www.native-instruments.com/en/reaktor-community/reaktor-user-library/entry/show/9791/
MPad Electronix
3 years ago
thanks for answer (danke für die antwort :) , This is a pity :( i was hoping that it works like ableton. hmmmm "mr. and mrs Native Instruments" can you change that for me :) like a button where you can adjust, from which midi controlled. say: reactor controlled midi to ext.Hardware, Start/ Stop from Machine (Studio), Hardware Audio to Maschine Input.....and record themin / with Maschine. that would be the hammer :)
Phil Durrant
3 years ago
@MPad, you can't route MIDI from one plugin to another in Maschine.
MPad Electronix
3 years ago
reactor standalone works with midi out to eurorack, but when i try maschine 2.4 and load reaktor as a plugin :( Does somebody has any idea? have tried many things: maschine midi out, reaktor connections.......it does not work anyway mhhhhhhh :(
Phil Durrant
3 years ago
Velocity now works thanks to Emm@ Em.
CHARLES GRAEF
3 years ago
Sorry, sorry, need to clarify the below because my less-than symbol won't show up in this editor. For velocities less than 50, gate is shut off. For velocities over 50, gate passes normally.
CHARLES GRAEF
3 years ago
Actually, it looks like the Gate and Velocity inputs affect each other, such that velocity simply subtracts from gate. Say (for example) you have a sequence of 8 steps, all gates On, for any step for which velocity is set 50, gate passes through. In no instance does the DAW receive a velocity other than 100% or 0% – it's binary On/Off. Very curious about how to fix this, because in other respects it's a great help.
CHARLES GRAEF
3 years ago
Am I crazy or is this not capable of capturing/sending MIDI velocity? Can't get that to work. Any ideas?
Daniel Müller
3 years ago
thanks a lot!... using it to send MIDI trough SQ-1 (MIDItoCV) to modular-synthesizer...works fine!
Marko Vierimaa
4 years ago
Thank you!
Alessandro Ramella
4 years ago
thank you thank you thank you!!!!
Joseph Guisti
4 years ago
Thank you Phil!
now