1. Please do not install macOS 10.15 Catalina yet, as Native Instruments software and hardware products are not supported under macOS 10.15 yet. For more info, please go HERE!
    Dismiss Notice

Permalink for Post #1

Thread: Will traktor dj be compatible with more than the z1 in future?