1. We're currently conducting systematic tests with the release version of macOS 11 (Big Sur) in order to offer full compatibility of our products as soon as possible. You can find our latest compatibility status - here


    Please note that although announced at the same time as macOS Big Sur, Apple Silicon processors are an independent release with separate compatibility concerns for NI products. Compatibility with macOS Big Sur will not yet ensure compatibility with Apple Silicon processors. At the moment, Native Instruments products are not supported on computers with Apple Silicon processors. Read more - here

    Dismiss Notice

3 Maschine In Reaper Templates

Discussion in 'MASCHINE Area' started by PooFox, Aug 13, 2017.

  1. stalyan

    stalyan NI Product Owner

    Messages:
    28
    I understand what you mean but it just doesn't work for me. As an example, I got a basic loop that was enough for me to write 3 min lirics aprox.

    Once I do this I want to record the vocals with the basic loop and start toying with that basic loop to create additional patterns based on the vocals so the integration is more organic.

    I'll let you know how it goes on my first attempt, thanks for sharing your view it seems very legit too.
     
  2. PooFox

    PooFox NI Product Owner

    Messages:
    135
    Templates have been tweaked, simplified and updated.
     
  3. Stratguy100

    Stratguy100 New Member

    Messages:
    3
    Just a note to say thanks and that I use this multi midi channel approach now too, as it provides the best workflow I have seen between Maschine and Reaper.

    Brilliant
    Cheers
    Jed
     
  4. PooFox

    PooFox NI Product Owner

    Messages:
    135
    Stratguy100 you're very welcome; good to know that it helped you!
     
  5. ryanhiggs

    ryanhiggs New Member

    Messages:
    2
    Hi, thank you for creating these templates! For some reason I cannot get any sound to come out, even though it shows my midi recording. I know I'm close, but I'm also a noob when it comes to figuring all this out so yeah. Any ideas??
    Here's what I'm running: imac Mojave v. 10.14.6, reaper v.5.981, maschine MKII v. 2.8.3
     

    Attached Files:

  6. PooFox

    PooFox NI Product Owner

    Messages:
    135
    Not a problem, dude. Did you load any kits? Is there sound coming out of Reaper otherwise? Make sure when you load your kits, you do it without loading the routing as well or it will mess up the routing I made.

    Oh I might have made a mistake when I added that single track template. If that's the one you're using in the pic, it looks like you just need to bring up the fader, cos it's down to 0. Lemme know if that's not it. Maybe I need to edit my template.
     
  7. ryanhiggs

    ryanhiggs New Member

    Messages:
    2
    Ahh ok, yeah. I downloaded the second template and that worked. Not sure why the first one didn't (I had my fader up, kit loaded, routing seemed legit, still nothing). But dude I'm so stoked that I'm finally able to record my Maschine sounds in Reaper! Instead of drag n dropping/exporting all the time. Such a better workflow.
    Thanks again.
     
  8. PooFox

    PooFox NI Product Owner

    Messages:
    135
    Ok I'll take a look at the first one again and re-up later if something's amiss. It was a bit of a rush job, so you might just be the first one to let me know it's not working. Glad I could help, lemme know if you have any problems.

    EDIT: Ya, geez I had the fader down and the master/parent send disabled for the track. Thanks for providing feedback. Fixed it.
     
    Last edited: Aug 15, 2019
  9. Christos Adamos

    Christos Adamos NI Product Owner

    Messages:
    221
    Unfortunately for me doesn't work. I trying to open the templates and Reaper stuck on loading Maschine
    Reaper version 5.9.71 on Windows 10 X64
    Any opinions?
    But thanks anyway, that you giving these templates to us ;)
     

    Attached Files:

    Last edited: Sep 12, 2019
  10. PooFox

    PooFox NI Product Owner

    Messages:
    135
    I'm also on Win10 x64 but this is the second time I've heard about Reaper hanging while loading the templates. I'm not really sure what could be causing it. Do you have SWS extensions installed and Maschine up to date? I use Maschine Mikro mk1, but it shouldn't matter, since they all use the same software. I'll have a look at them and see if I can figure it out. Thanks for letting me know.

    In the meantime, try this: Find Maschine 2 in your fx browser, right-click it and set it to "hard reset" and "inform when channel count changes." I also use "minimal undo states" because Maschine has its own internal undo and I categorize it as instrument (under "rename").
     
    Last edited: Sep 11, 2019
  11. Christos Adamos

    Christos Adamos NI Product Owner

    Messages:
    221
    Yes, SWS extensions and Maschine are up to date. I did what you suggested, but I didn't see any difference
     
  12. SIRjamsalot

    SIRjamsalot New Member

    Messages:
    1
    PooFox you did a splendid Job here! Figuring out how to do this has been racking my brain for some time now.
    with that being said I have one more question that could improve my process even more.
    I downloaded the 16 channel track and everything is working awesome, However, I've come to realize that my timing isn't quite perfect yet haha I was curious if you have any suggestions for modifications so that way the files record as individual MIDI's that way I can have the ability to quantize individual sound/MIDI hits. Its interesting because you can quantize these sounds in Maschine and export them as stereo, which id also like to find a way to do it reaper.

    Ive gotten the tracks converted to MIDIs after playing around but still haven't found a way to individualize each track out of stereo so they can be quantized individually!

    Thank you!
     
  13. PooFox

    PooFox NI Product Owner

    Messages:
    135
    Thanks SIRjamsalot, glad you like it. I didn't do any templates with separate MIDI tracks for the drum sounds because I just find it unnecessarily cumbersome to work with and also there's a bug in Maschine on Windows that makes it impossible to output more than 16 channels of MIDI (so only one kit max if the sounds are on separate channels. I can try to add one like that later if you really need it, but if you're working first inside of Maschine, you can use the SELECT button to isolate individual sounds for quantizing. If you want to quantize the sounds individually inside Reaper, you can just right click the Piano Roll in MIDI editor to select a single row of notes.

    One thing to keep in mind if you try recording MIDI performances directly inside Reaper is that you need to ensure "preserve PDC delayed monitoring" option is on when you monitor through Reaper (r-click the arm button for the option). This is because you will unconsciously tend to play early due to latency causing the sounds to occur slightly later than your hits, and this option will adjust the recording to compensate.
     
  14. GetFletch!

    GetFletch! New Member

    Messages:
    16
    Hi PooFox - I am successfully using your templates with Maschine Mikro Mk3 in Reaper. A big thank you for not only your initial efforts but also for your continued support in this forum.
    The one question I have: I don't seem to be able to capture midi from Mikro if I have Reaper tracks set to record midi overdub. Any solution for overdub recording of midi from Mikro?
     
  15. PooFox

    PooFox NI Product Owner

    Messages:
    135
    You're most welcome! I'm not aware of any advantage to using overdub mode with my templates. If you turn on the option 'new recording creates new takes' (it's on by default), then each new take will combine the old material with anything you play live during recording. That's overdubbing essentially, but also preserves the original as a take. If you don't need the old takes, just trim to the active take when you're done recording. Hope that helps.
     
  16. themixtape

    themixtape NI Product Owner

    Messages:
    362
    Hey Fletch! No luck with the custom thing I made for you?
     
  17. GetFletch!

    GetFletch! New Member

    Messages:
    16
    That works perfectly. Didn't realise I had turned off the the default option. Many thanks.
     
  18. GetFletch!

    GetFletch! New Member

    Messages:
    16
    Hi MixTape - yes, the templates you provided are great and I use them to transform my Mikro Mk3 into a surface in Midi Mode.
     
  19. caronte23

    caronte23 NI Product Owner

    Messages:
    92
    Thank you for doing these templates! I'm having trouble using the One Audio routed kit. It works fine when I have the maschine track record enabled, but as soon as I hit record a massive latency comes in. I've tried all combinations with input onitoring on or off, recording the audio tracks as well, having them with input monitor on or off.. nothing. As soon as the transport starts the latency comes in :/
     
  20. igoryazzaigor

    igoryazzaigor New Member

    Messages:
    9
    hi every body from italy!
    i found only today these useful instructions, and it was many days i was looking with a solution.

    myproblem is this: find a way to make communicate maschine and reaper in order to record on reaper some music coming from maschine and other instr. LIVE, on the fly-
    i found very useful the template "just one track". With it i was finally able to record simply madi phrases on reaper. BUT, WHEN I CHANGE GROUP, I ONLY CAN PLAY THE NEW SOUNDS, BUT NOT TO RECORD THEM (i use win 7 64 bit) i dont understand why this happens- only the 3 drum groups seem to work , not the others...
    So i tried the other way, audio 16 traks +1 midi. Thre i could record on separate traks other groups, but with a big big echo disgusting... what to do?