1. We're currently conducting systematic tests with the release version of macOS 11 (Big Sur) in order to offer full compatibility of our products as soon as possible. You can find our latest compatibility status - here


    Please note that although announced at the same time as macOS Big Sur, Apple Silicon processors are an independent release with separate compatibility concerns for NI products. Compatibility with macOS Big Sur will not yet ensure compatibility with Apple Silicon processors. At the moment, Native Instruments products are not supported on computers with Apple Silicon processors. Read more - here

    Dismiss Notice

3 Maschine In Reaper Templates

Discussion in 'MASCHINE Area' started by PooFox, Aug 13, 2017.

  1. PooFox

    PooFox NI Product Owner

    Messages:
    135
    igoryazzaigor - Sounds like you maybe forgot to uncheck the routing option and new kits are loading the default routing instead of using mine. Re-read the OP carefully. Let me know if you still have problems and I'll take a closer look.

    caronte23 - Sorry I missed you message. I'm not sure what would cause that but sounds like a system issue. I'd remove all other plugins from the project to see if its any of them. Plugins on the master track can cause a lot of latency. Also ensure you're using the correct and latest driver for your audio device.
     
  2. igoryazzaigor

    igoryazzaigor New Member

    Messages:
    9
    ciao, thanks a lot for answer. I''ll try to follow your advices- i dont underst well your "Re-read the OP carefully"... i will write again, good things!
     
  3. PooFox

    PooFox NI Product Owner

    Messages:
    135
    OP=original post. I mentioned there needing to turn off the routing option, but seemed like you had not, so maybe you missed reading it in the instructions of that first post.
     
  4. igoryazzaigor

    igoryazzaigor New Member

    Messages:
    9
    Thanks a lot again! i'll tell you how things will be, ciao!
     
  5. Felix Kogoj

    Felix Kogoj New Member

    Messages:
    14
    Hey PooFox you are doing a great job here... i almost figured it out perfectly but I have one last issue if you can help me:

    I am using the simplest Version 1 and I can finally record my Drumkits in Maschine via the Pads into Reaper!
    here comes the but... but as soon as I add another Track and add Maschine as FX to record Bass or whatever, I can´t record on the Drumkit any longer and only the first Pad is highlighted, even when I go back to the Drumkit Track... I hope you know what I mean and can help me :)

    Greetings
    Sam
     
  6. PooFox

    PooFox NI Product Owner

    Messages:
    135
    If you mean you add another instance of the Maschine plugin to your project, I don't recommend that at all. It's a hassle to keep switching between instances on Maschine and it can recognize one at a time and your new plugin will be at default settings.

    If you want to record your bass into Maschine and not Reaper, then just add another Group to the original instance of Maschine. My settings won't have any affect if you load another Maschine plugin but they'll still be there if you switch back to the original instance. You can do that from the Maschine GUI by clicking the icon that looks like Maschine in the top of the window.
     
  7. GetFletch!

    GetFletch! New Member

    Messages:
    16
    Hi PooFox - any chance of you putting up a template of the variation to the 4 kits template with separate midi channels for each Maschine Kit/Group coming in to Reaper? I want to do anything in Maschine (Mikro Mk3 in my case) I just can't seem to get the midi from individual Kits to record to a separate tracks. Didn't understand the sub-folder idea for a fix.

    Well I can with a workaround: I have to use midi sends from the Instrument track to separate tracks, creating a midi send-receive loop. But that means I have to mute the send back to the Instrument track for recording - hope that makes sense.

    Ideally, we need a solution similar to the one Jon has posted on ReaperBlog for routing Kontakt -
     
  8. PooFox

    PooFox NI Product Owner

    Messages:
    135
    The reason I didn't do any templates like that is because it creates a MIDI feedback loop. You can try it if you want, you just have to enable feedback routing in project settings. Then you send your MIDI to other tracks on different channels. If you then make the Maschine track a folder with those tracks as children, their MIDI will be sent back to Maschine automatically without further routing.

    The kits are already on separate MIDI channels and I recommend managing them all from the same item, by switching MIDI channels in the MIDI editor.

    Any special reason why you would need MIDI on separate tracks? I tried it like that at first too, but it's not fun to work with.

    In the video he has MIDI tracks sending to Kontakt and records directly to those tracks. There is no feedback loop. If you want to work inside Maschine or have access to note repeat etc, you have to record onto the Maschine track itself to avoid the feedback loop you would get by sending to and receiving from the separate MIDI tracks. Enabling feedback routing defeats PDC, which is what keeps your recordings in time with each other if your monitoring with any latency (Maschine is digital sound and therefore has latency).

    If you really need it that way and can explain why I can make it maybe this weekend, but again, I don't recommend working like that.
     
  9. GetFletch!

    GetFletch! New Member

    Messages:
    16
    Thanks for taking the time to help me on this. I have found a workaround that starts with using your 3 Kits template:
    - I create both sends and receives from my Maschine VST Instrument track to separate midi tracks - one for each Maschine Group on separate channels.
    - I have separate Audio tracks with receives from the Maschine VST Instrument track. Again, one for each Group.
    - When I want to record midi from Maschine while playing a specific Group on my Mikro, I have to mute the send from the midi track to the Instrument track.
    - When I have finished recording and want to playback the midi, I then unmute the send to Instrument Track.
    - I have written a couple of custom actions using SWS: Mute or Unmute all send from selected track(s) followed by Track: Toggle record arm for selected tracks.

    If you have a better solution to my workaround, I'm all ears.
     
  10. disso-fiddle

    disso-fiddle NI Product Owner

    Messages:
    31
    Hello,

    With the new clip functionnality, using maschine in reaper is even easier !
    Using "enable transport" in kontroller editor allows to have maschine with transport function
    and clips allows a more flexible linear edition.
    The only downside is the number of outputs, but actually being limited to 16 outputs is more
    than enough when you have unlimited tracks in reaper.
    Usually, I use the first group (group A) 12 sounds as a drum kit, each sound routed on its audio channel (1 to 12),
    and I keep the 4 remaining channels to route the audio outputs of 4 others groups, totalling 5 groups for audio.
    Additionnaly, I am using another group (so the group F or 6 ) to route the 16 midi channels out of maschine to reaper.
    This group is used to trigger audio loops or slices in reaper, which I find more reliable for time-strech and slicing.
    Frankly this is more than enough and makes the workflow very convenient.