1. IMPORTANT:
    We launched a new online community and this space is now closed. This community will be available as a read-only resources until further notice.
    JOIN US HERE

Solved A61 mod wheel sending midi when not being touched (KH1062-274)

Discussion in 'KOMPLETE KONTROL SERIES' started by decredis, Mar 29, 2019.

  1. kaotik78

    kaotik78 NI Product Owner

    Messages:
    318
    Thats a tough one and everyone's experience will be different. I was in your shoes years back and opted to buy Maschine MK2 new and it had hardware issues, screen and encoder, out of the box brand new. It took a considerable amount of time before I ever got the MK2 replacement, but what I got was good up until I opted to purchase a brand new MK3, which also had encoder issues out of the box and the replacement I received is again exhibiting the same encoder issue within the same year unfortunately.

    For me, buying new at least gave me the option of being able to go back to NI and show them the issue and ask for a replacement in good working order. Buying used, you may have to pay for some additional parts/replacement so it may help to keep that in mind when weighing your options.
     
    • Informative Informative x 1
  2. Trond Hindenes

    Trond Hindenes New Member

    Messages:
    2
    After a bit of head-scrathing, I figured that the issue with my keyboard only happens when the mod wheel (the right-most of the two wheels to the left of the keys) is at full zero. So, instead of sending it back and starting a full-on warranty process I simply make sure to have the mod wheel a bit above zero - I've frankly not thought about it at all after I found out.

    As far as I can see my keyboard does _not_ have an encoder issue, but since VST many instruments from NI program the mod wheel to the same function that a mod wheel controls, it's a really weird error. In any case, I just make sure the mod wheel isn't fully at zero and I'm golden.

    I'm sure Native Instruments will get this fixed in a firmware at some point, but in the meantime the bug doesn't bother me. No guarantees tho, I'm almost getting the feeling there's several issues with Komplete Kontrol keyboards so it's difficult to recommend what you should do.
     
    • Informative Informative x 1
  3. Mykhailo VR

    Mykhailo VR New Member

    Messages:
    6
    Thanks for your comments!

    I ended up ordering a new A49 which I just received.
    I have not noticed any issues with knobs, but I do have those phantom signals from the mod wheel - no matter what its position is. The only difference that the middle-around position triggers the signals much more often.
    And it definitely has nothing to do with dust since the item is new.

    So, now my question is for Jeremy - is there a chance to get an item with a not faulty mod wheel at all?

    Even though I'm not sure how critical the issue is in real life (I'm new to midi keyboards), I don't like the idea of having a new device with a bug from the very beginning, especially after so many owners reported the issue.

    I'm going to request a replacement of the keyboard for another one from my store, but I'm wondering what is the chance and how long this game should last until I get a not glitchy device?

    On top of the above, I've also found at least one white key (G3) which has less sensitivity than the others. I.e. when I hit it with the same attack as the keys around, it sends a remarkedly lower level of velocity. Very disappointing...

    P.S. The item has been for about 24 hours at my home after delivery before I turned it on for testing, so no chance for condensate inside.
     
    Last edited: Dec 18, 2020
  4. realmichaud

    realmichaud New Member

    Messages:
    6
    my A61 is doing the same thing with Massive X ....mod changes without being touched.
     
  5. Billy86

    Billy86 NI Product Owner

    Messages:
    73
    Wow. What a journey everyone has had with these hardware issues. I hope you all get to a better place with your units. I was about to buy an A61, but will hold off until NI gets a handle on what is apparently a known issue. Love the VSTs and was looking forward to going with an integrated keyboard.
     
  6. emrecello

    emrecello New Member

    Messages:
    7
    Hey everybody! Another a61 user with the same issue here :/ I got today and I have This problem.
     
  7. emrecello

    emrecello New Member

    Messages:
    7
    Anybody got solutions about the mod wheel cc jumps without touching problem?
     
  8. emrecello

    emrecello New Member

    Messages:
    7
    Hey I also have this lower level G3 and higher level C3.
     
  9. Jeremy @ NI

    Jeremy @ NI Support Team NI Team

    Messages:
    1,339
  10. Mykhailo VR

    Mykhailo VR New Member

    Messages:
    6
    Jeremy, I used this link and have not found anything related directly to the issue. I'm seeing just a general questionnaire about the issues for NI products. And the most relevant option is probably to create a support request. Is that the thing you are suggesting to do?

    Currently, I received a second unit from the store, and it's faulty again. The production date is the 13th of Aug, 2018 for both devices. The Device ID is almost the same (differs in 1 digit). And the store had one more unit but it was even more faulty - one of the knobs was sending the signals constantly.

    So, since I'm inside of the return/replace period, I'm not interested in any kind of requests to support, I just want to get a not faulty device for the money I've paid. And I would really appreciate it if you can advise what I am supposed to do. Just continue replacing them? Trying to find a device with a specific production period (or out of some specific production period)? Or that issue is only resolvable by reaching out to the support?

    I believe your open answer will be really valuable to all the people who are interested in that topic.
    Thanks.
     
  11. emrecello

    emrecello New Member

    Messages:
    7
    Hey Jeremy, I completed the form, sent photos. Nobody contacted me yet. I stil have This problem, and if its a hardware issue than help me to give this product back. Please let me know as soon as possible.
     
  12. JesterMgee

    JesterMgee Well-Known Member

    Messages:
    3,455
    Maybe just keep in mind it is a holiday season and many staff will be on break and not sitting waiting for tickets to come through. Can take a few weeks to clear backlogs during holiday breaks, worst time to expect speedy support.
     
    • Like Like x 1
  13. Jeremy @ NI

    Jeremy @ NI Support Team NI Team

    Messages:
    1,339
    Hey Mykhailo,
    We are getting close to a solution on this issue, but it is still under test at the moment.
    Could you send me your ticket number by direct message ?
     
    • Informative Informative x 1
  14. Jeremy @ NI

    Jeremy @ NI Support Team NI Team

    Messages:
    1,339
    Can you send me your ticket number by private message ?
     
  15. Mykhailo VR

    Mykhailo VR New Member

    Messages:
    6
    Hey Jeremy,
    Thanks for your reply!
    I've sent you a direct message.
    And could you please share, is the solution you have mentioned based on a software/firmware update, or it involves any hardware manipulations?
     
  16. emrecello

    emrecello New Member

    Messages:
    7
    Hey Jeremy, they returned to me but saying “please update your firmware” etc. I already updated when I bought the product. How is the situation, any news?
     
  17. Jeremy @ NI

    Jeremy @ NI Support Team NI Team

    Messages:
    1,339
    I sent you a private message.
     
  18. Chris-01

    Chris-01 New Member

    Messages:
    3
    Leaving my mod wheel untouched I too get spurious midi commands on an A49 bought in Dec 2019. I have the latest firmware. It has only come to light as I'm using a separate fader controller to adjust CC11, CC1 and CC21 for orchestral libraries, and all of a sudden the CC1 gets overridden by an erroneous signal from the mod wheel.

    The screen shot attached shows what happened to CC1 when the A49 was left unattended when I went off to make a coffee, and then write this post. As a temporary solution I thought I might be able to disable the mod wheel in the Controller Editor... But you don't support the A series in the Control Editor, so I can't do that.
    Screenshot 2021-01-16 at 12.39.55.png
    This thread documents this issue in March 2019, I've done one if not two firmware updates since I bought my A49 just over a year ago, how close to a fix are you?
     
  19. Mykhailo VR

    Mykhailo VR New Member

    Messages:
    6
    As a temporary solution, try to set the mod wheel in the edge position - either 0 or 127. My current device does not send any signals in those positions, although the previous one (that I sent for replacement and then got the current one) has been sending them in any position but with a different frequency.
     
    • Informative Informative x 1
  20. Chris-01

    Chris-01 New Member

    Messages:
    3
    Thanks Mykhailo VR, I will give that a go.

    I really like the A49, but this issue and the lack of velocity curves, have put quite a dampener on my NI experience.