1. Hi everyone,

    This forum is now closed for posting. If you require technical support from NI or have a questions about activating your product, please head over to our new Support Community!


    The Support Community is the new location where you can expect to receive assistance and feedback on technical support, sales or installation issues from our Support Agents and other users.

    Please also note, questions about the status of an order should always be directly sent to our Order Support team HERE.

    Best wishes, 
    The NI Team

Ableton and Maschine: Midi Mode Stops Working

Discussion in 'Technical Issues (Archive)' started by Murder the Govt, Oct 8, 2011.

  1. Murder the Govt

    Murder the Govt New Member

    I have seen this issue posted several times around these forums with no acceptable solution given. So, I felt compelled to make an account here to tell you about this, again.

    I am running Maschine 1.7 in Mac OsX Lion. It works 100% of the time in control mode as either a stand-alone application or as a VST inside Ableton 8.25. I have no problems whatsoever with Maschine itself.

    My problem arrises in Midi mode, particularly while controlling Ableton Live. It will work for a random amount of time and then abruptly stop working. Maschine itself will still function in control mode, I just lose control of everything in Ableton. The fact that the Ableton template works initially with 100% functionality and Maschine keeps working afterwards leads me to believe that I have everything set up correctly.

    It is hard for me to ascertain precisely when and why I am losing control of Ableton because I am usually working in Maschine mode for a while, I'll only notice when I switch over to midi mode to adjust something in Live and get no response.

    Oh and also: I have my takeover mode set to pickup but it just does whatever the **** it wants. Meaning, sometimes it works other times I get abrupt spikes in values.
  2. sowari

    sowari Moderator Moderator

    are you using Ableton in 64 Bit Mode?

    do you let your computer go to sleep?

    how have you set up Ableton's MIDI Preferences..... maybe you could do a screenshot?

    have you reported this to tech support.

  3. Murder the Govt

    Murder the Govt New Member

    I am going to assume I am running in 64-bit mode. When I click "Get Info" on Live's file it doesn't give me the option to run in 32-bit mode. For example, when I click Safari's "Get info" I have the option of checking "Run in 32-bit mode" I'm not seeing that for the file Live.app.

    I do. I initially thought that was the problem. I adjusted my power saver settings so that it wouldn't go into sleep mode or even screen saver mode while I was working. This problem has occurred since then though.

    Pic included. Everything seems to be working with these settings... for now.

    Haven't reported to tech support.

    Attached Files:

  4. skatr2

    skatr2 New Member

    I am having similar issues, but I can't get the midi to work from the onset. I recently bought Maschine, downloaded a maschine template you had posted in an earlier thread sowari, and when I load up the ableton scripts I get no control over any tracks. I do see a constant midi signal showing up in the top right corner as if I had been hitting a pad repetedly...but nothing moves around ableton when using maschine.
  5. KC Muff

    KC Muff NI Product Owner

    Hi Mate

    I have given up trying to use Maschine as a controller for live for this exact reason; for no apparent reason control just ceases. I have found that unplugging the USB cable seems to reset, but it is very annoying, and not suitable for any live work.

    I have also had issues with Traktor Pro 2 losing contact with Maschine Control.

    Drivers? ( rhetorical question)
  6. titusraindrops

    titusraindrops New Member

    Add me to the "me too" list.

    Everything works fine for a random short amount of time and then it stops working completely or only partially works to control Ableton. For example, the pad lights still control the scenes that are playing, but the active scene pad stops flashing so you can't tell what is running anymore...

    The only fix I've found is to unplug/replug the USB cable, which obviously sucks.

    Is there any merit to trying to use the MIDI OUT port of the Maschine, rather than the USB MIDI port, to communicate with Live? Has anyone tried that?

    I will soon.
  7. MMI

    MMI New Member

    me too

    Add me to the me too list (at least, I think it's all related):

    Found this thread via google. I am not a maschine user but I *am* using Ableton Live on Lion with Komplete. Changing settings in Guitar Rig, certain complex Kontact patches with rapid note inputs (like from my Impulse's arp) will cause audio to just stop.
  8. macchinista

    macchinista NI Product Owner

    Same here

    Ok, I just started two threads about this same issue. I had not seen this one yet. Sorry about that :eek:

    Just wanted to add my voice to the chorus. This is a serious problem which makes Maschine useless as a MIDI controller. I have emailed customer support about this issue, so far no replies. Would be great to receive an official statement from NI. It's not just with Ableton. I have tried it with Reaktor& MaxMSP and Maschine goes dead after a random amount of time. Midi is still being sent but nothing is received. The bi-directionality breaks down all of a sudden.

    BTW, I am on Mac Snow Leopard 1.6.8
  9. danimalswainger

    danimalswainger New Member

    me too

    this really is a bit a pain of bug, when my 40 quid akai lpd pads work more better for midi control.

    joined thread in hope of fix
  10. Cloudy

    Cloudy Forum Member

    I've had similar issues with Live but other controllers as well, I assumed it was an Ableton issue. Pro Tools 10 and Cubase 5 don't give me any similar issues that I have noticed.
  11. TheStreisandEffect

    TheStreisandEffect Forum Member

    Maschine Freezes / Freezing as a Ableton Midi Controller

    Just confirming the same issue here. Anywhere from 5, 10, 15-30 minutes of using it as a controller for Ableton Live, Maschine will just freeze and quit working. It's done this since day one. Unplugging and replugging and re-selecting the controller will only sometimes fix the problem. Sometimes even restarting the computer will still leave only half of the controllers functions working (maybe some filter maps, no volume maps, no main pads or blue group pads). I've installed and re-installed all the latest drivers/controller editors etc, have zero cracked software, and know this isn't user error. It seems as though once the "corruption" occurs, it sometimes "stays" in Maschine for a while, as in, after it freezes once, maybe just a couple midi knobs i mapped will work but nothing else will, everything else will remain frozen, especially the main pads and blue "directional" group pads. I was originally told this would be fixed in a software/firmware update but it hasn't happened yet. I've talked to at least five other people who have this same problem and now we all have to share APC-40s because our Maschines are useless for live performance which is what I bought it for in my attempt to stay true to the NI brand. I've submitted a ticket so hopefully they will have an answer soon. I even had a friend offer to let me use his Maschine because he heard mine wasn't working, and he's like "the only problem with mine is, it'll freeze up after about 15 minutes", which apparently isn't a big deal to bedroom DJ's but is a show killer for full time producers like myself. I was like, "Thanks, but that's the exact same problem I'm having buddy."

    MacPro 10.6.8
    4 GB RAM
    Ableton Live
    Ableton Live Midi Map for Maschine
  12. macchinista

    macchinista NI Product Owner

    I hope you have better luck than me. I submitted mine last week and nothing yet from NI. Ignoring the problem won't make it go away. We deserve some kind of answer. :angry:
  13. taoyoyo

    taoyoyo NI Product Owner

    Confirming the issue here... seems to be effecting a certain group of OSX users only, have reported it and tried out some tests with NI and Midi control mode is still freezing. Unplugging/replugging the USB cable doesn't seem to help unless it's for a long period of time.

    To be fair to NI they seem to be as much at a loss as to the cause as we are.
  14. macchinista

    macchinista NI Product Owner

    Not encouraging. In any case, this issue is very annoying and needs a resolution quickly. Still have not heard a work from customer support. Not pleased at all.
  15. TheStreisandEffect

    TheStreisandEffect Forum Member

    Make sure you submit a ticket

    Make sure you submit an actual tech support ticket and don't just email them. They contacted me back in about two days and it's a known issue. And yeah, I don't think they know why either. I understand that technology can have bugs but the disheartening thing is that Maschine was specifically billed as a great controller for Ableton and this is a total show stopper. As someone who also composes for video games, in the world of game testing, this would be an A level bug that would most likely prevent a game from being shipped.
  16. ikarys

    ikarys Forum Member


    This is happening for me now.

    I have not touched maschine for a couple of months, and now when I connect it, ableton sends midi to maschine (i can see the lights change, and various tracks flash), however nothing from the maschine side is sent back to ableton.

  17. macchinista

    macchinista NI Product Owner

    Actually, I submitted a proper tech support ticket (got the ticket # and everything), but no response yet. At this point, it does not matter much. It seems like they are clueless on what the problem is :(

    This is old fashioned MIDI, I thought this stuff was pretty well understood. So what's going on with Maschine and OSX MIDI?
  18. Tony Cagnoni

    Tony Cagnoni Forum Member

  19. tkurfurst

    tkurfurst New Member

    Maschine MIDI Control Mode Bug

    I have wasted possibly 20 hours trying to track down the source of the problem ... and then came across your proposed fix and IT WORKED!

    It is important when reinstalling 1.7.2 that you DO NOT install the driver that comes with it (uncheck driver installation).

    And yes NI you should issue a driver update ... 2.4.21 is FLAWED
  20. macchinista

    macchinista NI Product Owner

    @ tony & @ tkurfurst

    Thanks a lot for your input guys. This sounds good. Before I go into all this hanky panky of installing and re-installing the Maschine software as you suggested, could you please verify the following for me? Do the buttons and pad LEDs turn on in response to MIDI IN? This is an option that was added in one of the last updates of the Controller Editor, if I am not mistaken, so I am wondering if it works with the old driver in 1.6.2. Would appreciate your feedback! THANK YOU.