1. Please do not install macOS 10.15 Catalina yet, as Native Instruments software and hardware products are not supported under macOS 10.15 yet. For more info, please go HERE!
    Dismiss Notice

ACPI.sys causing latency

Discussion in 'Technical Issues (Archive)' started by DJMattB241, Feb 9, 2011.

Thread Status:
Not open for further replies.
  1. DJMattB241

    DJMattB241 New Member

    Messages:
    5
    I followed the Windows 7 tuning tips, and in the LatencyMon, ACPI.sys has a number way above 1.0 (right now it's at 1.6, but in testing I've seen it go as high as 2.5)

    The problem is, what do I do about that? ACPI.sys is a system process. I can't just disable it.

    Help? :(
     
  2. tribaljet

    tribaljet NI Product Owner

    Messages:
    187
    Technically you can disable ACPI device, as it is mostly a power savings virtual device that controls how your OS manages power settings. In a laptop you basically lose the battery icon, and can't read the remaining charge, but it's nothing severe to the point of causing damage to the system.
     
  3. andreyrubleff

    andreyrubleff New Member

    Messages:
    4
    How can we disable ACPI in Windows 7?
    Any ideas?
     
  4. tribaljet

    tribaljet NI Product Owner

    Messages:
    187
    Go to Device Manager and disable (not uninstall) ACPI Compliant Control Method Battery.
     
  5. Dj arab

    Dj arab Forum Member

    Messages:
    68
    I had the same issue with a pc running w7 32 bit.I did the same but nothing.I thing that in w7 you can not disable the "ACPI sys for NT" because is not a driver.I was looking for a "workaround " for 3 months.I almost did everything.Finally i bought a Mac.
     
  6. bluesticky

    bluesticky Forum Member

    Messages:
    68
    Disabling acpi at boot rendered my Vista laptop unbootable. Repair wouldn't fix it. Had to completely reinstall the OS to get it back up.

    bluesticky
     
  7. tribaljet

    tribaljet NI Product Owner

    Messages:
    187
    I'm sorry that you had to reinstall your OS, but are you sure you disabled the right device? There are several ACPI devices on different categories.

    EDIT: Are you using the less problematic driver version?
     
    Last edited: Feb 26, 2011
  8. bluesticky

    bluesticky Forum Member

    Messages:
    68
    Hi there,

    I should have been more specific. I deleted the registry key that starts acpi at boot. I have pretty much given up on this laptop. It isn't going to work. After a year of trying I am done. I've posted it for sale in a couple of spots in hopes I can get something for it. It is great, it seems, at everything except when trying to use an external soundcard. For now my digital dj'ing experience is over. Back to vinyl. I'll check this stuff out once it matures a bit I guess. Thanks to all who have offered help.

    bluesticky
     
  9. tribaljet

    tribaljet NI Product Owner

    Messages:
    187
    I'm sorry for all the trouble you had, but you should never have done that in the first place, only a specific part of ACPI, namely the battery management should be disabled.

    And since you didn't post your system specs, audio hardware used, it makes things a bit difficult in order to help you.

    Audio interfaces can be tricky, no matter what the price tier, and there isn't exactly a rule of thumb when it comes to solving issues.

    Also, things run a bit smoother on Windows 7 than on Vista, and much more than on legacy XP.

    Anyway, you shouldn't give up so easily, but good luck on any choices you might take on the future.
     
  10. cosmic tune

    cosmic tune New Member

    Messages:
    3
    found solution

    hey,

    i had the same problem with the acpi.sys and just could fix it on my computer.

    i already used the dpc latency checker with my other audio-interface ua-25ex before and found out that the network-adapter caused high latency - so i disabled it and it worked. some days ago i bought the ni audio 2 and with this audio-interface there was again high latency altough the network-adapter was still disabled in the device manager.
    here is what i found out:
    if i just disable either the ´ACPI Compliant Control Method Battery´ or the ´network-adapter´ (whatever you have in it - for example realtek wireless LAN,..) the the latency is still very high from time to time, but if you disable both of them then (at least on my computer) the problem with the latency is fixed.

    i´m watching the dpc latency checker right now and since i began to write this message the absoltue maximum was 333 :D

    greets from austria
     
  11. DJMattB241

    DJMattB241 New Member

    Messages:
    5
    None of the ACPI stuff in my Device Manager is able to be disabled. The disable button is greyed out. My random internet searches seem to say that it is not able to be disabled in Windows 7.

    Also, disabling ACPI is not an option in my BIOS (yes, I updated to the most recent BIOS version).

    Disabling wifi helps, of course. But about once every hour or so, everything just stops dead for about three seconds, and then picks back up again.
     
  12. tribaljet

    tribaljet NI Product Owner

    Messages:
    187
    While the Battery alone item cannot be disabled or uninstalled, ACPI Compliant Control Battery Method can indeed be both disabled and uninstalled.
    Use 2.0.15.7 driver, use cabled networking if possible, disable the other network device if not needed (wireless affects more than wired). Configure power settings as it's recommended on NI's Windows 7 optimization guide, and in case you have a Nvidia GPU, change powermizer settings as well.
     
  13. cosmic tune

    cosmic tune New Member

    Messages:
    3
    still clicks

    @tribaljet:

    now my latency seems to be at a good level BUT there are
    still clicks from time to time - have you got a clue what this
    might be?

    + what to do about the horrible clicks when strating up and
    shutting down the computer?

    thanks in advance,
    greets,
    andreas
     
  14. tribaljet

    tribaljet NI Product Owner

    Messages:
    187
    I always recommend people to go through NI's Windows 7 Optimization Guide: http://www.native-instruments.com/knowledge/questions/847/Windows+7+Tuning+Tips+for+audio+processing
    It really goes through a lot of important tweaks, settings and procedures that optimize a computer to perform optimally for all audio related tasks.

    The way DACs work makes then turn on by themselves after the computer has started, making clicking or popping sounds, that's normal.

    About having issues, clicking, crackle, dropouts, etc, you can increase your buffersize settings and that will reduce, if not completely eliminate all issues. Try different settings to see which works best for you while maintaining a quick response to your actions, it's all about compromise. And just like the control panel says, for playback only use, buffersize can be set to the highest values as latency isn't a concern on those cases.
     
  15. 3gp

    3gp New Member

    Messages:
    5
    hey guys,

    i had the same problem like u all and i fixed it ths way. first i found out that my graphic card is causing some real latency drop outs so i started disbling the graphic card during the session. it was better after that. after some time i found out to disable the ACPI control method battery and it was really better after that, the only problem left was that from time to time the sound quality was for like 4 seconds really bad. after that i disabled all entries under network devices. after i disabled that, all problems were gone and i had like 0 drop outs! mb it helps u.
     
  16. DJMattB241

    DJMattB241 New Member

    Messages:
    5
    I don't have anything in my Device Manager labeled ACPI control method battery.
    I have Windows 7. I'm not sure if that's the difference.
     
  17. cosmic tune

    cosmic tune New Member

    Messages:
    3
    @ djmattb241:

    if you have a laptop you should have it - i´ve also windows 7 on
    my laptop and the device you are looking for has a battery
    symbol with some sub-devices also with that battery symbol.
    one of these is the one you are looking for - right click on them - it
    should be possible to disable one of them.
    in case you don´t have a laptop i don´t know where to find the ACPI
    you are looking for.

    greets from austria,
    andreas
     
  18. tribaljet

    tribaljet NI Product Owner

    Messages:
    187
    The first thing people need to do in order to get some help, is to post the #"$% system specs. No one can guess what specific hardware you have ;)
     
  19. DJMattB241

    DJMattB241 New Member

    Messages:
    5
    Okay, massive update.
    First of all, duh, I found the ACPI thing. I wasn't looking under Battery. I disabled that, and now LatencyMon shows the highest execution time as 0.15, which is much better than the 2.8 that ACPI was giving.

    Woo! Thanks! :D

    However, my laptop is still doing it. LatencyMon doesn't seem to show anything when the glitch occurs It's seriously about a 2-3 second freeze where the audio and traktor both freeze. The computer doesn't freeze, just traktor and the audio stream.

    I snagged a screenshot of DPC Latency Checker catching it.
    Looks like this:
    http://i4.photobucket.com/albums/y149/DJMattB241/Capture-1.png

    Anyway, here's all the stuff I can think of about my computer:
    Samsung laptop
    i5 processor, 2.67Ghz
    4Gb RAM
    Win 7 x64
    Audio 2 DJ (driver 2.0.15.007)
    Traktor Pro
    VCI-100 midi controller
    ACPI and WiFi disabled.

    Interesting side-note: If I just run Latency Checker all day without having Traktor playing, it doesn't spike like that. It doesn't even go into the yellow. Does this mean the Audio 2 DJ is causing it?

    Also, when playing, some of the buttons on my midi controller make a pop noise over the speakers. Like, there's a button that changes some of the controls from play/pause to cue buttons. Pressing that button makes an audible pop sound over the speakers, just for a second. I'm less concerned about this than I am the huge audio drop out issue.
     
  20. 3gp

    3gp New Member

    Messages:
    5
    like i said before, deactivate ur graphic card + network device and it should be fixd!
     
Thread Status:
Not open for further replies.