Anyone using Z2 with Sierra? Z2 is not working with Traktor after Upgrade

Discussion in 'KONTROL Z2' started by thirdletterc, Oct 24, 2016.

  1. thirdletterc

    thirdletterc New Member

    Messages:
    10
    If anyone has any other suggestions/tips that is running Sierra with the Z2 please let me know. I've tried every troubleshoot on Ni's Site. Z2 will not send any midi to Traktor. Faders, knobs nor any buttons work. This is a new Mac. All firmware is updated. Z2 still works properly with old mac running 2.8. So i don't believe it's a mixer issue.
     

    Attached Files:

  2. Karlos Santos

    Karlos Santos Rocket Man Moderator

    Messages:
    12,056
    Please file this with Technical Support - I haven't seen that 'INVALID' warning before.
    I have 2 Macs on Sierra working perfectly with the Z2.

    Karlos
     
  3. Irv_Tf

    Irv_Tf NI Product Owner

    Messages:
    559
    The answer for this might be in the "Audio MIDI Setup" app in the /Applications/Utilities/ folder. I don't know exactly what to do but compare the app settings on both computers. Good luck.
     
    • Like Like x 1
  4. Mattia Voci

    Mattia Voci New Member

    Messages:
    10
    Now, I have the same problem.
    How did you solve it?
    Video of my problem:
     
    • Like Like x 1
  5. deejayollie

    deejayollie NI Product Owner

    Messages:
    123
    Had the same issue... How i solved this problem:

    1. Open Controller Editor first and it will usually seem like its freezing for about 10-15 min...
    2. Once Controller Editor is fully open... Try to press the connect button on the top left to your Z2 mixer...
    3. While Controller Editor is still open, Make sure you exit and close Traktor...
    4. Once Traktor is closed. Quit Controller Editor then open up Traktor again...
    5. At this point your Mac should recognize your Z2... if not yet, you may have to repeat steps 1-4 one more time...

    Hope this helps...

    Oz
     
    • Like Like x 1
  6. M_Gekks

    M_Gekks New Member

    Messages:
    1
    I'm having this exact same problem, been chatting with support and they told me they've never heard of this issue (so I thought it was just my Mac, until I just saw your post), I also have the brand new Mac running on IOS High sierra, did the control editor sort out this issue ?, even if this is the case and it gets it to work this must be a software saving issue I think ?
     
  7. soulguru

    soulguru NI Product Owner

    Messages:
    312
    Try a re-install, worked for me.