Battery Loading Issue

Discussion in 'BATTERY' started by sidge2222, Oct 5, 2018.

  1. sidge2222

    sidge2222 New Member

    Messages:
    1
    Hiya guys, apologies if this sounds stupid, I am really new to this.

    I have looked online but I can't seem to find this specific issue. Basically, all instruments will load perfectly in Komplete Kontrol, except for battery. It is physically there in the komplete kontrol software and also on the hardware screens but when I try to load them I am getting the 'Loading Issue, Could not load Plug-in' error.

    Thing is, the previews work, so I get sound when I click on any of the kits, however if I double click to load the instrument I then get the error message. Unsure as to why this is only happening to Battery and nothing else?

    I have a Komplete Kontrol S49. I have reinstalled everything, I didn't move any of the files during installation etc.

    Thanks in advance :)
     
  2. Michel Blok

    Michel Blok New Member

    Messages:
    1
    I have the same issue.
    Did you solve it yet?
     
  3. pawned

    pawned New Member

    Messages:
    6
    I've got the same problem. I ccontacted NI support, but they don't respond.
     
  4. aboxclaude

    aboxclaude NI Product Owner

    Messages:
    103
    Mine crashes on open nearly every time and takes out my DAW (Ableton) in the process. I had been loading the kits into Kontakt until I opened it yesterday and Kontakt crashed too. WTF is going on here? I wish they, NI, would just allow us to downgrade Battery until they fix this. It's messed up my entire live situation, forcing me to use a different vsti with my samples. Seriously?
     
  5. pawned

    pawned New Member

    Messages:
    6
    NATIVE INSTRUMENTS Customer Service ( support@nativeinstruments.zendesk.com ) send me a reply.

    The reply contains no solutions, instead you are told to download and run an information gathering tool on your PC and send the output (a zip file) back to NI, as an attached file.

    Here are the links from the email, rewritten, because the forum wont accept them, it thinks my reply is spam:

    Windows: bit DOT ly SLASH 2EndsXj
    MAC: bit DOT ly SLASH 2CPEIk1

    I must say that I feel this is a time waster, because my install of the NI software is a standard install, i.e. NI should get the same resutls if they install and test their own software on an up-to-date windows 10.
     
    Last edited: Nov 8, 2018
  6. aboxclaude

    aboxclaude NI Product Owner

    Messages:
    103
    I agree. I'm running Win 7 64 and have NEVER had a problem with my stuff before. It's just this latest update of Battery that has caused the trouble. What I may do.. is rename the battery library folder so it doesn't scan it, and use only the kits I've created, just to see if this works.

    For now, I loaded my kits using Drum Racks in Ableton, sound by sound until I made the kit I use for my live show. This is about 128 loops and hits, and it worked beautifully for an entire 6 hour day. So I may start using DR to create my kits from now on.

    Truth be told, the only reason I was using Battery was to open kits from my MPC500, so as to be able to interchange the sequences from hardware to software and back... so that does suck. But Kontakt 4 does this too. what pisses me off is that I spent good money on Battery.
     
  7. aboxclaude

    aboxclaude NI Product Owner

    Messages:
    103
    Here's what I did, and Battery 4 loads perfectly every time. But note, you may not like the solution. It's some sort of problem with the database. What I did was rename the folder where the Battery4 library was and then Battery opened just fine. I was able to load my own kits (which are the ones I care about the most anyway), and it worked like a champ. Saving these older kits as Battery 4 kits also worked flawlessly. These new kits were then scanned by Battery as 'user kits' and they load up just fine. In other words, the factory library has a problem. Where? Hell if I know.

    What I do know is that my own Battery 3 kits work just fine, and my own created kits also work just fine. I tried loading random kits from the factory and BOOM... It crashes! Regardless of kit from that folder.

    Now.. as an experiment I loaded in samples from that folder into cells by dragging and dropping them in, randomly. They work just fine.

    What I may do is locate the database file and delete it. Then I will have Battery rescan it. Maybe that will do it? Or perhaps reinstall the library?

    To be honest, I once went through the entire Battery 3 library and deleted every kit I did not see myself ever using. I then created kits from the ones I liked and added my own collection over the years, so for me, my Library is the factory library. So long as they open I could care less about the other ones.

    /// UPDATE ///

    I deleted the db file from my computer and restarted Battery. It scanned for about two @&$#@ hours and thus far found 3,000 files... When it was done, I opened a kit and it worked. But when I browsed the factory library... crash. So I'm not sure what to do to help others out. All I can say is that avoiding the factory library and making yours the default works just fine.

    For the time being, this is my solution. I have music to make, damn it. :)
     
    Last edited: Nov 9, 2018
  8. pawned

    pawned New Member

    Messages:
    6
    Here is the reply from NI support:

    >After checking your account, it shows you don't own Battery 4. Some Expansions have
    >Battery kits and you would be able to open them if you had Battery. Komplete 12 SELECT
    >doesn't include it. Sorry for noticing it only now.

    So it looks like it is yet another attempt to talk you into buying more of their wares.
    They did not notice that it wasn't part of the product :)
    Did they notice that many of their other presets don't not work either ?
    Did they notice that their software only runs in a resolution suitable for monitors that are at least 15 years old ?
    Did NI notice that they removed the chip that allows the Komplete Kontrol mkk2 to be costumized, like you could with the first version AND did NI make sure to change their marketing to inform the customers that the Mk2 is not costumizable like the Mk1 is?

    I will not buy anymore products from NI and I will recommend to everyone not to buy NI products.
     
    • Informative Informative x 1
  9. Moryc

    Moryc New Member

    Messages:
    1
    I have the same issue
    "Loading issue. Could not load the plug-in."
    Reinstall and rescan Library do nothing :/
    (KK S88, MacOS)
    Some ideas?
     
  10. wilsonhart

    wilsonhart New Member

    Messages:
    3
    Battery 4.1.6 (R27)
    Live 9.7.7

    I've experienced this issue intermittently over the past year..

    My workaround is as follows:

    From Battery VST
    Save As... (New Battery Kit)

    From Ableton,
    Save.

    Once the Kit is saved, AND the session is saved with the New Kit loaded in the VST. I am able to get back into my file folders and load samples as normal.. I hope this helps.
     
  11. Gus Wilson

    Gus Wilson New Member

    Messages:
    6
    Is there a solution out the to load battery kits....samples plays but wont load....do you need the keyboard connected to use?
     
  12. Gus Wilson

    Gus Wilson New Member

    Messages:
    6