BCD3000 + Traktor not working on new laptop

Discussion in 'TRAKTOR 3' started by mattyg44, Oct 6, 2009.

Thread Status:
Not open for further replies.
  1. mattyg44

    mattyg44 Forum Member

    Messages:
    30
    Have been trying to get a BCD3000 running with Traktor 3 on a new laptop since my old one I had been running on crashed. All I know of the old laptop was that it was an Advent with Pentium Dual Core processor, running VISTA 32-bit.

    Had this laptop for over 2 years and never had any problem running the BCD3000 and Traktor on it, which is why I am so frustrated and confused as to why the new laptop (Acer Aspire 5536, AMD Athlon 64 X 2, QL 64 (2.1GHz), 4GB Memory, running VISTA 32-bit) refuses to work properly.

    The problem is that after installing the BCD3000 driver (have tried installing both from CD and from the supposed Vista driver from Behinger website, aswell as installing them in XP compatible mode) and installing Traktor (same problem with both LE and full versions + updates from the NI service centre); the BCD3000 controls will only work with Audio Setup > Soundcard > Audio Device set to the laptop's inbuilt RealTek speakers. Set up like this all the BCd3000 controls work in conjunction with onscreen controls and sound comes through the laptop speakers, but when the audio device is set to BCD3000 ASIO nothing works - crossfaders etc, dont move on screen when moved on the controller and although songs can still be loaded into the decks, it isnt even possible to play them by clicking the play button on the screen (it just changes from highlighted on/off, but doesn't play).

    I am aware that when Audio Device is set to BCD3000 that Output Routing channels need to be set to 3 & 4 for monitoring and 1 & 2 for master, and that the BCD3000 box in MIDI Interface also needs to be selected.

    I have searched the internet for solutions and tried every one I can find and nothing works. From my limited knowledge of computers and what I have picked up reading other peoples posts I think the problem might lie in the ASIO driver? I have noticed that when I turn on the BCD3000 and the little icon appears for it in the bottom right taskbar, it only makes 1 bur-dum sound, whereas on my old laptop is would make that same bur-dum sound twice... If this is likely to be the problem, how would I go about finding out whether the ASIO is working properly or not, and go about fixing it? Or is there anything else I could try? I am stuck with this laptop now and don't really fancy shelling out for new software or a controller so what other options do I have? (Buying a new soundcard? Is there any guarantee this would work?)

    Any help anyone can offer me is gratefully recieved, I feel like I'm going to need a Phd in Computer Science to figure this out on my own :-s
     
  2. mattyg44

    mattyg44 Forum Member

    Messages:
    30
    Please can anyone offer me ANY advice with this, its driving me up the wall! Can't understand why everything ran prefectly on the old laptop, but refuses to work on this one, which is running EXACTLY the same Operating System as far as I can see...

    Could something inside the BCD3000 have been changed when I used it with the old laptop? So that it has been made incompatible with this new one?

    What other options do I have if I can't get it working? I don't really understand what the ASIO driver is or where it is located, so would upgrading to Traktor Pro solve the problem? Or buying an external soundcard?

    Please guys, any ideas I can follow up are really appreciated. I am losing the will to live with this, have rebooted to factory settings 6 times now and seriously considering finding someone to ask if they want to swap this poxy laptop with theirs!
     
  3. Hippie

    Hippie Forum Member

    Messages:
    135
    I think I saw a solution to your problem somewhere recently, I thought it was this thread actually hence I didn't reply sooner.
    I'll try and find the thread I saw for you later, they said they had to manually update the driver iirc.

    You don't really need all these steps and reboots but it's good practice when you have driver issues :
    As it's a new PC, I take it there's no exclamation marks or devices waiting to be installed in device manager and the PC is upto date regarding windows update and manufacturers drivers as they would need to be addressed first.

    In device manager you should have 2 lines relating to the BCD.
    Download and extract the latest Behringer drivers.
    Disconnect the BCD and uninstall the drivers you're using.
    Reboot
    Check in device manager to see if the BCD is still lingering and uninstall again if needed and reboot again if you had to uninstall it again.
    Reinstall as per Behringer instructions.
    Reboot
    Check the dates of the newly installed drivers in device manager to make sure they match the latest Behringer drivers and check if both drivers have installed.
    If the dates don't match up, update the drivers maually by clicking update driver and pointing the driver update wizard to the loaction you extracted the latest Behringer driver.
    Reboot
    Set the Behringer control panel
    Cross your fingers and play :)
     
  4. lali_puna

    lali_puna New Member

    Messages:
    6
    well, thanks for this tread, I got the same notebook, tryed the same things, even the answer from hippie, but it still won't work =(

    Any suggestions?
     
  5. mikesilence

    mikesilence NI Product Owner

    Messages:
    1,088
    Set the power settings of Vista from "balanced" to "full performance" and reinstall the BCD driver again. Then it should work fine with BCD3000 ASIO driver.
     
  6. mattyg44

    mattyg44 Forum Member

    Messages:
    30
    never did get it working, after 2 weeks of ripping my hair out every night trying to get it working i took the laptop back to where i brought it from, explained the problem and got it exchanged for a new one which the bcd3000 and traktor work fine on!

    i think the problem was centred around the AMD processor since i have tried to use the bcd3000 + traktor on 4 pcs now, 3 of which were intel processors and 1 AMD, and the AMD was the only one it wouldnt work on.....

    as far as i can see if you are stuck with that laptop you are screwed, you can change settings, uninstall and reinstall drivers as many times as you like but there is no way you are going to get it to work. sorry. my advice if the latop is new is to return it immediately, explain it wont work with the piece of software that you brought it to run on, that that was the main reason you brought it so it is useless to you (it is not 'fit for purpose'), that there was no way of knowing prior to buying it that it wouldnt work. if it is inside the 28 days from when you brought the laptop i believe they are legally obilged to exchange it for you, take your bcd3000 and traktor software and make sure you test it on the exchange pc before you leave the store with it!

    either way stop wasting your time trying to get it working on that latop, it wont. its a ridiculous situation and an absolute disgrace that neither NI, berhinger or acer/AMD fore-warn of the problem but there you go thats the way the world works!

    good luck finding a new laptop to run on, or a new software/midi-controller setup to use!
     
  7. lali_puna

    lali_puna New Member

    Messages:
    6
    @mikesilence:
    It won't =(
    But it's good to know that option for better performance anyway =)

    @mattyg44:

    Well, now after 20 hours of testing aroud, I did as you told me.

    I got myself a MSi CX600 - T4343W7P (Intel Duo T4300, 4GB Memory, Windows 7)

    And HEUREKA, it works....for 2 or 4 Seconds after I select the BCD3000 Driver in Traktor.
    =(((

    Well, any Suggestions for that Problem, except from kicking the **** ****ing Behringer out of the window?

    I got the feeling it has something to do with the Realtek High Definiotion Audio Driver, which was on my old Acer Laptop, too.

    Please help me.
    ---
    I can not explain what I did, but it works =)

    Well the cause might be, Behringer sucks!
     
  8. mattyg44

    mattyg44 Forum Member

    Messages:
    30
    mate, what did i say?

    TAKE YOUR BCD3000 + TRAKTOR TO THE STORE WITH YOU AND MAKE SURE THEY LET YOU TEST IT ON THE DISPLAY MODEL OF THE LAPTOP YOU ARE BUYING BEFORE YOU LEAVE THE STORE WITH A BRAND ONE BOXED ONE!

    Why the hell did you go for one with Windows 7? As it is a brand one operating system, id say that is more likely to be the problem than the Realtek speakers, which are standard on most laptops as far as i can see...

    I can't help you with Windows 7 as never used it. Hopefully if you have to take it back again, they will let you exchange it for a second time, don't know how much hope Id hold out for that though... If thery are kind enough to, MAKE SURE YOU TRY IT OUT BEFORE YOU TAKE IT AWAY!

    Let me know how you get on.
     
  9. mikesilence

    mikesilence NI Product Owner

    Messages:
    1,088
    BCD3000 drivers are not for Windows 7...
     
  10. lali_puna

    lali_puna New Member

    Messages:
    6
    well, well, well, except from trying virtual pc, I tried everything again and now I give up until Behringer pays some attention to it's customers until then I go out and tell all my friends and everyone I met:

    Beware of Behringer!
     
  11. lali_puna

    lali_puna New Member

    Messages:
    6
    so funny, after I learned a lot of tuning tricks, I gave my old Asus EEE PC S101 a try and it works perfectly =)
     
  12. stevenlk

    stevenlk New Member

    Messages:
    12
  13. mikesilence

    mikesilence NI Product Owner

    Messages:
    1,088
    BCD3000 drivers run also on Windows 7 now, but only 32bit. And it is possible to install the driver in XP compatibility mode.
     
  14. stevenlk

    stevenlk New Member

    Messages:
    12
    so it does? i tried installing the BCD 3k driver 1.2.00 and it doesnt function. im using it on Native UInstrument's Traktor 3 LE . my desktop is XP SP2 and the bcd works just fine. also my laptop is a win7 home premium 32-bit OS . i tried installing it as ADMIN, also Compatiblitiy install as Windows XP Service Pack 2, i also have the power switched to High Performance. it did it over and over and then it'll work and play and light up for 5 seconds then the controller doesnt work after that.
     
  15. mikesilence

    mikesilence NI Product Owner

    Messages:
    1,088
    Traktor 3LE may not work properly under Windows 7...
     
  16. stevenlk

    stevenlk New Member

    Messages:
    12
    so how can i test that. i did switch my soundcard setting to Realtec and it plays and works completely fine. when i switch to bcd3k asio/ asio it doesnt work and the controller doesnt work for any settings. what program does work for win 7 that bcd3k hooks up to?
     
  17. mikesilence

    mikesilence NI Product Owner

    Messages:
    1,088
    Traktor PRO
     
  18. stevenlk

    stevenlk New Member

    Messages:
    12
    so if i upgrade basically, you're saying it'll work completely fine?
     
  19. mikesilence

    mikesilence NI Product Owner

    Messages:
    1,088
  20. stevenlk

    stevenlk New Member

    Messages:
    12
    alright cool, it works. thanks a bunch for all the help, i apprciate it alot man, but it seems bcd3k doesnt have the buttons ont he remote for everything. 20x's more mouse work.
     
Thread Status:
Not open for further replies.