1. IMPORTANT:
    We launched a new online community and this space is now closed. This community will be available as a read-only resources until further notice.
    JOIN US HERE
NOTICE:

Our Traktor Pro Public Beta is available again in our new online community. Join us if you want to try new features.

MORE INFO

Beginner Tutorial: How to connect your S2/S4 to Speakers and Headphones

Discussion in 'KONTROL S2 / KONTROL S3 / KONTROL S4' started by tmccoy, Jan 6, 2013.

  1. mr smashy pants

    mr smashy pants New Member

    Messages:
    1
    I did it this way and it works fine. I find if its anything other than Direct or Pure Direct, there is a delay in the sound also.
    My only concern is that in these modes the audio coming out of the speakers is fairly low and I have to crank the Main Level knob on the S2 and the volume on my receiver to get a good loud sound.

    As an example, I watch movies and TV comfortably through the receiver at a receiver volume level of about -40ish DB.
    Audio through FM, airplay, or an auxiliary cable directly to the receiver is similar.
    Music howevever I like to listen to it loud, and around -25 is plenty loud. Enough to annoy the neighbours.
    To get the same volume from my Kontrol S2 to my Pioneer VSX-1020K I have to set my S2 Main Level to around 3/4 full and the receiver volume to -10ish! And even with this, the bass isn't the greatest, so I usually have to have the lows set to more than half on most tracks.

    Its not SOOO bad, but sometimes when I mess around with my decks late at night and forget to change the volume, and turn on the TV first thing in the morning, its not such a nice reminder that I had forgot to turn the volume down.

    I just signed up cuz this has been bugging me, and even though I would say its more of receiver specific question, I figured I'd try and see if anyone here knew.


    I''ve tried messing around with manual EQ settings and such through the receiver, but nothing quite fixes the gain.

    Hope you can help
     
  2. tmccoy

    tmccoy Forum Member

    Messages:
    2,005
    What is the main level and headroom setting? Make sure the Main Level knob in Traktor (which is separate to your S2 Main Volume knob) is set to 2 o'clock (double click to reset it, or even increase it a little). Remember that Traktor uses -6dB by default as headroom - which means when Traktor is indicating "red" it is still 6dB away from clipping.

    If you reduce the headroom to say -3dB and make sure your levels are filling the VU Meters, then you'll probably find a little less difference to other inputs. I have to admit - I've noticed the same difference in levels, and there's no risk of damage - it's just that the S2 is overall slightly lower in output as there are far more level management options - where as the TV and DVD player will be using a maximum level.
     
  3. djnoob

    djnoob New Member

    Messages:
    3
    IT'S ALIVEEEEEE!!!!!!!!!!!!
    I got it to work now. I believe I had not correctly assigned the master outputs in the S2.

    Thank you very much for your help. You're a star!!!
     
  4. jondaze

    jondaze New Member

    Messages:
    1
    Thanks for the info v helpful in setting this up. Hoping you can help me with a last issue. When using the s4 with 2 external sources in my case technics 1210 I can not use the mic input otherwise deck d won't work. Is there a work around. I have an audio 8 laying around that I could maybe use for mic inputs. Would this be possible?
     
  5. tmccoy

    tmccoy Forum Member

    Messages:
    2,005
    You are correct - at least on the s4 Mk1, the mic input takes over the Deck D line input and they cannot be used together.

    If you use the a8, you'll need to route all of your audio inputs and outputs through it, but there is enough for everything.
     
  6. livramento67

    livramento67 New Member

    Messages:
    2
    hi guys I have 2 krk monitors connected to my s2,but I would like to connect a sub also(not a krk they are to expencive) can anyone tell me if it is possible and how to do it!!! will appreciate your help !!!! PEACE
     
  7. makar1

    makar1 Forum Member

    Messages:
    3,343
    The S2 has two sets of outputs. Use one for the KRKs, and the other for the sub.
     
  8. tmccoy

    tmccoy Forum Member

    Messages:
    2,005
    Depending on your setup, as suggested by makar1, you can use the free set of RCA or 1/4" S4 output connections to feed the sub, or daisy chain the monitors from the sub - but this is entirely dependant on the sub you are using.

    For example, I am using a higher end Funktion One MB112A sub that has two XLR inputs (one each for Left and Right) and two XLR outputs (again, one each for Left and Right). So I use two 1/4" TRS Male to XLR Male cables from my S4 to my sub, and then two XLR Female Cable to XLR Male cables from my sub to each of my Left and Right M-Audio BX5 D2 Monitors.
     
  9. obiwankabrodie

    obiwankabrodie New Member

    Messages:
    1
    Hi there, I am getting really frustrated with my computer and traktor kontrol s4 mk2. No matter what I do, I can not get traktor to play the cued decks through headphones. They always go through my computer speakers. It seems like the only thing it will let me use in the setup is the computer card, and not the actual sound card. This may be a silly question, but do I need speakers hooked up to the main outputs in order for the built in soundcard to be picked up, or should I just be able to play it through my laptop speakers and have cues coming from the front headphone output on the kontrol?
    The first two are screenshots when I try to connect to the controller, the second two are when I use my laptop speakers.
     

    Attached Files:

    • Capture.JPG
      Capture.JPG
      File size:
      61.9 KB
      Views:
      726
    • d.JPG
      d.JPG
      File size:
      49.7 KB
      Views:
      806
    • e.JPG
      e.JPG
      File size:
      58.5 KB
      Views:
      694
    • f.JPG
      f.JPG
      File size:
      52.3 KB
      Views:
      730
  10. tmccoy

    tmccoy Forum Member

    Messages:
    2,005
    It almost looks like the S4 isn't being properly initialized, as that 0ms latency looks odd. I would suggest unplugging the S4 and reinstalling Traktor and the S4 driver and trying again.

    Speakers do not need to be connected to allow you to select the proper output routing. Once you get the S4 audio driver working, both speakers and headphones need to be connected to the S4 directly to use both the Main and Monitor outputs.
     
  11. tmccoy

    tmccoy Forum Member

    Messages:
    2,005
    Last edited: Mar 29, 2014
  12. burtdj

    burtdj New Member

    Messages:
    5
    I have the same question, and I wanna also add the MASCHINE to the KA6, but I have no idea how routing and setup the S4
    Any idea?
    Thanks a lot
     
  13. lachie113

    lachie113 New Member

    Messages:
    6
    Hey guys,

    I have come across a problem. Decided last night to connect the S4 to my LG CM9370 XBOOM sysem which I thought was a great idea considering how loud and clear it is. Only problem is there was a half or 1 second delay between the song through the speakers and the headphones. This HIFI system does this through my coimputer also. Is there a way of calibrating the speakers through the Software? as I would love for it to all work properly for next time do it

    Any help would be greatly appreciated
    THANKS!!!!
     
  14. tmccoy

    tmccoy Forum Member

    Messages:
    2,005
    Most Home Theater amps introduce a processing delay as they turn stereo input into multi-speaker or enhanced output.

    Look in the manual of the HiFi system to see if there is a way to disable all audio processing or to put it in a simple Stereo output mode.

    Unfortunately a lot of consumer hardware behaves this way and there isn't a good way around it.
     
  15. Tode Dragos

    Tode Dragos New Member

    Messages:
    6
    I've been browsing around for quite a while now trying to figure this out but does anyone know how / if it is possible to disable the filter knobs from automatically turning on, for a Traktor S2 MK2 ?I made the mapping in control manager like this: when i press the knob the filter will change ON/OFF and when i move it will simply move the filter in which direction i want (The override factory map option is also checked. i made a duplicate .tsi, disabled the default one.etc.). The problem is that the filter will automatically turn on when i'll make any change to it. I really want to make this happen. Please help me :D.
    Sorry for my english.
     
  16. Alonso Obregon

    Alonso Obregon New Member

    Messages:
    1
    Hey Guys. I'm knew to this.

    Recently bought a Traktor Kontrol S4 mk2. I've tried to set up speakers to it. But I can hear all through my headphones only. I can hear the first song. And hear the second one too. I've done everything and tried everything. Have RCA (red and white) plugged in the MAIN OUT and the speakers. But still will listen everything in my headphones.

    In preferences. The monitor is plugged to MONITOR LEFT(3) AND MONITOR RIGHT (4)
    In Output master. it is plugged to 1: master left and 2: master right

    If anyone knows what am I doing wrong. Please help.
     
  17. tmccoy

    tmccoy Forum Member

    Messages:
    2,005
    Adjust the CUE MIX knob on the front of the S2 - as this controls if you only hear the CUE Monitor channel or the Main.
     
  18. Paul_Batman

    Paul_Batman New Member

    Messages:
    10
    I am having an absolute nightmare! I've just bought the S4 mk2 and installed it all with the traktor pro 2 etc etc

    Right i have all the software set up, tracks and what not when i click play nothing happens with the track, and the audio has a circle with a line through it, I click that and it brings up setting box and says my traktor isn't connected but i can clearly see it changing stuff on the software on my laptop via the controller, i fixed or not so fixed this by selecting the Realtek device aka laptop driver, This is obviously no good as i can't use the headphones this way and means im running the phono to jack to my laptop.

    I've bought Phono to Phono heavy duty one too from maplins but even after plugging them into the back of the S4 it says "Audio Device" not connected, its really doing my head in as ive uninstalled and reinstalled and been here four hours lol, tried following the steps on here to no avail.

    my external speakers aint flash its just a Logitech 5.1 but worked fine on my old Pioneer Ergo, laptop, phone, tablet, ipod etc etc it has its own power and guess its internally amplified for the sub.

    any help would be greatly appreciated!
     

    Attached Files:

  19. tmccoy

    tmccoy Forum Member

    Messages:
    2,005
    Completely unplug the S2 from USB and Power adapter. Uninstall the drivers. Reinstall the S2 drivers and Traktor.
     
  20. tmccoy

    tmccoy Forum Member

    Messages:
    2,005
    Obviously I meant the S4 Mk2 driver :)