1. IMPORTANT:
    We launched a new online community and this space is now closed. This community will be available as a read-only resources until further notice.
    JOIN US HERE
NOTICE:

Our Traktor Pro Public Beta is available again in our new online community. Join us if you want to try new features.

MORE INFO

New Browser Flickering

Discussion in 'Bug Reports' started by humphrai_Tf, Jul 13, 2021.

  1. humphrai_Tf

    humphrai_Tf NI Product Owner

    Messages:
    227
    (I dup'ed this due to some user referring me to here)
    I'm a very long term (since ~2003) TPro user.... wedding DJ and with huge collection (170k).... and was beta testing TPro in the group for long.

    Now, with the new 3.5, the browser flickering of Traktor got worse then on 3.4 and before. Up until 3.4 flickering this way was only happening when I have the Track Collection dropdown open in the playlist browser. It seemed to be that the browser flickers (renews the view) when something was searched for.
    I know, this comes together with the huge collection, when I use a pretty small one with just i.e. the traktor tracks, you can't see it.

    Now, with 3.5 it looks like that the browser renews the view, TPro also renews the (time consuming) search and therefore flickers also when the track collection dropdown is closed in the playlist window. So it flickers ALL THE TIME. Annoying. And sometimes, when I'm about to choose something and try to edit, it throws me back out from inline editing.

    This is up to making traktor not useable in live situations. It's not only ugly (if someone looking from behind), it disturbs my eyes. Aftern an hour not only Traktor is flickering, my eyes go crazy too.

    As said, I know this flickering for long long time, but not that harsh.

    Please fix it. Soon.
     
    • Like Like x 5
  2. saradis

    saradis New Member

    Messages:
    13
    I posted about this too, it's the first time in 13 years that I've rolled back to a previous version because of it
     
    • Funny Funny x 1
  3. Jonas C @ NI

    Jonas C @ NI NI Team NI Team

    Messages:
    161
    Hi humphrai_Tf

    Like said into saradis 's post, I think we have experienced that flickering already but I would like to be sure we're talking about the same thing. Could you record a short screen capture of Traktor when this is happening ?
    That would be very helpful to understand the context and the degree of flickering of the Browser.

    Thank you !
     
  4. Stelios Frontistis

    Stelios Frontistis New Member

    Messages:
    1
    i have the same issue, so i went back to 3.4.2 too

    Thanks a lot
    Stelios
     
    • Like Like x 1
  5. chilly

    chilly Returning Customer

    Messages:
    3,138
    I'm throwing a +1 here. humphrai_Tf 's experience is exactly mine as well. The flickering has always been an issue, primarily when searching for a track in the entire collection OR when new files are being analyzed and added to the collection (this is worse than the first example). In 3.5.0 it seems as though it's constant.
     
  6. saradis

    saradis New Member

    Messages:
    13
    You asked for a screen capture, yet the forum won't upload mp4 files. You can find a short example of the flickering here https://www.dropbox.com/s/b46ep3fq3740r4d/traktorbug.mp4?
    i'm just pressing "Remove duplicates" from a list. This NEVER used to happen, and now it happens all the time, not only when removing duplicates but sometimes when I just delete single tracks
     
  7. SpirosG

    SpirosG NI Product Owner

    Messages:
    72
     
    • Like Like x 2
    • Funny Funny x 1
  8. Jonas C @ NI

    Jonas C @ NI NI Team NI Team

    Messages:
    161
    SpirosG : Indeed this is pretty concerning !

    Could you give me a bit more precision about your OS and your configuration ? Is there any hardware plugged in when this is happening ? Was it the same with previous version 3.4 ? How big is your collection ?

    I'm gonna assume this is the same problem described by humphrai_Tf and I'm gonna join your video to the ticket TP-15744.

    Thank you !
     
    • Dislike Dislike x 1
  9. saradis

    saradis New Member

    Messages:
    13
    Jonas C @ NI no need for OS and configuration details. This is the problem we're talking about, it happens on both my macbooks (intel and M1) and my AMD desktop, with or without specific hardware, and with different collection sizes from 5000 to 40000 tracks. It used to happen before 3.5 (only sometimes) in large lists when the "Track Collection" section was expanded, and you just collapsed the section and it was smooth af. Now the Track Collection just keeps expanding on its own when you search or change things in playlists and every playlist behaves like a very long smartlist.
     
    • Like Like x 2
  10. SpirosG

    SpirosG NI Product Owner

    Messages:
    72
    Ηι Jonas C @ NI

    This is my configuration.

    Screenshot 2021-07-16 155128.png

    There is no hardware connected. My collection, well actually is huge and no i didn't have the same problem with previous versions except when, as saradis describes very well, "Track Collection" section was expanded.

    Thank you!
     
    • Like Like x 2
  11. Jonas C @ NI

    Jonas C @ NI NI Team NI Team

    Messages:
    161
    SpirosG :

    Did you use Beatport or Beatsource streaming service via Traktor in these session by any chance ?
     
    • Dislike Dislike x 1
  12. DJ-Andre

    DJ-Andre NI Product Owner

    Messages:
    108
    This is a frustrating bug that will hopefully be fixed in the final release of 3.5.1. The browser refresh also happens when analyzing (newly added) tracks. The search function is nearly impossible to use then.
     
    • Like Like x 2
  13. SpirosG

    SpirosG NI Product Owner

    Messages:
    72
    No Jonas C @ NI , i 've never used it.
     
    • Like Like x 1
  14. dariodelima

    dariodelima NI Product Owner

    Messages:
    186
    +1 on this flickering issue, have never really noticed it before 3.5. Before it was very subtle or once in awhile. With 3 .5 it is really there to be noticed and is an issue when needing to search quick. Jonas C @ NI , it happens even without beatport or beatsorce logged in or been used and only really happens in track collection when loading tracks or editing tracks or analyzing them not in playlists. It is def a browser issue as I also keep getting the filtering message coming up in between the flickering. This could also possibly be linked with the other issue where traktor takes longer to load history playlists then it did before as mentioned in the other forum post.
    Fortunately playback continues without a glitch but library management has def become an issue with 3.5.

    A video showing the flickering in track collection vs playlists
     
    Last edited: Jul 22, 2021
    • Like Like x 3
    • Funny Funny x 1
    • Informative Informative x 1
  15. humphrai_Tf

    humphrai_Tf NI Product Owner

    Messages:
    227
    Well, my hardware config in the message footer is the device I am using. No more hardware that should influence traktor in it's behaviour. No controller, sound card or anything. I may try to add some more video to it, but I think the above posted videos shows it already.
    Traktor was flickering before 3.5 also, but it was much much less. Well, before 3.5 I couldn't have the track collection item (top of the playlist browser (Artists, Releases, Labels etc)) open. If it was open it was also annoying like it is now.

    ((As you -Native- have been recognized, I live in Berlin. If needed, I can show it in your office, did that before while I was in your early beat list))
     
  16. humphrai_Tf

    humphrai_Tf NI Product Owner

    Messages:
    227
    I just recognized something bad:
    The flickering and the induced timeouts are making the tabbing function for the beat grid unusable to me. TPro never finds the correct grid because the algorithm gets corrupted...
     
  17. humphrai_Tf

    humphrai_Tf NI Product Owner

    Messages:
    227
    Okay, I was really fighting to get a video done. The normal windows screencast didn't work. VLC screencast has no audio...
    Anyway, I hope I did something helpful:
    https://www.mediafire.com/file/kx3b3jtvyn7labi/2021-07-23_11-50-14.mkv/file
    The video shows some flickering while I was preparing some new tracks. First, Traktor flickers at places, where it is not neccessary. Especially bad is the handling of the Inline Editor.
    And: yesterday I started a checking whole track collection. It usually takes 3 to 4 hours. This time after about 8 hours (back from work) I saw the browser flickering regularily, slowing the whole process down. It took approximately 16 hours this time.
    Maybe it helps (I know it's not perfect)
     
    • Funny Funny x 1
  18. humphrai_Tf

    humphrai_Tf NI Product Owner

    Messages:
    227
    • Like Like x 1
  19. Sûlherokhh

    Sûlherokhh NI Product Owner

    Messages:
    214
    This flickering also troubles me, especially when i am prepping tracks, adding tags and finding/removing duplicates in the collection. It's not a new bug but it got greatly exacerbated.
     
    • Like Like x 1
  20. re5etuk

    re5etuk New Member

    Messages:
    14
    i'm pretty sure my collection list has flickered for years.... i used to get graphic corruption on the decks too but that seems ok now (occaisonally it just smeared the entire track graphics across the display area).
    collection flickering is especially bad when importing new tracks, even if none of the tracks on screen are changing.
    mac 10.13.6 geforce gt330m , main laptop screen or on 2nd screen.