1. We're currently conducting systematic tests with the release version of macOS 11 (Big Sur) in order to offer full compatibility of our products as soon as possible. You can find our latest compatibility status - here


    Please note that although announced at the same time as macOS Big Sur, Apple Silicon processors are an independent release with separate compatibility concerns for NI products. Compatibility with macOS Big Sur will not yet ensure compatibility with Apple Silicon processors. At the moment, Native Instruments products are not supported on computers with Apple Silicon processors. Read more - here

    Dismiss Notice

Can't get damper/sustain pedal to work with S61 keyboard

Discussion in 'KOMPLETE KONTROL SERIES' started by Budda05, Sep 4, 2015.

  1. vision-m

    vision-m NI Product Owner

    Messages:
    143
    thats just ... wow. i read this and think: thank the powers that be, that i did not yet purchase the 88 version. i would be SO p* off. i have instead decided to spend my money on the kawai vpc1 to use with pianoteq.

    for quite a while i have not bought anything from ni, and been reading now and then through the forum. this thread is the perfect example as to why be cautious these days. sadly, because in general ni still makes great products. sometimes.
     
  2. Richard Vodden

    Richard Vodden New Member

    Messages:
    1
    I had issues with my Yamaha FC-3A (which is a continuous sustain pedal, not on/off) and the S-88. However having fiddled a bit I have it working perfectly in standalone and in plugin modes.
    First I plugged in the pedal to the Sustain Pedal jack whilst the S-88 was powered off. Then i powered on the keyboard.
    I opened Control Editor, and checked that "Komplete Kontrol S - 1" was selected. There should be an orange box around the connect light.
    Then on the File menu, select preferences and select "Komplete Kontrol S - 1" on the left menu.
    From here you can recalibrate both the expression and sustain pedals, and most importantly select "Continuous" versus "Switched" from the Pedal Mode dropdown under Sustain Pedal.

    I saved that setting and all was perfect :)
     
    • Informative Informative x 2
    • Like Like x 1
  3. Budda05

    Budda05 NI Product Owner

    Messages:
    99
    They have not provided this to S61 users as of yet. I don't know why... The wiring is the same, there is tip and ring control in the controller editor.
     
  4. jg::

    jg:: NI Product Owner

    Messages:
    36
    Buddha05 said, some time ago:

    "No other piano players who find this lack of control puzzling or frustrating, especially with regard to the 88-key controller?"

    Yes, there's plenty of us. Very disappointing. I hope they resolve the situation asap.
     
  5. Budda05

    Budda05 NI Product Owner

    Messages:
    99
    Last they told me, there is some limitation in the S61 that is not there in the S81 that prevents the setup from being implemented "properly". Until then, there is a workaround for using the expression pedal jack for continuous control, but that involves going into your controller editor and changing the settings, never mind switching the pedals around. The proper thing to do would be to eliminate the limitation in the S61 and fix it, but that doesn't seem like something NI wants to do.
     
  6. AntonA1

    AntonA1 NI Product Owner

    Messages:
    1,722
    I will be curious to see what improvement they make on the next iteration.
     
  7. Frantz

    Frantz New Member

    Messages:
    8
    Hey Budda05, First off thanks for spearheading this post. I've owned the s61 for a while now but only recently got back into relearning piano. I came across this thread as I was looking to use a sustain pedal. To make a long story short consider me a newbie and was hoping you could clear something up for me. Do I have it setup right?
    • I have the latest firmware & software installed
    • I purchased the Roland DP-10 based on this thread and other reviews
    • I was interested in using the half-damper function
    • I ended up following the steps in this NI article which I thought was funny because they likely released it because of you (looks like it was released a few days ago based search results).
    • I've tried the feature with the "Alicia Keys Init" instrument
      • Found a setting "HALF PED" under "Symp Res / Half Ped" and turned it on
    • I have the pedal set to continuous
    • I've also tried it with The Gentleman and The Maverick
    So far I don't hear any difference regardless of how far down I have the pedal pressed. I'm sure I must be missing something simple but so far haven't figured it out. Can you let me know what I'm doing wrong?

    Thanks,
     
  8. Budda05

    Budda05 NI Product Owner

    Messages:
    99
    Are you a piano player? Do you know what you're listening for? If not, don't worry about it, unless you want to go to a piano store to find out what half-pedalling is and what it sounds like. Otherwise, I suppose you've done it right and it should be working properly for you.
     
  9. Frantz

    Frantz New Member

    Messages:
    8
    Thanks for the quick response. When I was 12-13yrs old I had stopped at level 8 of the Royal Conservatory exams. I'm 40 now so it's been a while. :) I did take the time before reaching out to watch/listen to a few YouTube videos to refresh my memory and hear the difference when a different pressure was applied to the pedal. The sustain sounds exactly the same to me regardless of positioning. I do have monitoring speakers and headphones so I should hear the nuances. It does look like I have things setup correctly but wanted to check in in case I had missed something within the instrument apps. Cheers.
     
  10. Budda05

    Budda05 NI Product Owner

    Messages:
    99
    Hm.

    The reason I asked is because the effect shouldn't be subtle or hard to hear. If you went as far as grade 8, you'd know, ha ha. I can definitely "choke" notes off with my set-up, so not sure what with your set-up that it's not obvious that it's working for you. Check your DP-10 and make sure the switch is on "continuous" and not "momentary". If that's in the right position, I'd suggest looking for a program that tracks MIDI messages in your system to make sure that your KK is actually transmitting continuous data as opposed just "on" and "off". Double-check your Controller Editor settings and make sure in there that you've got that all lined up according to the article. After that... Tech support, as useless and ignorant as they may be about this feature.

    Good luck!
     
  11. Frantz

    Frantz New Member

    Messages:
    8
    Thanks for the suggestions. I'll look into a midi tracking program. Hopefully I can avoid tech support as all my experiences with them have been extremely bad. Considering how much I've purchased from them ($3k+) I'm shocked at how much they don't seem to care.
     
  12. musicare

    musicare New Member

    Messages:
    24
    It‘s been awhile. Out of curiosity... is the Sustain pedal for the KK S61 working as it should, now?
     
  13. musicare

    musicare New Member

    Messages:
    24
    Video explaining how to make it work:
     
  14. Prismaspect

    Prismaspect New Member

    Messages:
    1
    In case anyone comes across this trying to figure out how to get a "continuous" pedal like the yamaha FC3A to work, go to the standalone Komplete Kontrol app, click on midi, set the port the pedal is plugged into to continuous, reverse the polarity (it is necessary on the yamaha, it may not be on others), T/R to Tip (to the left), type=control change, midi channel 1, and change the number from 11 to 64. You may have to do the calibrate thing, but I don't know if it's necessary. Works like a charm for me now!