Can't Update Kontrol Z1 Firmware

Discussion in 'KONTROL Z1' started by Leons, Mar 20, 2019.

  1. Leons

    Leons New Member

    I'm trying to update the firmware of my Kontrol Z1 but when starting the update process the LEDs of the Kontrol Z1 flash for a second and than go off which results in not being visible in the update tool anymore (have to reconnect the Kontrol Z1 to make it work again).
    Tried both device updater version 1.2 and 1.7 but no luck, tried it on MacOS and Windows 10(in a virtual machine), same outcome.
    My Kontrol Z1 is currently on Firmware version 8 and the newest seems to be 16.
    Anybody knows why that is happening and how to solve it? Already invested 4 hours trying to solve it but no luck.
  2. Djoulsbab

    Djoulsbab New Member

    Hello - I have the same problem. Namely that Traktor Pro 3 does not recognize the Z1 and that I cannot update the firmware on a Mac running macOS Catalina 10.15 with all required specs to work with a Z1 (the updater does not recognize the Z1). Does anyone have a solution ? Thanks a lot