1. Please do not install macOS 10.15 Catalina yet, as Native Instruments software and hardware products are not supported under macOS 10.15 yet. For more info, please go HERE!
    Dismiss Notice

Solved Catalina, Maschine 2 and Komplete S61

Discussion in 'MASCHINE Area' started by David Baines, Nov 6, 2019.

  1. David Baines

    David Baines New Member

    Messages:
    3
    Hi..
    I have upgraded to Catalina, and to the latest Maschine 2 (Ver 2.8.7 (r763)), and after some phaffing around with eLicenser got it all working.. Sweet.
    Tested with Maschine Mk3, no probs...
    I also own a Komplete S61 keyboard.
    Komplete Kontrol works fine with the S64 under Catalina, BUT S61 no longer works with Maschine.
    If I select the S61 as the hardware within Maschine, no other parameters appear, then when I exit the Preferences dialogue and go back in, the hardware field is cleared...

    I'm sure this will be ultimately fixed by NI, but I was wondering if anyone else has this issue, and if you did, did you manage to resolve it somehow??

    I have re-installed Maschine 2.8.7, no change to the symptoms.

    Thanks

    Dave
     
    Last edited: Nov 10, 2019 at 8:04 AM
    • Like Like x 1
  2. mickeyl

    mickeyl NI Product Owner

    Messages:
    231
    Are the NI low-level helpers (NI Hardware Agent and one another with a name I have just forgotten) running? Btw., it's the S61, there is no S64.
     
  3. D-One

    D-One Moderator Moderator

    Messages:
    7,060
    It's working for me but then again I have an SMk2.
    Check for firmware updates, a few were released yesterday.
     
  4. David Baines

    David Baines New Member

    Messages:
    3
    Hi, thanks for your swift responses...
    mickeyl... Yea, S61... what a n00b I am.. I'm a puter geek, so everything I work on is base 2, so 64 is welded in my brain, of course it's a S61 haha..
    Anyhew... yea, the NIHostIntegrationAgent and the NIHardwareAgent are both set to run at login.... Hmmmm

    D-One.. All firmware is up to date........

    I did a little more poking around....
    Other things on the S61 work, such as browser, but not the notes.... Nothing from the keys works, and you (sort of) can't select the S61 in the hardware section of the preferences of Maschine.. See image.... When you quit the preferences and go back in, nothing is in the controller drop-down.

    I've re-installed Maschine and Komplete Kontrol....

    Any more ideas??

    Cheers again..

    Dave

    Screen Shot 2019-11-07 at 6.24.18 pm.png
     
    Last edited: Nov 7, 2019 at 3:22 PM
  5. David Baines

    David Baines New Member

    Messages:
    3
    Hmmm... After struggling with this issue for a few days, it magically all started to work again...
    No updates, nothing.. Just tried it all again and it worked!!..

    Can't tell you what fixed it, but now it's all good.

    Cheers for the input.

    D