1. Hi everyone,

    This forum is now closed for posting! If you require technical support from NI or have a questions about activating your product, please head over to our new Support Community!


    The Support Community is the new location where you can expect to receive assistance and feedback on technical support, sales or installation issues from our Support Agents and other users.

    Please also note, questions about the status of an order should always be directly sent to our Order Support team HERE.

    Best wishes, 
    The NI Team

COMMON PROBLEM: "Unknown medium, calib. failed"

Discussion in 'Technical Issues (Archive)' started by Chris White, Jan 21, 2009.

Thread Status:
Not open for further replies.
  1. Chris White

    Chris White New Member


    I've searched around and seen almost one hundreds threads about this flaw ("Unknown medium", which is Traktors inability to identify the type of timesignal (vinyl/cd/etc)) regarding the new Traktor Scratch Pro/Traktor Pro. There are in fact 99 (NINETYNINE!) threads about this on your forums: See for yourselves.

    I've found the cause and solution to this common problem, it's in the last post from me in this thread. Read on, especially if you work for NI. I've also been editing this thread multiple times to the point where it's now really long, sorry about that, now it's sure to only be of interest to NI and people affected by the problem. It contains all pertinent info and troubleshooting to solve this problem, and it is 100% confirmed to be a software-only issue, due to the proven fact that the issue can be solved through SOFTWARE methods shown later, and the fact that NO HARDWARE CHANGES are needed to get it to identify the vinyl, no need to change needles, nothing hardware based whatsoever. This is a sporadic software flaw in the timecode identification code. People have been trying replacing their Audio 8s and all kinds of things, I feel bad for them since it's a software flaw. Read on for thorough testing and proof.

    Video added: http://www.scummgames.com/traktortemp/tracking.avi (DivX, 7mb). Click here to see the EXACT timecode waveform I am seeing in Traktor. See how perfect it is, yet Traktor says "Unknown medium". The first half is both decks playing. After that I move the needle on Deck B, then on Deck A, to show that the signal is perfect no matter where on the record you go. This is a digital screen recording, not camcorder, so you see a pixel-perfect image of what is on my screen. Read on:

    The problem: "Unknown medium, calib. failed" when Traktor is trying to identify and calibrate the vinyl timecode signal. CD users are reportedly affected by the same inability to identify the TYPE of timecode it is reading. This inability to identify whether it's reading timecode vinyl or cd causes the pitch to jump around wildly, but playback still works (you can even scratch). HOWEVER, since it has NO CLUE what medium you are using, the Track Scroll section does not work, for instance. Traktor MUST know what medium you have connected, and not having perfect, accurate identification code in Traktor is unacceptable.

    The consensus is that either the Software or the Audio 8 is at fault. One or the other. I decided to investigate which one it was. Findings at the end.

    Here's what's known about MY setup:
    • BOTH STEREO CHANNELS are working properly, I've tried with regular vinyl and sound is coming from both speakers.
    • The AUDIO 8 is set to TIMECODE VINYL mode.
    • The GROUND CONNECTION is PERFECT and connected properly to the Audio 8 (also tested grounding to the Mixer, same result with identically perfect waveform no matter if you ground to mixer or to Audio 8. The waveform is round and crisp. If the ground is completely disconnected, the waveform becomes very fuzzy. In other words: Ground is perfect where it is.)
    • I (and others) have at your suggestion tested the GROUND LIFT option in the audio interface. It made no difference either in WAVEFORM or performance. The waveform does not change at all, and continues to look perfect (that's a key thing to note here, the waveform is great, Traktor SOFTWARE is at fault).
    • The control WAVEFORM in Traktor looks PERFECTLY CLEAN AND ROUND, it's round and crisp, no fuzziness or distortion or missing channels or "unroundness", it's P E R F E C T.
    • Testing has been done with both COMPLETELY NEW CARTRIDGES (Ortofon Q-bert Concorde) + NEEDLES and with OLD CARTRIDGES (Ortofon Night Club Concorde) + NEEDLES.
    • Using the EITHER OF the needles mentioned above results in PERFECT performance when trying Deckadance + MS Pinky vinyl (just wanted to verify that my hardware setup was working with other software and timecode solutions, so I tried this and the timesignal was perfect with Ms Pinky Vinyl through Audio 8 using the Deckadance program, indicating that indeed the NEEDLES and TIMECODE are perfectly read, and in that program there was no jumping/jittery pitch either, which is natural because this is on a 1210 M5G with Quartz lock 0% pitch enabled, resulting in stable rotation speed), so it turns out that:
    • TRAKTOR PRO SOFTWARE is wrong here. NOT the VINYL, NOT the Needles, NOTHING other than the software is wrong here. Illustrated by the fact that all sources of user error have been verified to be false. The source identification and vinyl handling seems bad (the inability to identify the timesource medium, and the jumping pitch indicates this to be the only plausible explanation).
    Update 10 minutes after posting this thread, I found that it is WITHOUT A DOUBT a Traktor software fault that is affecting all these people:
    Traktor Pro/Scratch Pro is REALLY... I mean REALLY bad at understanding the Timecode Vinyl. The code needs serious fixing!

    By WILDLY both >>RAISING<< and >>LOWERING<< the Audio 8 Latency (Preferences > Audio Setup > Audio Latency), and restarting the program after every change, results in it EVENTUALLY being able to identify the vinyl and say "Vinyl 10 min" and have a 100% stable, non-fluctuating pitch (as I said, this is on a perfect 1210 M5G with Quartz locked 0% pitch enabled). Whether it identifies the vinyl or not has nothing to do with the actual latency being too low, as you'll see:

    You may try 100ms latency and get "Unknown medium" and then 10ms and get a correct identification. Then change it again to 15 and get no signal. Each time you restart/change value it's a gamble if it will understand the signal or not. Additionally, it's sick how bad the program is at handling high latencies, when I tested latencies like 50ms, it kept popping up "Vinyl 10 min, skipping", it thought the vinyl was skipping! The high latency value caused this misreading, despite the fact that such a high latency will be perfect as far as INCOMING TIMESIGNAL goes, due to the nature of audio buffers and how higher buffers cause smoother audio with less interruptions/crackling.

    IN FACT: Once you have played WACKED AROUND with the buffers up and down, and restarted the programs until it FINALLY identifies the vinyl (when it will do this is a gamble), you are then free to (WITHIN THAT SESSION) set the buffer to 1 MS (1 millisecond, the lowest value! proving that this is not buffer-related!). I repeat: THIS IS NOT BUFFER RELATED. THIS IS NOT AUDIO-PICKUP/CRACKLE/QUALITY/GROUNDBUZZ-RELATED. THIS IS NOT HARDWARE RELATED AT ALL.

    IT IS A SOFTWARE FLAW IN THE TIMECODE IDENTIFICATION CODE, and this flaw has NOTHING to do with any buffer settings or hardware setup. The issue can be solved RANDOMLY by jacking around with the buffers and restarting the program which will eventually lead to Traktor identifying the vinyl properly, no HARDWARE changes or fixes were needed, and then you are free to set the buffer even as low as 1ms within that session (restart and tracking will be lost again, proving once again that it's a flaw in how you try to identify the incoming timecode signal). Once the timecode is actually identified, the tracking becomes perfect and pitch fluctuation stops completely. Therefore, the code is in need of major overhaul to solve it so that it ALWAYS identifies the timecode properly.

    Jesus christ, please stop all your other Traktor work and fix this common (see above, 99 other threads since T Pro was released!) problem in your timecode identification code. As you saw, it has nothing to do with hardware or buffers, and once the timecode has been identified, all pitch fluctuation problems go away as well. Solve the timecode identification issues and boom, all these users will be able to reliably use your software. As you saw from some of the threads, people have actually gone to gigs and had the software be unable to identify their timecode all of a sudden. It's completely sporadic and doesn't even have anything to do with the needles or cartridges. It's entirely a TRAKTOR software flaw.
  2. DiscoNova

    DiscoNova NI Product Owner

    For what it's worth, on the video, the tracking circle is nowhere near perfect. It seems like there is some strange static (*) noise in the detected audio signal - on top of the fact that the speed appears to be quite unstable.

    Unfortunately I don't have my turntable at hand to see how that calibration display compares to what I get. I've had only once a tiny calibration error, when I had the wrong input chosen (see attached picture; previously I had two Audio 8's listed, now I apparently have three... the only one that works as expected is the one listed as "Audio 8 DJ", when I erroneously chose the other one, I was not able to calibrate - it failed with the same "unknown medium" error message).

    Just out of curiosity; are you running the calibration @ 33 or 45 RPM (and have you indicated this in the settings)?

    (*) Edit: actually, calling the noise "static" is not correct. It seems like it repeats at intervals... most likely always it occurs at the same position of the turntable's rotation... which is a bit strange.

    Attached Files:

  3. Chris White

    Chris White New Member


    Hi, maybe you just saw the video and didn't read the entire thread (and it did become long, sorry about that, I kept editing it to add more info as I discovered it and it became quite unwieldy by the time I was done).

    I established with certainty that the fluctuating pitch is caused by traktor being UNABLE to identify the TYPE of timecode (VINYL or CD), because once it successfully identifies the source (this happens at random, just wack around with the latency up and down and eventually it will identify the type of timecode, it's a software flaw), then pitch then becomes 100% stable, no flutter, proving that it's not a timecode READING error, it's a timecode IDENTIFICATION error. Once it's identified, everything is rock solid. Waveform is the same as before identification. Control is perfect.

    The cause of the identification problem is Traktor being bad at identifying whether the timecode is vinyl or CD. Hundreds of threads, with dozens of replies in each thread with people saying "me too", shows how widespread it is.

    Combine that with all the testing I did, which showed how ONCE THE VINYL WAS IDENTIFIED, pitch became 100% stable and tracking was perfect, as was vinyl control and scratching. The way to get it to identify the type of timecode was to wack around up and down on the latency, the actual latency you choose has no effect, just tweak it up and down loads of times until the signal is identified. Nice identification code, huh? :/ Once it is identified, it's rock solid and perfect at controlling.

    Oh, and the rhytmic thing you are talking about has no effect on this, it's merely a bit of dust on the record (the control vinyl were dusty and full of tiny paper chips when I got them, I brushed them off as good as possible, but dust has NEVER hurt ANY other digital vinyl system before, I've used Serato, Mixvibes, Numark Virtual Vinyl, Torq and now Traktor. Dust is not a factor in any of them, they're all made to handle these "bumps" when the needle passes over dust. On that note, it would be pretty good if NI actually had quality plastic sealing of the records at the pressing plant, and didn't ship them dusty and with paper chips on them).

    Edit: As far as choices for audio interfaces go (see attached image), from top to bottom I see the 4 generic ASIO drivers installed by Cubase (these are not related to Audio 8 or any of the other interfaces), two M-Audio Delta 1010 drivers, the Access Virus TI driver, two RME Fireface 800 drivers, and ONE choice related to Audio 8: "Audio 8 DJ (Ch A, Out 1|2) (8 In, 8 Out)". Odd or correct?

    I've got a headache, I'll sleep and come back tomorrow. ;-)

    Attached Files:

  4. DiscoNova

    DiscoNova NI Product Owner

    By first impression, I'd say this sounds odd. From what I've gathered, the interface identified in this manner propably uses the generic system audio driver, and not the proper ASIO one. But since I'm no expert on this matter, my impression might be invalid.

    Edit: It might be that the problem is related to the ASIO4ALL driver you have installed. Hopefully I don't need to remind anyone that it is a hack (a clever one, though) which most "real" ASIO driver providers normally discourage people from using. Of course, I don't know where NI stands.
  5. Chris White

    Chris White New Member

    Good thing I refreshed the thread before going to bed. Thanks for the excellent lead to the root cause of the problem!

    I am now almost completely sure that everyone affected by this (again, 99(!) threads with dozens of replies saying "me too" are affected) are using the "Audio 8 DJ (Ch A, Out 1|2) (8 In, 8 Out)" WDM driver (I didn't even know it was WDM since it doesn't have either WDM or ASIO in its name, and no separate ASIO driver is listed, which is very strange).

    The use of this WDM driver is EXTREMELY likely to be THE cause for EVERYONE affected by this crippling problem. The solution would be to code Traktor to NEVER, EVER LIST the incorrect WDM driver, no matter what happens, NEVER list it under any circumstances, since it's obvious Traktor does not play well with WDM drivers in combination with timecode.

    First thing tomorrow I'll try to reinstall to see if I can properly get the ASIO driver that you mention. And yes, I installed the latest driver from the web, downloaded today, so it's baffling that the ASIO driver wasn't installed even though I fetched the most recent driver package.

    Regarding the ASIO4ALL driver, it's some crap that Cubase insists on installing, I don't use it in Traktor (or anywhere else for that matter, I use the native ASIO drivers of my various audio interfaces). The ASIO4ALL driver is simply meant to give ASIO to non-asio soundcards, and since it's an audio driver just like any other, it's of course listed in Traktors options, but it's not involved in Traktor in any way since it hasn't been selected as the active driver. ;-)



    VERIFIED! Look at attached screenshot!

    No Audio 8 ASIO Driver was found when using Cubase to verify the list of ALL available ASIO drivers! That means that all these affected people are using the WDM drivers, and that's causing their problems!

    It's high time to code TRAKTOR to HIDE ALL WDM DRIVERS, PERIOD! ;-) That should put a stop to these thousands of affected people (Hundreds of threads * Dozens of replies = quite a lot, and not to mention the people that don't post, or the people that actually went and got their Audio 8s replaced several times!). All because of the usage of the WDM driver!

    If Traktor handles itself that badly when using a WDM driver, it shouldn't list them in the first place, scrap them completely! Secondly, they should definitely NAME these drivers, just like all other manufacturers, ie "ASIO" and "WDM" in the actual driver name! There's a reason manufacturers do that, it's so things like this don't happen (ie wrong driver getting chosen).

    Now... if I could just get that ASIO driver to install itself too, all will be solved. That's quite serious in and of itself, why wouldn't the ASIO driver install itself? I'll have to find out tomorrow, maybe by trying an older Audio 8 driver or swapping USB slots and reinstalling the current driver.

    Thanks for helping to troubleshoot this, now we have a proper report to give to Native Instruments!

    Once I've (tomorrow) managed to get the ASIO driver to install itself, I'll test everything again, then rewrite the first post of this thread and submit a bug report to Native.

    Attached Files:

  6. iamthedj4u

    iamthedj4u Forum Member

    So the calibration rings should be perfectly round and crisp? Mine are a little oblong and fuzzy? Is this bad? I mean everything sounds good and always calibrates?
  7. chilly

    chilly Returning Customer

    Hey Chris...

    I wanted to touch on a couple things here.

    In regards to playing a non-timecode vinyl or cd through the multicore cables and an Audio8: You will always have sound come through because the Audio8 does not do any of the processing - it's all in the cables. This is why you can lose power to your laptop (and thereby lose power to Audio8), yet you can still play music using regular medium.

    Secondly...one of the posts must be mine. The only resolution I had was obtaining a new Audio8. I own 2 Audio8s...one worked, one didn't. I sent the faulty unit back, received a new one, and they both work now.

    I fail to see how your post must be taken as gospel, and that there is only one solution...yours. I'd be very careful in my choice of wording, especially with something like this. I see nothing in your test scenario where you used another Audio8!

    Find my post...should be in the T3 or Scratch Technical Issues subforum. My history is all in there. You'll be convinced that you're wrong (about it being 100% software related).

    PS...Yes, I know that this was in regards to TPro.
  8. Thomas @ NI

    Thomas @ NI Administrator NI Team

    Hey Chris,

    The driver labelled "Audio 8 DJ (Ch A, Out 1|2) (8 In, 8 Out)" is the DirectX driver for the Audio 8 DJ. It is not at all recommended to use this driver with Traktor. The DirectX driver is for generic Windows applications.

    In Traktor you need to choose the driver entry "Audio 8 DJ", that's the low-latency ASIO driver. If that entry is missing, you probably need to reinstall the driver.

    Changing to the correct driver should sort your timecode problem.

    Regards, Thomas
Thread Status:
Not open for further replies.