Discontinuing OSX support of S4 Mk1

Discussion in 'KONTROL S2 / KONTROL S4' started by thatkidduffy, Sep 20, 2016.

  1. thatkidduffy

    thatkidduffy NI Product Owner

    Messages:
    53
    Just got the email from NI stating that they can't will be ceasing support for the S4 Mk1.

    So a device that was released, what, 6 years ago? That may sound like a reasonable amount of time, but there are still a hell of a lot of these devices 'in the wild' and in regular use.

    It seems to me that NI simply can't be arsed sorting the drivers for the device. Lets be honest here, they have hardly been a beacon of customer support over the past few years. In fact, the looooong overdue update to Traktor 3 (or whatever) is a farce in itself.

    Anyway, I'm sure I'm not alone in being pretty pissed off about this, but hey, past experience tells me NI will do cock all about it!o_O
     
  2. emmetkt

    emmetkt New Member

    Messages:
    9
    100% agree with you here, totally puts me off further NI purchases to be honest.
     
  3. Jesus Climent

    Jesus Climent New Member

    Messages:
    1
    The thing that puts me down is the fact that the less expensive S2 MK1 is supported, but the S4 MK1 is not.

    I put down $1000 and is still my working device, and now I have to maintain an El Capitan laptop only to be able to play with this device... Not cool.
     
  4. tomazzzi

    tomazzzi New Member

    Messages:
    18
    That's insane, S4 is my last NI product !!!!

    Dropping support for what they called a flagship product shows the respect they have for their customers.

    So let me tell you NI that my next product won't be a Native Instruments product for sure.
    There are toons of others company who keep working on drivers for more than 10 years old devices ( MOTU for ex )

    That scheduled obsolescence piss me off !

    At least make your drivers open source so we can spend the time you don't want to spend to make this ******* driver.
     
    Last edited: Sep 21, 2016
  5. dj babura

    dj babura New Member

    Messages:
    2
    It really sucks that NI dropped out support for S4 MK1 .Technology goes further but what has changed in terms of sound and mp3 and other stuff connected to S4 - answer is nothing. Why not to be able to use still properly working and fully functional S4 MK1 is a question of not giving the customers opportunity of choice wheatear to keep the ''very old" hardware or update to "brand new" macOS that in terms of just plugging the controller in MacBook and playing the mp3 bring absolutely nothing new, besides Siri - I suppose future of DS-ing is perhaps in playing with Siri.

    Shame on You NI not to be able to update the driver once a year when Apple releases their so Brand new and amazing operating system that kills every peace od hardware that is couple of years old and forces You to buy only the new flag shipped products. Most people uses their Macs for DJ - ing or graphics manipulations, and the new flag shipped MacOS bring absolutely nothing new in the world of DJing besides maybe improved hardware which I will point once again for DJ - ing play no rolle at all, since Traktor is not so resource hungry.
     
  6. David Calver

    David Calver New Member

    Messages:
    3
    Yep. It might be 6 years old but it's only 3 years since it was discontinued. Which is nothing even in computing terms (I am still using the same Mac, after all). My mk1 is just over 3 as I bought one just before the mk2 came out (since the extra outlay didn't seem worth it). One of the reasons I bought it was because the hardware is so robust but what's the point of that if it is no longer supported. I'll go back to Pioneer next. I respected NI as a manufacturer of quality up to now but that's no longer the case.
     
  7. hypnorex

    hypnorex New Member

    Messages:
    18
    F.Y.I.:

    I have been testing Audio 8 and Kontrol S4 MK1 (each on 48KHz) extensively with 10.12 Golden Dev, they've been working like a charm for hours and hours. So even if NI officially drops support for these models, it seems as if they will still be working fine.

    There are three aspects everybody should bear in mind when using Sierra: all energy saving options must be deactivated, AppNap has to be disabled globally and FileVault needs to be deactivated.
     
    Last edited: Sep 21, 2016
  8. David Calver

    David Calver New Member

    Messages:
    3
    That is really helpful hypnorex! Thanks very much.
     
  9. Karlos Santos

    Karlos Santos Rocket Man Moderator

    Messages:
    11,986
    Please Read:

    Please note that support being dropped does not necessarily mean functionality being terminated.
    We have received quite a few reports from users of the affected products suggesting that these devices still work flawlessly - provided that the following aspects have been taken into account:

    • the device has to be operated with 48Khz Sample Rate

    • the macOS security preference „FileVault“ needs to be deactivated

    • the macOS energy saving option „AppNap“ must be globally disabled

    • all other energy saving options must be disabled as well

    Please check these threads in our Traktor User Forum in order to find several reports on this matter:

    https://www.native-instruments.com/...dio-is-fixed-100-percent-confirmation.308513/
    https://www.native-instruments.com/forum/threads/sierra-andaudio-8.309381/


    IMPORTANT NOTE: regardless of the current situation, any upcoming update of macOS Sierra may change the situation and put the functionality of the devices to an end.
    Therefore, in case you decide to update to Sierra please backup your system periodically in order to be able to roll back to a working version.

    Karlos
     
    Last edited: Sep 21, 2016
    • Like Like x 2
  10. David Calver

    David Calver New Member

    Messages:
    3
    Many thanks Karlos,

    That is very interesting. However, I am wondering why NI can't apply/develop the Mk2 drivers to operate the Mk1 given that it is largely the same bit of hardware. You'll have to excuse my ignorance here....
     
  11. hedo

    hedo New Member

    Messages:
    1
    Would it be possible for NI to develop and sell a S4 mk1 to mk2 upgrade kit which includes the hardware that is no longer supported in S4 mk1?
     
  12. frankle

    frankle NI Product Owner

    Messages:
    855
    Completely different USB chipset. The Mk1 required very specific drivers for it to work where as the Mk2 is a class compliant device that is able to have it's firmware updated.
     
    • Like Like x 2
  13. thatkidduffy

    thatkidduffy NI Product Owner

    Messages:
    53
    ^^ that was the source of problems previously wasn't it?

    Cheers for the info Karlos, I've got to be honest, I can't see me buying NI products (hardware definitely) again in the future. Not solely because of this, but the chain of problems over the past few years.

    About time I regressed back to vinyl anyway.
     
  14. anenomi

    anenomi New Member

    Messages:
    17
    Any reports on the current state of Sierra OSX and the S4 Mk 1. I'm not rich enough to drop this controller just yet.......