Display problems with Touch bar Macbook Pro

Discussion in 'TRAKTOR PRO / TRAKTOR SCRATCH PRO' started by Bert Patroons, Dec 26, 2016.

  1. Bert Patroons

    Bert Patroons NI Product Owner

    Messages:
    38
    Hi,

    I just bought a brand new, maxed out Touch Bar 15'' MBP (and for all the people worried: it is a seriously good machine).
    I just have one issue with traktor specifically: the waveforms on the display seem te be lagging/stuttering constantly.
    The lag is also visible on the S5 screens.
    Coming from a 5 year old MBP, which worked perfectly in that respect, this really surprised me.

    There isn't a performance issue. I just played a 5 hour gig without any problem, and the load and memory use is really low.
    It is a just graphics issue I guess.

    Is there anyone with the same model here? Do you have the same problem or is het just me?

    Thanks!
     
  2. markino2003@mac.com

    markino2003@mac.com NI Product Owner

    Messages:
    308
    That's really interesting because I'm going to buy this MBP the next month and I'm glad to know you are only experiencing not serious problems.
    I think this problem could be hopefully fixed with the new Traktor release.
     
  3. Bert Patroons

    Bert Patroons NI Product Owner

    Messages:
    38
    It is a little annoying, but not a real dealbreaker.

    Is there seriously no one here with the new macbook pro?
    If yours works fine, please let us know too! Maybe it's some specific problem for my macbook/combination with other apps, but I doubt it.
     
  4. ErikMinekus

    ErikMinekus NI Product Owner

    Messages:
    593
    Same issue here with my base model 15" MBP 2016, but my D2 screens are fine, it only happens on the waveforms on the laptop screen. Might be related to this:

     
  5. Bert Patroons

    Bert Patroons NI Product Owner

    Messages:
    38
    This could be related, but in my case it is certainly not system-wide. videos and other visuals play fine.
     
  6. ErikMinekus

    ErikMinekus NI Product Owner

    Messages:
    593
    I am now seeing it on my D2 screens as well, definitely more stuttering in the scrolling waveform compared to my 2011 MBP. And I actually restored a Time Machine backup from the 2016 MBP onto the 2011 one, so they are running the exact same software.
     
  7. Jiri Cvancara

    Jiri Cvancara New Member

    Messages:
    1
    I have the same problem. I have Maxed Macbook Pro 2016 - and the Waveforms are sometimes running very very Laggy.
    Also I have some problems to control the knobs via trackpad - sometimes it doesnt react right,
    And Also - when there is lot of mp3 files in folder and I want to scroll it on trackpad - it is Laggy.
    Didnt have this problems on my Old Macbook pro 2008.
    But I believe this is software problem
    Maybe OSx Sierra?
     
  8. ErikMinekus

    ErikMinekus NI Product Owner

    Messages:
    593
    No, my old 17" MBP 2011 is also running Sierra and does not have this issue. I have found that hiding deck C & D or enabling browser mode eliminates the stuttering, so it definitely has to do with rendering the large waveform.
     
  9. Liubo Ursiny

    Liubo Ursiny NI Product Owner

    Messages:
    151
    But when you enable browser mode, you don't really see waveforms?! :)
     
  10. ErikMinekus

    ErikMinekus NI Product Owner

    Messages:
    593
    If you have the S8, S5 or D2 you can see the waveforms there ;) I'm not sure this is even a problem with other controllers. I've also modded my D2 screens so that I no longer have to look at my laptop, unless I'm typing something in the search field.
     
    Last edited: Mar 13, 2017
    • Like Like x 1
  11. xaros84

    xaros84 New Member

    Messages:
    5
    Has anyone found a way to fix this problem?
    I'm having the same stutter waveforms in both d2 screen and in the macbook screen.(Macbook pro with touch bar/15"/2.7Ghz i7/ 16 Gb ram/ 500 GB Ssd/ Radeon 455 Pro 2GB). I tried to launch traktor without the d2 connected and the same stutter waveform problem was still there. Also in fullscreen mode.
    (Traktor version 2.11.023)
     
  12. Joatheman

    Joatheman New Member

    Messages:
    1
    Hi, following this thread. Also new MBP 15" with touch bar. Load is really low and still stuttering waveforms/lag on the displays (I almost only use the S8 controller displays). With my previous MBP 2011 model there were no similar issues.
     
  13. MyNameIsAlias

    MyNameIsAlias New Member

    Messages:
    1
    Would like to say I have the same exact problem. 2016 15" MBP almost maxed out (Radeon Pro 455 instead of 460). The stuttering is insanely frustrating considering I can edit 4K footage in FCP without any problem.
    I tried fullscreen or not, 2 decks or 4, different waveform zoom levels... Nothing seems to reduce the lag. What's weird is that it stays fluid for a couple of seconds, then starts to lag by itself, no knob, mouse or keyboard actions.

    And just to be sure, I am forcing the usage of the dedicated graphic card instead of the integrated one using a piece of software called gfxCardStatus (2.4.3i).

    Hope it helps NI fix this... Quite embarrassing/disturbing to pay 3k+ on a laptop and looking at a professional audio software struggling to render a waveform...
     
  14. Chamaeleolabs

    Chamaeleolabs New Member

    Messages:
    3
    Hi. Any progress on this anyone. Literally just loaded Traktor onto my new macbook pro 15 and have exact same issue.

    My old 2011 Mac air runs seamless.

    Same as above. Just juddery waveform.

    Latency is low when using Z2.
    I did notice it's actually higher thanks to the output value when running on internal soundcard. Odd.

    Feeling a bit peeved after spending an arm and a leg on a new DJ laptop which is worse than my 5 year old one at present :(
     
  15. TroyMichael

    TroyMichael Forum Member

    Messages:
    1,367
    any of your open a ticket with support? What did they say? I am also debating a new MacBook pro or maybe a refurbished older model.
     
  16. Chamaeleolabs

    Chamaeleolabs New Member

    Messages:
    3
    Yup. Today. I'll keep the thread updated.
    Going to try a reinstall and older version too.
    Works fine. Just the visual waveform :(
     
  17. jimmyv

    jimmyv NI Product Owner

    Messages:
    354
    Is this still an issue?
     
  18. Bert Patroons

    Bert Patroons NI Product Owner

    Messages:
    38
    Hasn't changed on mine.
     
  19. Chamaeleolabs

    Chamaeleolabs New Member

    Messages:
    3
    Still not smooth, but apparently it's a known problem.
     
  20. djrosco

    djrosco New Member

    Messages:
    16
    I'm having an identical issue with Traktor 2.11.0 23 and MBP with Touch Bar running OS 10.13.2 (High Sierra)...

    Has anyone found a solution?