F1 stop-button behaviour

Discussion in 'KONTROL F1' started by agentc, May 30, 2012.

  1. agentc

    agentc Forum Member

    Messages:
    114
    Hi,
    I just got my F1 and the first thing I noticed is that the small buttons below aren't stop switches - it's mute by default. Coming from ableton, this just feels a little awkward to me.

    Ok, so now there is shift-stop (actually the stop function is marked as a shift-function), that's what I need. But again, it's an awkward move to perform. There should be an option to swap those functions (make stop the default behaviour, mute with shift-stop) within the traktor F1-configuration.

    Cheers,
    agentC
     
  2. xbubbax

    xbubbax New Member

    Messages:
    17
    stopping the rmx decks

    hey hey,

    if you want to stop playback of all 4 sample decks in deck C....use your midi controller on deck C and hit stop so your stopping deck C, not just the individual sample as you would on the F1

    thats how its done.
     
  3. agentc

    agentc Forum Member

    Messages:
    114
    hi,

    that is what you do if you want to stop all slots at once, right. But I wasn't searching for stopping all the slots at once - I want to stop an indivual slot, like it actually can be done by pressing shift-stop. What disturbs me is that the buttons are mute-buttons by default, they should be stop buttons with mute as an option. it happens often that I want to stop the loop within a single slot, and pressing shift-stop to do so seems confusing, given the fact that loops are launched with the pads, there should also be an option to stop then again with a single button-hit, without needing a second hand or extra long fingers...

    cheers,
    agentC
     
  4. zephry

    zephry NI Product Owner

    Messages:
    1,951
    Of course oneshots stop.
    And depending on how you have each cell set a full stop may be the interaction when the pad(button) is released.

    A quick and smooth stop is to push "type" then change the cell you want to oneshot. it will stop.It will turn(yellow I think) before pushing "type" again push that pad(cell) it will turn back to loop(green) without retriggering.

    Of course also page down real quick and push an empty cell will stop even easier.

    I would suggest opening the advanced veiw of the remix deck and interacting and learning the colors and quick movements of the hardware. I had to force myself to stop playing with the thing and actually see what was happening.

    I am pretty sure an accidental stop instead of mute would make punchmode go poopoo. Not sure why it is set for other modes other than that it would be an easy thing to forget when a person is intending to mute not stop. So its better to have the same throughout. I think.

    BTW I still need to read the manual through.again and figure it all out too.
     
  5. Dubcraft

    Dubcraft New Member

    Messages:
    12
    I wish the default for the bottom row of buttons was stop and the shift mode was mute.
     
  6. agentc

    agentc Forum Member

    Messages:
    114
    Exactly. It just seems that I am not that eloquent expressing myself :p.

    It should be no problem to offer a swap mute/stop functions within the x1-config rider in traktor - I hope to see that in a future update.

    Cheers!
     
  7. cheef

    cheef NI Product Owner

    Messages:
    79

    Agreed
     
  8. jarnow

    jarnow New Member

    Messages:
    3
    Hi,

    I found this to be a bit weird too. I'd hoped to see a way to stop the deck using a button on the F1 but this seems to be missing. I now have to switch decks on the S4 and press the play button to stop playback.

    Now, I am playing the F1, and I open up the browser to load a remix set and before I am able to complete that operation I have to leave the device and stop the deck using my S4. This happens because you cannot load a remix set when the deck is still playing - even though no samples are actually triggered. Even when I stop all loops from playing using shift-stop, I still can't load a remix set.

    Shouldn't the remix deck stop playing if you stop all samples that are in it from playing? Or am I doing it wrong?

    :)
     
  9. Pjotr123

    Pjotr123 NI Product Owner

    Messages:
    187
    The only way is to stop it is via the S4 (or any other controller). Look at the bar counter in the mixdecks: they continue to count, even if you stopped all individual sampleslots. As long as they count, the software will block re-loading a new mixset.
     
  10. zephry

    zephry NI Product Owner

    Messages:
    1,951
    If you get the remix sets showing in the browser window. Push browse. Then turn the encoder to whatever set you want.
    THen push down on the encoder. When I do this it stops the playing samples and loads all new ones.
     
  11. jarnow

    jarnow New Member

    Messages:
    3
    Really? It didn't work like that here... I used the browse button on the F1, selected a remix set but it wouldn't load because the track was playing (not the samples, just the track).

    I'll try it again when I get back from work, maybe it's just me being thick again... :)

    Thanks!
     
  12. zephry

    zephry NI Product Owner

    Messages:
    1,951
    Maybe quantize makes it play out?
     
  13. Pjotr123

    Pjotr123 NI Product Owner

    Messages:
    187
    It will only work if you change the settings "load track if deck is playing" in the setting menu. Standar behaviour of Traktor. Uncheck this and you can load any track when the deck is playing.
     
  14. jarnow

    jarnow New Member

    Messages:
    3
    Thanks a bunch, man! I didn't know this setting, I feel a bit dumb right about now...

    Time to practise again.
     
  15. fun_invest0r

    fun_invest0r New Member

    Messages:
    10
    I have a question, though. I specifically enabled the option to load into a stopped track only - does it mean one has to turn it off in order to be able to load new remix sets from F1? Needless to say, this is not a very well thought out approach in this case.

    Do I have to resort to my trustful MC6000 to switch to deck C/D and stop the playback or is there a way to _stop_ playback completely from F1 after all?
     
  16. jdownesbaird

    jdownesbaird Forum Member

    Messages:
    437
    Definitely agree!
     
  17. iMike

    iMike New Member

    Messages:
    15
    So there isn't a way to map the buttons the other way around? I don't see the point of muting the samples, if you could stop and retrigger them just as easy.
     
  18. zephry

    zephry NI Product Owner

    Messages:
    1,951
    You could map a keyboard shortcut. Or map a modifier condition somehow to the f1. I am thinking something to do with the delete mode.Not sure how yet. Or maybe switch to midi mode via the shift+browse then map whatever function you like in that.
    I have found that once you switch to midi mode via the shift+browse any custom mapping is in that mode only?

    But yeah if you dont mind any extra functions to be in midi mode you can do whatever.
    ---
    Also I think the stop behavior has something to do with sync and how it all works smoothly. And quantize. If you have a specific flow going using quatize and having everything timed the way you like. Then stopped the deck and started back up It may to sound quite the same being triggered at different parts? Just a thought? Something like that would not matter for oneshot type triggering or randomness.
     
  19. Pjotr123

    Pjotr123 NI Product Owner

    Messages:
    187
    So, I tried a couple of things and found a temporarily workaround.

    1. In the Controller Manager, I added a new F1 user mapping (default blank one). Manually set the input tab to Kontrol F1, otherwise it won't work.

    2. Add a Modifier for the Shift button ( I use modifier #1) and set it to hold, direct, value 1.

    3. Add play/pause function to the mapping and assign it to the stop button on F1 (one of the four). Set modifier condition to Mod#1 =1. Assign the funtion to the deck you want to kontrol (for me Deck D). If you want this function for all four buttons, you have to copy this mapping four times and assign it.

    Now you have two F1 user mappings in the list of controllers. The original one and the new one. If you now use the native Mixdeck control on F1, the assigned stop function button (while using Shift) will stop the mixdeck. You will loose the stop function per Mixdeck slot. I don't use that anyway, since mute is sufficient now.

    Only fallback: if you want to use the native user mapping of F1 (Shift + browse) to control Decks A/B this new function will still be active. In order to use this function, you have to go back to the Contoller Manager and set the input of the new added F1 user mapping to "none". Have to find a way to solve this, since the Shift + browse function on F1 automatically switch the default and user mapping inputs, but not any added user mappings.

    Hope this helps some people.
     
  20. psynapse

    psynapse Forum Member

    Messages:
    51
    Wait.. you mean you don't see all the functions of the F1 in the Traktor when you plug a unit in?