1. Please do not install macOS 10.15 Catalina yet, as Native Instruments software and hardware products are not supported under macOS 10.15 yet. For more info, please go HERE!
    Dismiss Notice

First Impressions of 2.1.2 update... Any Good..?

Discussion in 'TRAKTOR PRO / TRAKTOR SCRATCH PRO' started by dannybyrne29, Dec 5, 2011.

  1. technicaltitch

    technicaltitch Forum Member

    Messages:
    59
    For me 2.1.2 performance seems to be pretty much identical in terms of audio. (If it goes to 99% processor while it over-buffers stuff, but it glitches less, that's good by me. I don't mind if the processor's running like a f***ed clock, the GUI looks like a frozen Spectrum game and the S4 starts melting, as long as the punters are none the wiser.)

    The tap function seems to override the default 300 now, whereas it didn't reliably before, I think. However Traktor still can't handle me scrolling through a playlist without the audio glitching, which is pretty unacceptable. It is odd - sometimes I can scroll at immense speeds fine, but I'll then scroll slowly and it'll cause the audio to freeze. For me this is far and away the biggest issue - if I play live I use MediaMonkey in place of the browser, although it is an absolute nightmare and hardly making the most of my S4..hoping it is fixed SOOOOOON!
     
  2. ekwipt

    ekwipt NI Product Owner

    Messages:
    1,100
    I agree with larger pool of beta testers, why not use everyone who wants to beta test be a tester.

    NI you havea lot less headaches in the final versions, you could open up a beta area to all beat testers and start responding more in the forums. I can't see why this is so hard. The ticket system obviously doesn't work that well.
     
  3. stroumf77

    stroumf77 NI Product Owner

    Messages:
    713
    dariodelima
    do you use midi controller ?
    I have the same problem like you.
    (my setup cd time codes & midi controller)
    I explain : when the time code is stopped at 0:00 (zero minute - auto cue) and i press in my midi controller the ''hot cue'' button (it happens for all the cue numbers), then i have the same results when i hit the play (as i see in your video).
    The only solution that i found is.. i must play the time code for a second and then push the cue button in the midi controller and then i can pause or cue the timecode.
    I think we have the same problem ! I am not sure if the problem is the same because i cant see how did you get into Relative mode (so i guess because of a midi controller).
    i am talking about that video : http://www.youtube.com/watch?v=FdiZkdjwNfo&feature=youtu.be
    + that happens to me and with all the TSP2 versions. With TSP1 all ok.
     
  4. DJ.KroNiX

    DJ.KroNiX New Member

    Messages:
    7
    I Wish I could use my Software without being worried on the club that it might crash, in front of HUNDREDS of people! I was SO Pleased with 1.2.7 (TSDUO) and Love Traktor so much that i bought tsp2 Expecting the same quality. Its frustrating to feel the need to downgrade TWICE (2.1.1 and 2.1.2) to 2.0.3 to be able to use the dj software (AND HARDWARE) I bough with my hard earned money. Please NI, PLEASE DON'T DISAPPOINT ME OR ANY OTHER TRAKTOR USER!

    Best of wishes to all, and a verry merry Christmas From Puerto Rico!

    -Joshua (DJ KroNiX)
     
  5. dariodelima

    dariodelima NI Product Owner

    Messages:
    164
    hey stroumf77

    Yes thats the identical problem i have, i use cd timecodes and the x1 controller, i have not tried playing a second and then pressing cue as you say, i will try that tomorrow and see if it works, i that is in true fact, then it must surely have something to do wit the old mk1 cds, perhaps it will work better with the mkII's....it is really frustrating as this issue was not there in verson 2.0.3
     
  6. perversity

    perversity NI Product Owner

    Messages:
    21
    I've been using 2.1.2 for a couple a days and have noticed some problematic behavior. Audio that was routed thru the cue was cutting out, so far it's stopped after doing a reboot. Also, while doing basic mixing with no fx or track manipulation, the Track Stripe sometimes goes blank.
    I use the S4 controller to do a beat juggle with the same track loaded on decks A and B, and I use the load button quite a bit to get the tracks re-aligned and sometimes it will load the track back to the beginning.
    none of this happens on 2.0.3.
    CPU usage seems to be fine on my setup and I haven't had audio cutting out thru the mains yet, so it's better than 2.1.1 so far
     
  7. schranzinator

    schranzinator NI Product Owner

    Messages:
    299
    hello ni fuzzies,

    why do cubase, reason and live perform so good with asio/core audio and traktor so extremely bad since version 2.1.1 ?
     
  8. MrOpa

    MrOpa New Member

    Messages:
    3
    Used 2.1.2 out last nite. Tried the affinity trick with adjusting CPUs no luck.
    Seems to be a lot more sluggish and my system is tweaked completely for traktor.

    Cpu usage is 60% right up to spiking.. Pops and clicks sometimes when redlining.
    All the help/tweaks on the forum ive done.. and still cant reduce the CPU.

    2.0.3 is the most solid version ive found. with 2.0.1.5 audio 8 DJ driver.
    And im using a AMD Laptop as well. With Win7-64bit 4gig DDR2-800 and a 500GB Seagate Momentus XT

    :( A bit disapointed since 2.1.1 multicore has made the software worse :(


    Cheers
    Angelo
     
  9. VesperDJ

    VesperDJ New Member

    Messages:
    10
    I would love to know how many of you guys that are still having all the audio glitches and drop outs and high CPU, are STILL using AVG Antivirus on your laptop.

    This has been a known problem for ages.
     
  10. cBlaq

    cBlaq Forum Member

    Messages:
    358
    what antivirus is recommened if any?
     
  11. dannybyrne29

    dannybyrne29 NI Product Owner

    Messages:
    2,342
    one you can disable... i use norton and have no issues when its switched off in the task bar
     
  12. dahJah

    dahJah NI Product Owner

    Messages:
    295
    I can report that it is working flawlessly and even better than before. Good job NI!
     
  13. djsubculture

    djsubculture NI Product Owner

    Messages:
    103
    Unfortunately the default .tsi file for the MC6000 don't work. The faders and knobs will move, but I can't load a track.:angry:

    The Denon .tsi file, does work. Unfortunately, I don't really care for that .tsi file. :(
     
  14. thebretch

    thebretch NI Product Owner

    Messages:
    25
    So.... Is it me... Or is it mainly us pc users that have huge cpu usage issues since 2.1.1
     
  15. GRiNSER00

    GRiNSER00 NI Product Owner

    Messages:
    137
    Microsoft's Security Essentials is free and should do the job quite well (it's taking up virtually no resources), used it on all my Windows machines so far.
     
  16. shadow23

    shadow23 NI Product Owner

    Messages:
    764
    +1

    Been using it for years now ever since Win7 came out.
     
  17. djmgj

    djmgj NI Product Owner

    Messages:
    720

    im assuming its just you ;), go threw the threads. The cpu usage is problematic for both pc and mac users.
     
    Last edited: Dec 12, 2011
  18. pasik

    pasik NI Product Owner

    Messages:
    179
    To me it *looks* like high cpu usage is a problem for users having mostly AMD cpus.. at least that's what i've noticed from multiple "problem reports" here on the forums. Dunno if that's a fact :)
     
  19. technicaltitch

    technicaltitch Forum Member

    Messages:
    59
    Just a thought - have you tried, under Timecode Setup, UN-ticking "Switch to absolute mode when loading", and ticking "Switch to Absolute mode in lead-in". Realize it isn't what you're looking for but thought it might be a handy workaround in the meantime.
     
  20. cBlaq

    cBlaq Forum Member

    Messages:
    358
    just the av, or do u have a suite?
    ---
    thanks, i hate to use one of my user licenses from my norton 360 3 pack, just for my DJ machine. i will check it out!
    ---
    thanks for the +1!
    ---
    someone should start a poll on this, i have a first gen i5, i will check mine, where do i observe the CPU %? i dont have a external sound card