G4 experiences thread - problems & solutions

Discussion in 'TRAKTOR SCRATCH' started by djquartz, May 8, 2007.

Thread Status:
Not open for further replies.
  1. djquartz

    djquartz NI Product Owner

    Messages:
    5,321
    For G4 users having problems, please post your system info here.

    all G4 users NOT having problems, please use this thread also.

    this thread should collect all the G4 users and their issues, share optimization tips if you did some. please use quartz' draft and share our knowledge! - ng


    Type of Powerbook:

    Traktor Scratch Version:

    CPU Speed:

    Ram:

    Mac OS Version:

    Hardrive Free Space:
     
    Last edited by a moderator: May 9, 2007
  2. FunkyRob

    FunkyRob Forum Member

    Messages:
    87
    For G4 users having problems, please post your system info here.

    Type of Powerbook: Not sure what you mean, it's a 15". Is that it?

    Traktor Scratch Version: 1.0.1.020

    CPU Speed: 1.67 Mhz

    Ram: 2 GB

    Mac OS Version: 10.4.9

    Hardrive Free Space: 19.39 GB


    With all the people griping, why am I the first to post? I've done all that's mentioned in the manual, but I'm still getting audio drops, seem completely random. When I changed to 44100 Khz and 7.0 ms it helped but still happens. Also MASTER meter goes all the way to red sometimes.
     
  3. crucial d

    crucial d NI Product Owner

    Messages:
    1,719
    latency

    Rob, you have your latency set too low. At the moment G4's should be set no lower than 10ms, AFAIK in the very near future there will be optimisation updates from NI to address this.

    Change it up to 10 ms & see what happens.

    (I'm assuming you have turned off Bluetooth, Airport & Expose)

    Cheers,

    Crucial D
     
  4. FunkyRob

    FunkyRob Forum Member

    Messages:
    87
    Never thought of turning off the Bluetooth.

    What's Expose? I never heard of that.
     
  5. DiDigital

    DiDigital NI Product Owner

    Messages:
    915
  6. FunkyRob

    FunkyRob Forum Member

    Messages:
    87
    Yeah thanks, but I turned all the widget crap off when I first got the computer early last year. It just seemed like it would be doing way too much background processing. Some of them are quite cute though, but who needs it?
     
  7. BigBuddha

    BigBuddha Account Suspended

    Messages:
    286
    But turn off Expose is kinda joke, heh? I'm on a Mac and would never turn off Exposé to get TS work. C'mon!!
     
  8. gs

    gs NI Product Owner

    Messages:
    28
    OK. I cant even get the thing Audio 8 Working to play something from i tunes!

    I have installed the driver. When I go to the Audio/midi utility or sound in System preferences it says the audio has no output/input controls. In the audio/midi utility the audio 8 controls are dimmed out, like I cant control the volume of the audio 8 outputs, no matter what stream I choose.

    Please someone help Im getting fed up I cant even use the thing. When I play the demo track in TS there is activity in the master level but the out LED do not blink.

    Am I doing something wrong? Please help.

    BTW: g4 powerbook 1.67, 1.5 gig ram, osx tiger, stripped down version of OS.

    Thanks
     
  9. phazers

    phazers New Member

    Messages:
    2
    hi,
    first post, greetings.

    wish it were not the case, but here goes a post about not being able to use TS on my powerbook g4. FS2, SSL both run fine, however TS craps out.

    Type of Powerbook: g4 12in

    Traktor Scratch Version: 1.0.1020

    CPU Speed: 1.5 GHz

    Ram: 1.25 GB

    Mac OS Version: 10.4.9

    Hardrive Free Space: 60+ GB

    ______________

    After gleaning all I could from these here forums, its seems that things are still no where close to be stable enough to play out with. To be honest, I am incredibly taken back by the fact that NI could release this thing to the public fully knowing how many people are still using G4 rigs to play out with. They must have encountered issues with the machines they tested this on that were still in G4 land. I am stunned, really.

    Just to share my story for other users:::

    I hooked up TS to my powerbook and at first things seemed nice, all the rumors I had been hearing from other powerbook users seemed like so much bad luck.. however it was not minutes into my first mix session that things began to get hairy.... Suddenly pitch went wild, massive distortion, UI moving slowly, you name it, the thing just basically died. Closed the app and the Apple crash report thing popped up.

    Yeah.

    So, I decided to reformat the powerbook and install a fresh copy of OSX. Mind you, this powerbook is in top-shape, all RAM from apple, etc. I know 100% that the hardware is fine. As I mentioned before, FS2 and SSL work smoothly on this config.

    After reinstalling the OS and running updates, etc, 2.5 hours later I was ready to give it a shot. TS is the ONLY thing installed on this machine besides the requisite OS components. I even stripped out all the unnecessary items: bluetooth off, airport off, expose off, dashboard off, shadowkiller killing shadows, you name it. I have this thing configured as a dedicated TS box now.

    The test:

    Fired up TS, turned off all the items recommended in various threads to free up processing power, set sound card latency to 13ms. (above 10ms per someone on heres' suggestions).

    Load tracks, looks fine. Put the needle down on the time code vinyl on the track I want to bring in, and the playing track pops, a slight jitter in the output. things are not looking good.

    seems to go fine for about 15 min without any pops, etc, then suddenly BAM, totally craps out like some one threw a snake in the fan. It's a rather ugly affair Im afraid. Had to close down the app and reopen it before anything was mixable again. The software (TS) was using 20% system resources at the time of the freakout. I logged all processes to a .trace file for later perusal. At the time it was going crazy and outputting the wild sounds (I don't know how else to describe it), the system still had 46% free processing overhead.

    Based on this, its not a system issue, or system resource issue. It leads me to only one conclusion, the TS software itself. Seems like development may have spent too much time on the Intel instruction set side and not enough on the PPC optimizations.


    So, as it is this product is not usable on a G4 machine.

    Let me say once again for the record, it is beyond belief that NI would state in the required system specs that this product would work on a G4, however, the reality is that is will not.

    Of the 4 people I know that have TS here in my city, all of us tried it on our g4s only to replicate the exact same results (seemingly random crap outs). And based on what I have seen on the forum, that same applies to users all over the world who are unlucky enough to still be G4-based TS users. That should be enough anecdotal evidence to support my above statement that this doest work on g4s. ...


    Im not yelling or getting pissed, I just want to know one thing, and one thing only:

    When will native release a patch that works to fix these G4 issues? I can wait to for a patch to come out, but given the breadth and scope of this issue as it stands at present, NI needs to start being forthcoming with a time frame to address this issue.

    Let's have it, when is this going to get fixed?

    In the interim I have moved TS to my WinTel machine and it runs just fine. However the 12in G4 is my preferred gigging machine. I dumped 60,000 YEN on this sucker to use on the mac ‘cause NI said it would work.




    Peace and Respect,

    Akishige Kanemitsu
    Yakiniku-beefheart Captain
     
  10. trat

    trat Forum Member

    Messages:
    59
    Shipping this product with a bugfix in the pipeline before it's release sounds like shipping beta.
     
  11. trat

    trat Forum Member

    Messages:
    59
    Why you need to turn off all those stuff. I play with SSL without any special things on or off.
     
  12. BigBuddha

    BigBuddha Account Suspended

    Messages:
    286
    You say it - a big but expensive joke.

    NI SHOULD THEIR WORK DONE. NOW.
     
  13. PhilL

    PhilL Moderator Moderator

    Messages:
    7,084
    Hey Phazers can you shoot me an Email ASAP, got a couple of questions for ya... [ jplewis01 AT comcast DOT net ];)

    Phil
     
  14. DJ Freshfluke

    DJ Freshfluke Traktor Mod Moderator

    Messages:
    26,765
    because SSL lacks of a lot of features, plus it uses it's own drivers and not asio drivers.

    more processor/ ram load is the price of the flexibility that TS users have.
     
  15. trat

    trat Forum Member

    Messages:
    59
    Great...
     
  16. BigBuddha

    BigBuddha Account Suspended

    Messages:
    286
    Excuse me native, I didn't get the causal relationship between asio drivers and poor performance?
     
  17. djquartz

    djquartz NI Product Owner

    Messages:
    5,321
    Let's keep the SSL vs TS discussion out of this thread.

    This is for G4 issues specifically and it doesn't make sense cluttering it up.

    Thanks.
     
  18. DJ_Rob_Berry

    DJ_Rob_Berry NI Product Owner

    Messages:
    25
    Hi there,

    I´ve done the things from the manual and the mac OS-tipps from the NI-site. Got totally the same problems as mentioned above.
    The sound is kind of poor and becomes poorer and shortly drops while loading a new track into the non-playing deck.

    Sometimes TS really freaks out and plays tracks with a freaky kind of delay/drop-out. It wont´t end when you switch away from the timecode to a normal play mode. This you can just end by restarting the application. In this condition you cannot use it in the club!

    C´mon guys at NI - Fix these things! Schnell schnell!

    Playing with:
    PowerBook G4
    CPU: 1.67 GHz
    RAM: 1GB DDR SDRAM
    Traktor Scratch Version: 1.0.1020
     
  19. will-i-am

    will-i-am NI Product Owner

    Messages:
    1
    i have a powerbook g4 1.67ghz with 1gb of ram osx 10.4.8.
    i am running 8 ms latency at 44.1 khz

    when i had traktor scratch analyzing my music, about 4,000 songs from an external drive, i had similar problems as everyone else. now everything is set up and analyzed, me and my brother were at it til 2am. with out any pops or glitches. traktor scratch runs fine for me, knock on wood.
     
  20. DJ Freshfluke

    DJ Freshfluke Traktor Mod Moderator

    Messages:
    26,765
    asio drivers allow to use the audio 8 also as normal soundcard for other music applications.

    ssl uses their very own drivers, which means that the box cannot be used for anything else, but on the other hand this handmade drivers allow a better performance.

    higher loads for the computer is the price of the flexibility that TS offers.

    anyways, the G4 update is around the corner and announced for the beginning of next week and i really hope it fixes the problems for y'all!
     
Thread Status:
Not open for further replies.