Help! still having issues with Reaktor and Monark

Discussion in 'REAKTOR' started by Eric-(, Dec 6, 2019.

  1. Eric-(

    Eric-( NI Product Owner

    Messages:
    35
    Hi,

    I've been struggling like crazy since yesterday to figure out why Monark was only working on channel 1 in Reaktor, and why other instances of Monark on other channels failed to work in spite of receiving correct midi input in my DAW.

    After reading many posts on the web, I came to understand that Monark’s factory midi settings were set by default to 1 instead of “omni” (like other NI’s instruments, which is downright stupid).


    Eventually I came across a solution which seemed to work at first:

    - 1: I opened Reaktor standalone version, and accessed “edit” and “connect”
    - 2: I set midi channel from 1 to omni
    - 3: I saved Monark’s ensemble to ensure that settings would be applied by default from then on
    - 4 I opened my DAW (Samplitude Music Studio 2017), and created several midi tracks with 1 instance of Reaktor/Monark for each. I checked for each instance that midi in was still set at “omni”. They were.
    - 5: I then checked that all the tracks were receiving midi input: sure enough, I had chosen a different presets for each instance
    - 6: Then: bingo: it worked! All tracks were working perfectly

    It could have been a happy end but….
    - I closed Samplitude
    - I wanted to test it out again from step 2
    - And then: it didn’t work anymore: sound was coming out from channel 1, but all other Monark instances on other tracks were desperately mute
    - So I checked in Reaktor’s instances midi in: they were all set at “omni”
    - I went back to Reaktor standalone, saved again, opened my DAW again, and created various tracks with Reaktor and Monark for each… still the same issue. I’ve tried about 10 times in a row, even shut down my computer and fired it up again. To no avail.


    It’s getting frustrating, I’m tearing my hair out: what’s wrong with Reaktor? Why did it work perfectly the first time? Do I have to do something with the .dll? Help!
     
  2. Eric-(

    Eric-( NI Product Owner

    Messages:
    35
    one piece of additional information: I've been using Monark with the player version for several years, before upgrading to the full version a few days back. Do I need to upgrade Monark too, to a newer version to solve the issue?
     
  3. Paule

    Paule NI Product Owner

    Messages:
    5,644
    I order Monark in Dec 2015. There is no newer version than this from 2013
     
  4. ghizzu

    ghizzu New Member

    Messages:
    15
    Load Monark in Reaktor.
    Click on EDIT (the button near the magnifyng glass). A strip should appear with "Panel > Monark" written on it. Click on "Monark".
    The Structure of the Ensemble should appear. Click on the icon with the little keyboard and the name Monark (that is the Instrument!).
    The icon frame should become colored in cyan. Press F5. On the left panel, click on the tab "Connect". The Midi options should appear.
    Choose "Omni" for the Midi In Channel. Now, on the strip "Panel > Monark" click on "Panel". Exit Edit mode clicking again in the EDIT button.
    Now save your ensemble with another name (for example MyMonark) and use that in your DAW.
     
    • Like Like x 1
  5. Eric-(

    Eric-( NI Product Owner

    Messages:
    35
    thank you Ghizzu, I did exactly what you said and at last... it works. I saved my own ensemble, then recalled it, the midi in setting was still set to omni. thanks a bunch buddy, you made my day! :)
     
    • Like Like x 1
  6. Eric-(

    Eric-( NI Product Owner

    Messages:
    35
    I know that Reaktor is kinda complex, but why has NI never provided any clear information with Monark, nor provided any update that would make thing easier. That beats me