1. Hi everyone,

    This forum is now closed for posting. If you require technical support from NI or have a questions about activating your product, please head over to our new Support Community!

    NATIVE INSTRUMENT SUPPORT COMMUNITY

    The Support Community is the new location where you can expect to receive assistance and feedback on technical support, sales or installation issues from our Support Agents and other users.

    Please also note, questions about the status of an order should always be directly sent to our Order Support team HERE.

    Best wishes, 
    The NI Team

High CPU loads

Discussion in 'Technical Issues (Archive)' started by Lotuz, Feb 20, 2009.

Thread Status:
Not open for further replies.
  1. Lotuz

    Lotuz NI Product Owner

    Messages:
    1,474
    My PC is a WinXP SP3 P4 2.8 GHz with 1 GB RAM and it's having big trouble playing the demo songs. May I ask what specs are required to play the demo songs smoothly and still be able to operate the Maschine software without the CPU going sky high?



    Not Maschine related, but hopefully someone here can help me solve this:

    My USB 2.0 PCI card by Conceptronic is causing the soundcard (E-mu 0404 PCI) to crackle. When I disable it, the crackling is gone. But I need it to connect the Maschine controller. Does anyone know a solution to this problem?
     
  2. ew

    ew Moderator Moderator

    Messages:
    21,330
    Their minimum specs are optimistic, I think- and if you're taking them off the box, are different than the ones given on the Maschine page:

    http://www.native-instruments.com/n...schine/videos/?page=maschinespecs&content=101

    With hyperthreading disabled in your P4, you should be able to play the demo tunes though, I'd think. If you don't have hyperthreading disabled, I'd advise that you do so.

    The upcoming update's more optimized than the release version.

    ew
     
  3. Lotuz

    Lotuz NI Product Owner

    Messages:
    1,474
    I'm downloading the 1.0.2 update right now. Hopefully this version will run better on my PC. :cool:
     
  4. Lotuz

    Lotuz NI Product Owner

    Messages:
    1,474
    Not really. In fact, it seems even slower now. :(

    Is the 2 GB RAM requirement crucial for good performance?

    I'm not sure if I should increase the performance of my computer by adding 1 GB RAM or if I should buy a new computer. My other VSTi samplers (Battery, RMIV, Halion3) run fine on my computer. I like Maschine, but since it doesn't work entirely the way I'd like (see my "bypassing" thread) I'm having doubts if Maschine's worth the investment of a new computer. :S
     
  5. Funky D

    Funky D Forum Member

    Messages:
    71
    I have a P4 3.2GHz with 2GB of RAM and have some skips and stutters as well, so the RAM probably won't help you much :(

    Turning off hyperthreading helped a bit, and I overclocked to 3.5GHz, but I still get glitches in about half the demo songs.

    I'm thinking the effects are the CPU hogs, but I also had some slowdowns switching between patterns on a song with only a few tracks and effects. But that was after using Maschine for about 4 hours straight, so maybe a restart would have helped.

    Paul
     
  6. Lotuz

    Lotuz NI Product Owner

    Messages:
    1,474
    Thanks Paul. Looks like a new computer is the only way to go if I want to keep using Maschine. Tough decision. :S
     
  7. sowari

    sowari Moderator Moderator

    Messages:
    27,960
    maybe you guys need to increase the Latency/buffer size with your Soundcards?

    sowari
     
  8. Lotuz

    Lotuz NI Product Owner

    Messages:
    1,474
    That helps for playback, but you don't want increased latency (20 ms or more in my case) when you're playing the pads. Any idea why this piece of software is so heavy compared to other soft samplers?
     
  9. ew

    ew Moderator Moderator

    Messages:
    21,330
    A lot of it's the FX as you guessed earlier.

    ew
     
  10. Lotuz

    Lotuz NI Product Owner

    Messages:
    1,474
    My P4 has served me well over the years, but it's time to upgrade, so I've ordered a new PC (Core 2 Quad Q8200 2.33GHz 3 GB RAM) this morning. Maschine better run well on this PC! :angry: ;)
     
  11. MykeJ

    MykeJ Forum Member

    Messages:
    93

    Can you let us know if it helped. I have a 2.13 with 1gig and if I start to use FX the CPU can go to red pretty fast. thing is I got the poping to stop buy turning down the volume in maschine but I want to get the CPU to stop going red.
     
  12. Lotuz

    Lotuz NI Product Owner

    Messages:
    1,474
    My new PC should be ready to pick up this Friday. I'll let you know how it's running this weekend. :cool:
     
  13. Funky D

    Funky D Forum Member

    Messages:
    71
    I may have to look into upgrading as well... once the CPU usage hits 60% or so the interface starts to lag. Hit record and the CPU usage bumps from 60% to 90% and the pads are basically unusable :(

    I'm running a Tascam FW1884 with a 512 buffer size. My P4 may be long in the tooth, but Maschine is the first VST to really bring my system to it's knees. Kore is a bit of a hog, but at least it's still usable at high CPU usage.

    I look forward to how your new system works out as well Lotuz!
     
  14. Suicide Server

    Suicide Server Forum Member

    Messages:
    515
    Everythings fine here on a 2,4 GHz Core2
     
  15. Lotuz

    Lotuz NI Product Owner

    Messages:
    1,474
    I'm checking the demo songs on my new PC now. So far it's running smooth! :cool:
     
  16. SB1

    SB1 New Member

    Messages:
    4
    Maschine kills my 2ghz Core2Duo laptop.

    Literally playing 16 samples, 8 of them with fx, is enough for the audio to start dropping out. Surely this can't be right? Is this a bug or a lack of optimisation?

    Maschine has got so much potential but it's almost useless with my (not especially old) laptop.
     
  17. ew

    ew Moderator Moderator

    Messages:
    21,330
    You should be getting better results than that. It sounds like you've got speedstepping going on.

    Power scheme set to max performance (Vista)/always on (XP)?

    ew
     
  18. SB1

    SB1 New Member

    Messages:
    4
    I can't believe I forgot about that! Thanks a lot ew, you've made my day :cool:
     
  19. MykeJ

    MykeJ Forum Member

    Messages:
    93
    Good to hear I installed maschine on my wifes computer with 1.6 core duo and it runs great. I had 16 FXs going and the CPU was still running at maybe 10-12% at its highest. So I think I have to upgrade. My 2.0 runs at 30% min with maschine and when I 1st start it or load a sample it goes up to 100%:( . So its time to go shopping because I like Maschine a lot.:D
     
  20. iyacyas

    iyacyas New Member

    Messages:
    3
    ew- I'm hoping you or someone have a different set of tricks for me or, this is going back. Have a Core D (desktop) 2.8ghx and 3 GB of RAM. Yet, Machine is just killing the CPU. Dropped all other processes, disabled internet, bought a new soundcard (helped latency), disable, virus scanning. etc etc.. power set to always on..tried setting priority higher, set affintiy to 1 cpu vs. 2 (and vice versa...) but, still the songs drop out and stutter... even so much as viewing different parts makes it hiccup.... any other thoughts? Just really disappointed at the CPU usage..have Traktor and run 4 decks with effects with no issues etc....
     
Thread Status:
Not open for further replies.