Host Transport Control doesn't work with Komplete Kontrol MK2 due to NI removing MCU support

Discussion in 'KOMPLETE KONTROL SERIES' started by HammyHavoc, May 20, 2018.

  1. trusampler

    trusampler NI Product Owner

    Messages:
    1,742
    Presonus Studio One users, have you guys found an easy way for auto select to work? I thought it was working, but I found in order for me to keep up with the tracks, I have to manually select the track first in daw, and then use the instance button to then select correct tracks..

    Any one found a way for Auto Select to work?
    thanks
     
  2. Kymeia

    Kymeia NI Product Owner

    Messages:
    5,852
    Works for me - if I setup a MCU device and add KK DAW-1 as input and output I can get transport, record, stop and track cursor to work using transport controls and jogwheel from my Series 2 keyboard. What I can't get to work is everything else (eg pan, solo, mute etc).
     
  3. Slappz

    Slappz NI Product Owner

    Messages:
    339
    So I deleted my last post because I did finally get it to work. I'm not really sure what I did, but I really just switched between using the Mackie profile and the generic one. The thing is it didn't work the first time I used the Mackie profile, so I'm not sure what happened. I'll have to play with it more to give some more feedback on it.

    Edit: I seem to have also got it working in Mixcraft 8, but haven't fully tested it yet.
     
    Last edited: Jul 9, 2019
  4. Xyenz Fyxion

    Xyenz Fyxion NI Product Owner

    Messages:
    313
    Thanks, I'll try it again.


    Sent from my iPhone using Tapatalk
     
  5. Tommaso Scalici

    Tommaso Scalici New Member

    Messages:
    9
    I feel stupid, maybe I'm missing something obvious, but I still can't get transport control on Studio One. I tried setting new device twice, one as a MIDI controller (input from Komplete Kontrol) and the other one as Mackie Controller Unit (input from Komplete Kontrol DAW) but still no transport control. I get MIDI input if I press some button (like play, stop, record, etc.) but it just does nothing.
     
  6. Aymara

    Aymara NI Product Owner

    Messages:
    1,643
    Maybe this helps?

     
  7. Xyenz Fyxion

    Xyenz Fyxion NI Product Owner

    Messages:
    313
    I meant to come back last night and say I got it working. The video shows how. Just set it up as a 'Mackie Control' device, and select Kontrol - DAW. I made my own NI device with the same settings, and it didn't work.

    I'm on a Mac, but it might work for Windows, too. Very silly how that was the issue.


    Sent from my iPhone using Tapatalk
     
  8. Uwe303

    Uwe303 NI Product Owner

    Messages:
    4,485
    The problem, if you do it not with the pre defined mackie device, is the missing hand shake and then the keyboards behave differently. Im now on it to find out what's exactly going on cause I have a mackie device and so can't have a second mackie master in cubase but I want my A49 controller to control something but unfortunately in midi mode all the buttons are missing and the 4d encoder. But native, as far as i understand, will make an own integration for cubase again!?

    Uwe
     
  9. Kymeia

    Kymeia NI Product Owner

    Messages:
    5,852
    That's what I said to do
     
  10. Tommaso Scalici

    Tommaso Scalici New Member

    Messages:
    9
    Followed step by step, but still doesn't work, thanks anyway...

    EDIT: Switched off and on the keyboard, and now it works, lol. Thanks
     
    Last edited: Jul 25, 2019
    • Like Like x 1
  11. Mesut bakıcı

    Mesut bakıcı New Member

    Messages:
    4
    Does fl studio work?
     
  12. Aymara

    Aymara NI Product Owner

    Messages:
    1,643
    It seems so ;)

     
  13. Blindeddie

    Blindeddie NI Product Owner

    Messages:
    197
  14. Lab Rat

    Lab Rat NI Product Owner

    Messages:
    256
    Is this just for the MK1 series? I got transport controls in my MK2, but the Metro and Tempo buttons don't light up.
     
  15. Aymara

    Aymara NI Product Owner

    Messages:
    1,643
    The video was about the Mk1, yes. I thought, the Mk2 should behave the same now, but from your post it seems, it‘s a bit different.

    Does above post #553 help? That screenshot in the other thread was from an A-Series, that also might behave different. But the configuration should be the same.
     
  16. Lab Rat

    Lab Rat NI Product Owner

    Messages:
    256
    Not much help in that post. Here's screenshots of how I have it set up.
     

    Attached Files:

  17. Aymara

    Aymara NI Product Owner

    Messages:
    1,643
    Your screenshots are from Studio One, not FL Studio, right?

    But the setup looks correct. I myself use a Mk1 in S1 and everything works as expected.
     
  18. Lab Rat

    Lab Rat NI Product Owner

    Messages:
    256
    Right, that's Studio One. I owned MK1 at one time, and it worked fine. Something must have changed in MCU between the two versions.
    I also use Ableton, and it works fine.
     
  19. Blindeddie

    Blindeddie NI Product Owner

    Messages:
    197
    The Studio One Mackie Control Driver might not work in this case if the DAW /Driver requires a "handshake" with the actual hardware. I know that The M32 does not work with the standard MCU driver in another DAW I use because of this. Luckily another user of that DAW was able to Modify the Driver (an open source project) so that you can disable the Handshake requirement so you can use other MCU devices that do not support the Handshake protocol. I have one of those free copies of Studio One, (super limited version) that allows me to use my MCU pro, so when I get to the studio, I will see if it allows disabling the handshake...no guarantees, but will give it a shot!

    Peace,

    Blindeddie
     
  20. Uwe303

    Uwe303 NI Product Owner

    Messages:
    4,485
    As far as i found out with cubase the a49 and I guess then the m32 too needs that handshake to enable mackie mode on those keyboards. Otherwise the transport buttons won't lit up. But I can check again.

    Uwe