How to fix El Capitan Beta problems, crashing Logic AU scan.

Discussion in 'Computer Technology and Setup' started by matthiaswitt, Sep 22, 2015.

  1. matthiaswitt

    matthiaswitt New Member

    Messages:
    7
    Hello,
    today i found a way to fix the problem when Logic Pro crashes/hangs while scanning the Audio Units.
    This is going to be a little complicated.
    On OS X 10.11 El Capitan Apple implemented the new version of Audio Unit (3), many plugins do not pass the validation.
    To validate them Logic uses a programm called auvaltool. I replaced it with an older version (can be found online) and everything works fine after rescanning.
    Before you can replace the auvaltool you have too disable the new "System Integrity Protection", which is one of the new el capitan features and protects system files from beeing modified (like the auvaltool).

    1. Disable System Inegrity Protection by rebooting into recovery partition. Then open Utilities-> Terminal (Shell comand window)
    type in "csrutil disable", without the "" and press enter
    to restart your mac type in "reboot" and press enter

    2. Download old version of auvaltool, for example from here: https://discussions.apple.com/thread/4081659?tstart=0

    3. Open Finder, click on Go To -> Got to folder and type in "/usr/bin" (without the "")

    4. Search for the file auvaltool and make a copy of it to your desktop (if something wents wrong)

    5. replace auvaltool in the /usr/bin folder with the one you downloaded in step 2

    6. Restart Logic, Open empty project, Go to Settings-> Plugin-Manager. Select not validated plugins ant click on rescan

    I hope i did help you with this, tell me if it worked for you!
     
    • Like Like x 6
  2. mickeyl

    mickeyl Active Member

    Messages:
    196
    Thanks a lot – worked like a charm! Waldorf PPG 3.V still crashes, but all the NI stuff validates OK. Great workaround until the plugin vendors catch up.
     
  3. tubeaudiogear

    tubeaudiogear Member

    Messages:
    220
    Great, fixed in less than 5 minutes, thanks a lot!
     
  4. Dan Turner

    Dan Turner New Member

    Messages:
    1
    Thank you. This worked for FM8 and Massive, but it still doesn't work for Replika. It says that Replika crashes the validation.

    EDIT: Nevermind, I got it to validate by specifically resetting the scan for that plugin.
     
    Last edited: Sep 28, 2015
  5. matthiaswitt

    matthiaswitt New Member

    Messages:
    7
    I'm happy that it works for you
     
  6. Caseyland

    Caseyland New Member

    Messages:
    8
    Wow, this was such a welcome workaround! Back in action with my NI plugins.
     
  7. Satsamel

    Satsamel New Member

    Messages:
    5
    Did you reboot again into the recovery partition and enable System Integrity Protection after you applied the old auvatool?
     
  8. matthiaswitt

    matthiaswitt New Member

    Messages:
    7
    No, but you can to that if you want. It just hinders you to move/delete system files.
     
  9. tubeaudiogear

    tubeaudiogear Member

    Messages:
    220
    In the end I had to go back to Yosemite, too many problems with Logic Pro X on El Capitan unfortunately.
     
  10. lm425

    lm425 New Member

    Messages:
    1
    Worked perfectly for me thanks a lot! Do I need to worry about system integrity protection being disabled it sounds important haha
     
  11. Kymeia

    Kymeia NI Product Owner

    Messages:
    4,025
    I suggested in the other thread that rather than installing an outdated 2012 version of the auvaltool, which is the one in that link, which may have bugs of its own, it might be better to make a copy of the latest version in Yosemite (or even Mavericks would be more recent than the 2012 tool) from usr/bin and use that one before updating to El Capitan, or if you already have done that maybe someone could post the Yosemite version?
     
  12. koban4max81

    koban4max81 New Member

    Messages:
    4
    Could you report this to NI company and let them that you may have found the solution?
     
  13. hardy

    hardy New Member

    Messages:
    1
    You are a HERO!! 1001 Thanks!
     
  14. RaggaJungle

    RaggaJungle Member

    Messages:
    33
    For those who need to know how to disable SIP on El Capitan:
    1. Reboot the Mac and hold down Command + R keys simultaneously after you hear the startup chime, this will boot OS X into Recovery mode
    2. When the “OS X Utilities” screen appears, pull down the ‘Utilities’ menu at the top of the screen instead, and choose “Terminal”
    3. Type this command into the Terminal and hit ENTER
    csrutil disable; reboot (for the option to reboot)
    csrutil disable (without automatic reboot)

    Next - > GO through @matthiaswitt steps and you'll be golden ;)
     
  15. lowengard

    lowengard New Member

    Messages:
    2
  16. AutumnElm

    AutumnElm New Member

    Messages:
    12
    Tried it! Definitely works for me. ;) Everything is verified. At first, it wasn't verifying the reverb RC plugins as well as the VC compressors and the VariComp, but I had to go in and individually sit and click on each one with a reset and rescan function. It works now. All of em! :)
    I guess I'll just re-enable the "csrutil" when NI and Apple get their pickles together. Shouldn't be a problem in the future right? I also have the original auvaltool on my desktop.
     
  17. arenaboi

    arenaboi New Member

    Messages:
    1
    wow, thank you so much. I have been bummed out at losing Battery 4 for weeks, and you just saved me in 5 minutes or so. Very grateful :)
     
  18. ThaCoby

    ThaCoby New Member

    Messages:
    3
    i Need help!!!

    steps 3 -5 are pretty confusing.
    I don't have a "Go to" folder so where do I type in "/usr/bin"
     
  19. ThaCoby

    ThaCoby New Member

    Messages:
    3
    can u explain steps 3 - 5? u explain things pretty good.
    where do I type "/usr/bin"... he said type it in the "Go To" folder but i don't have one
     
  20. ThaCoby

    ThaCoby New Member

    Messages:
    3
    nvm! He meant click on "Go To" from the menu at the top
     

Share This Page