How to fix El Capitan Beta problems, crashing Logic AU scan.

Discussion in 'Computer Technology and Setup' started by matthiaswitt, Sep 22, 2015.

  1. LL Cool Whip

    LL Cool Whip New Member

    Messages:
    10
    Just in case....
    The El Capitan LATEST beta fixes this issue....but, might cause other issues. The latest beta fixed it for me.
     
  2. Dom Burgess

    Dom Burgess New Member

    Messages:
    1
    YES! Amazing! Thank you, you've saved my bacon! Question though...once a solution from Apple comes about, do I need to replace the Auvatool with the old one or will that be part of the update? (I would imagine part of the update but had to ask!)

    Thanks! Dom
     
  3. marinskas

    marinskas New Member

    Messages:
    2
    Could anybody help me? I have tried several times to do everything, as on instructions: booting ir recovery, opening terminal, type csrutil disable, but terminal always returns message command not found. May be in non beta version of El Capitan This is not possible?
     
    Last edited: Oct 12, 2015
  4. JOMC11

    JOMC11 New Member

    Messages:
    1
    If you are finding that not all of your plugins are validating when you select all plugins in logic and rescan (Step 6 above) - you need to select (tick the box and no others) of each plugin and rescan individually. A bit more tedious but well worth it. J
     
  5. oprahn

    oprahn New Member

    Messages:
    1
    You made my day :)
    Actually, for security reasons, after I fixed the problem with auvaltool; I enabled the SIP. I works too if you enable it after you fixed everything. Logic and Native still agree to work together.

    Marinskas, I think the problem is that you actually have to type 'csrutil disable' from the Recovery OS

    THANKS !!!!
     
  6. marinskas

    marinskas New Member

    Messages:
    2
    Oprahn, in fact I am typing 'csrutil disable' in Recovery OS, as it is told in instructions. If I would do it not on Recovery OS, it would tell me, that this comand should be run from Recovery OS. But the problem is, that in Recovery OS i get message 'command not found'.
     
  7. Junior Kegnia

    Junior Kegnia New Member

    Messages:
    2
    Hi matthiaswitt,

    At stage 5 I am unable to replace the auvatool as it won't let me drag the file into the folder could you suggest a way to get round this?
     
  8. Junior Kegnia

    Junior Kegnia New Member

    Messages:
    2
    hey how did you replace the auvatool file? as I am having issues with this

    thanks
     
  9. junklight

    junklight New Member

    Messages:
    25
    After reading LL Cool Whips post above - I thought I'd take the plunge - OSx 10.11.1 - all working fine! (this is the public beta so you don't need anything fancy to sign up to it except you already need to have installed 10.11 )
     
  10. alheeren

    alheeren New Member

    Messages:
    28
    The work around worked for me! Thank you!
    The only drawback I seem to be experiencing is that now my Mac is booting incredibly slooooowwww...
    What command do I use to re-enable the SIP?

    Thanks!
     
  11. heebie

    heebie New Member

    Messages:
    1

    Sir, you are a true hero. Thank you so much for sharing this, I've spent 2 days trying to get it work and solved it within 10 minutes after reading your post. I made this account specifically to write this thankful reply. Thank you!
     
  12. AngeloC

    AngeloC New Member

    Messages:
    5
    Hi Matthiaswitt,

    I am not a Computer Expert. Can you help me with these first steps:

    1. Disable System Inegrity Protection by rebooting into recovery partition. Then open Utilities-> Terminal (Shell comand window)
    type in "csrutil disable", without the "" and press enter
    to restart your mac type in "reboot" and press enter

    How I "disable the System Inegrity Protection by rebooting into the recovery partition"? I have never happened to do this. Please be so kind as to explain, I am going crazy with KOMPLETE!

     
  13. junklight

    junklight New Member

    Messages:
    25
    I'm kind of fascinated why people are messing about with SIP rather than upgrading to the 10.11.1 public beta (which is solid as a rock and has non of the problems with the AUs) given that the messing about seems far riskier than moving to a x.x.1 beta (Which lets face it has fixes for all the things people found wrong with the initial release) - am I missing something?
     
  14. AngeloC

    AngeloC New Member

    Messages:
    5
    Hi, thank you for your suggestion, but how do I upgrade to 10.11.1 I do not find it in the App Store nor does it advice me to upgrade
     
  15. junklight

    junklight New Member

    Messages:
    25
    if you go here https://beta.apple.com/sp/betaprogram/ you'll need an apple id (but you can just make one with a spare email address) and you register your machine (you have to download and run a wee app) and then it will be available as an update for you
     
  16. AngeloC

    AngeloC New Member

    Messages:
    5
    thank you. what is a "wee app"?
     
  17. junklight

    junklight New Member

    Messages:
    25
    sorry - I'm using colloquial english :)

    A "small" application
     
  18. AngeloC

    AngeloC New Member

    Messages:
    5
    thanks a lot. I am not English as you may imagine. I have checked out your link. I hope it will work. One question: what if I use my regular Apple ID, the one that I use for ICloud...? I mean, if I have to register my machine maybe it is better.. or am I too naif and some issue will come afterwords?
     
  19. junklight

    junklight New Member

    Messages:
    25
    Yes you can just use your regular apple id if you have one
     
  20. AngeloC

    AngeloC New Member

    Messages:
    5
    You did have not any other problem with other plugins? I have seen that in Logic even my Torpedo Wall of Sound (cab simulation by Two Notes) did not work... I am reinstalling all KOMPLETE now .. I hope that everything will be fixed soon... Three days spent in panic!