How to make keyboard transport control work in Reaper

Discussion in 'KOMPLETE KONTROL SERIES' started by Aymara, Dec 7, 2014.

  1. Aymara

    Aymara NI Product Owner

    Messages:
    1,632
    Hi,

    before I explain how to configure the Komplete Kontrol S keyboard as a MIDI Device so that even the keyboard's transport controls work, let me first give a hint to the Native Instruments people:

    Cockos Reaper is one of the most powerful DAWs, that blows away most of it's competitors, especially when considering the price, and it has a very huge and helpful fan base. So please don't shoot yourself in your own knee, as we say in Germany, and don't ignore this fact! You might sell much more products, if you would show better Reaper support ;)

    It's a joke, that I can't choose Reaper in my profile and I had to choose "other DAW" and what I will explain below, should already be available in the Knowledgebase, don't you think so?

    Ok, and now for the original topic:

    Making the keyboard transport controls work in Reaper is easier than you might think, though it's not quite obvious at first sight.

    The keyboard shows up as three devices in Reaper:

    KOMPLETE Kontrol Keyboard
    KOMPLETE Kontrol EXT
    KOMPLETE Kontrol DAW

    In Reaper Preferences only activate the Keyboard driver as a MIDI Device for MIDI In and Out, incl. Control Messages and Clock/SPP, and configure only the DAW driver as a Mackie Control Universal device in the Control Surface section. It's important, not to activate the DAW driver in the MIDI Device section, but only in the Control Surface section!

    That's all ... no individual knob configuration needed ... the whole transport section works at once.

    PS: Dear forum admins, have you ever edited a post on an iPad? It's a pure nightmare. Please fix that.
     
    • Like Like x 1
  2. Crane.

    Crane. New Member

    Messages:
    7
    Hi, is that under midi devices in preferences?
     
  3. Crane.

    Crane. New Member

    Messages:
    7
    Sorry, got it thank you....
     
  4. Aymara

    Aymara NI Product Owner

    Messages:
    1,632
    Yep, your guess was right ;)
     
  5. AL’DREAD

    AL’DREAD NI Product Owner

    Messages:
    3,889
    Hi , what wrong with your iPad ,if it's what I think, click on your name at the top of the page ,go to preferences in your n.i forum account ,click on style and change to n.i final, should solve the problem
     
    Last edited: Jul 5, 2015
  6. Aymara

    Aymara NI Product Owner

    Messages:
    1,632
    Thanks for the hint ... it was set to Default/NI-Final ... changing to NI-Final makes no difference.
     
  7. Aymara

    Aymara NI Product Owner

    Messages:
    1,632
    Such things only happen with the Novus profile for me, but we're completely off-topic now ;)
     
    • Funny Funny x 1
  8. Flojoko

    Flojoko New Member

    Messages:
    11
    Hi Aymara. I'm a recent owner of a komplete kontrol s61, I tried in reaper to follow your instruction. The vst kontrol works fine but the transport don't. When I tried to configure the Mackie Control Universal device in the Control Surface section and put the midi in and out of the kontrol , it's telling me "Control surface:Error opening MIDI inputs and outputs". Any idea why?
     
  9. Aymara

    Aymara NI Product Owner

    Messages:
    1,632
    That usually happens, when the DAW driver is also configured as a MIDI device. Only configure the DAW driver as a MCU device in "Control Surfaces" not as a MIDI device.

    Compare to this problem with a Behringer Mixer:
    http://forum.cockos.com/showthread.php?t=95118
     
    Last edited: Aug 1, 2015
  10. Flojoko

    Flojoko New Member

    Messages:
    11
    Thanks for your reply but I think It isn't, I followed your step :
    Option->preference>Midi devices>Midi input : Komplete kontrol 1 : enabled+control
    Komplete kontrol EXT and DAW : disabled

    Midi outpout : Komplete kontrol 1 : enabled+clock
    Microsoft GS Wavetable Synth, Komplete kontrol EXT and DAW : disabled

    Then in "control surfaces">add>control surface mode>Mackie control universal
    then select Midi input : Komplete kontrol 1
    select Midi output : Komplete kontrol 1
    then I click ok and a window open saying : "Control surface:Error opening MIDI inputs and outputs"

    I think I've done it right but impossible to figure out why. I tried to reinstall reaper and the driver but nothing. I've done as well the update for the kontrol...
    Any idea?
     
  11. Aymara

    Aymara NI Product Owner

    Messages:
    1,632
    • Like Like x 1
  12. Flojoko

    Flojoko New Member

    Messages:
    11
    Oh Problem fixed, you rock ! Thank you very much!
    Otherwise the integration is not taking in charge the track selection and the automatic track focus as NI said. Do you know if there is a way to set it up manually?
     
  13. Flojoko

    Flojoko New Member

    Messages:
    11
    Other question as well, when you record a track on reaper and stop it after recording, Reaper open a new window and ask if we want to save the changes or not so you have to take the mouth and click on "save all" or 'Delete all" etc So when sometime you record and try to do the best record you can, you redo it many time and you always have to catch back your mouth to select your save choice. Is it a way to do it via the keyboard and avoir to catch the mouse and click everytime? Thanks ;)
     
  14. Aymara

    Aymara NI Product Owner

    Messages:
    1,632
    First NI states clearly, that only Cubase and Ableton Live support track focus (there's an NI knowledgebase about that) and second I highly recommend Lemur in combination with Binder.

    Binder is a Lemur template to remote control Reaper with an iPad or Android tablet ... 50 bucks well spent ;)

    http://www.zvukofor.com/p/binder.html

    PS: For further Reaper specific questions I highly recommend the Reaper forums ... there are some Reaper gurus having much more experience than mine, which is pretty limited in comparison.

    http://forum.cockos.com

    That's one of Reaper's greatest strengths ... it's powerful community.
     
  15. Flojoko

    Flojoko New Member

    Messages:
    11
    ok Thanks ;)
    How about the other question for the recording window option to select?
    How do you do? just using your mouse all the time or you found a better solution?
     
  16. Aymara

    Aymara NI Product Owner

    Messages:
    1,632
    I guess the "save recording" dialog is something that requires the mouse. Ask in the Reaper forums, if someone has any idea for an alternative ... maybe auto save?
     
  17. brendan k

    brendan k New Member

    Messages:
    11
    thanks for the help i am just starting to use reaper now.
    the s49 works as a midi device fine but when i try to "browse" from the keyboard or activate the scale mode it does not work..
    any help with that ?

    thanks..
     
  18. Aymara

    Aymara NI Product Owner

    Messages:
    1,632
    If this problem only occurs in Reaper, check post 11 of this thread and make sure, the Kontrol DAW driver is configured correctly.

    It's also important to configure Kontrol Standalone first before using the keyboard in a DAW. I myself first configured every standalone instrument, that has it's own icon, then Kontrol standalone and finally Reaper. This worked like a charm on Windows 7 and OSX 10.10 with Reaper 4.

    If this even doesn't work in Kontrol standalone, there went something wrong with the driver installation. It's also worth mentioning, that many people reported problems with Windows driver 4.2.0, that didn't happen with the former release of V4. If you're affected by this issue and don't have the old driver available, contact NI Support.
     
  19. brendan k

    brendan k New Member

    Messages:
    11
    hey sorry for lack of info. i am on windows 7 as well.
    the standalone works just as it should i think. (scale mode, browsing is a breeze etc)
    bear with me here i have been using FL and sony acid for years and years.
    this is my first time on reaper and on this keyboard.
    i configured the midi and control surface as you said
    i am pretty sure the kontrol firmware is up to date since i installed it only a few days ago.
    maybe i am going about it wrong ? the way i am trying to access kontrol is opening a vst like kontakt in reaper.
    once kontakt is up, none of the kontrol options work for it.
    is there a way of opening the kontrol software via reaper that i am unaware of ?
    thanks a lot for your help.
     
  20. Aymara

    Aymara NI Product Owner

    Messages:
    1,632
    It seems so ;)

    If you load the NI instrument VSTs like e.g. Kontakt or Absynth in Reaper or any other DAW, the keyboard just uses MIDI. You need to use the Kontrol VST for lightguide and everything else to work. This is the same as with the standalone version too ... only Kontrol gives you full functionality.
     
    • Like Like x 1