New Key highlighting: matching keys and adjacent keys no longer highlight

Discussion in 'Bug Reports' started by dack, Jul 11, 2020.

  1. dack

    dack New Member

    Messages:
    2
    In Browser Details, "Color all keys" works, but not matching keys. (Also "Do not color any keys" works :/ ) This makes it much tougher to mix in key. I am using Traktor 3.3.0 108 on MacBook Pro running Mojave 10.14.6.

    Thanks for any help on this.
     
  2. Demus

    Demus NI Product Owner

    Messages:
    62
    Yes ....Just checked and it's not working on the latest beta also v3.4.0.160...On master deck or deck focus...Windows 10 latest version
     
  3. Scratch-E Con

    Scratch-E Con NI Product Owner

    Messages:
    241
    +1. Not working in latest beta (Windows 10)
     
  4. Sander @ NI

    Sander @ NI NI Team NI Team

    Messages:
    939
    I just checked this both on Windows 10 and on MacOS and its working correctly for me. Are you using Timecode control?

    You need to make sure that:
    1. Key Lock is on for each Deck
    2. Pref > Transport > Key Lock > Appearance > Show Resulting Key and Offset is turned On
    3. Pref > Browser Details > Key Highlighting is set to Only Colour Matching Keys or whichever you prefer

    Best
    Sander
     
  5. Scratch-E Con

    Scratch-E Con NI Product Owner

    Messages:
    241
    Sander @ NI I just tested again. It's inconsistent behaviour. Sometimes it works, sometimes it does not and then the highlighted keys are gone. Once you reset the Master deck the highlighted keys are lit again.

    Just experiment with it and I'm sure you will eventually notice.
     
  6. Sander @ NI

    Sander @ NI NI Team NI Team

    Messages:
    939
    Scratch-E Con I tried it for some time but for me it stays consistent. It would be great if you could make a video and share it here which shows the moment where it stops working.

    Best
    Sander
     
  7. Scratch-E Con

    Scratch-E Con NI Product Owner

    Messages:
    241
    Sander @ NI I hope someone else can help you as I am about to go on holidays.
    But the issue is definitely there when you switch master decks (manually) you should see that at one point the highlighted keys are gone, only to reappear when you set Master deck again.
     
  8. dack

    dack New Member

    Messages:
    2
    Wow. Duh. Somehow in an upgrade/update Keylock was turned off. Thanks to Sander @ NI for the response. I wonder if it would make sense in settings to point this out under "Only color matching keys." Either that or default Keylock on! :)
     
  9. Sander @ NI

    Sander @ NI NI Team NI Team

    Messages:
    939
    dack yes it will be improved in the future for sure to make it more obvious ;)