1. IMPORTANT:
    We launched a new online community and this space is now closed. This community will be available as a read-only resources until further notice.
    JOIN US HERE

Komplete Audio 2 cancelling other audio sources

Discussion in 'NI Audio Interfaces' started by adic27, Feb 2, 2020.

  1. adic27

    adic27 NI Product Owner

    Messages:
    338
    Seems audio can only be outputted from one source at a time, suddenly. I say suddenly because it couldn't have always been this way as I often in the past have sampled sound from my internet browser into Maschine standalone. I first discovered this issue within FL studio when I tried to look at a YT vid while FL was open. Also, I noticed if audio from another source is already playing and I open FL or Maschine standalone where NIKO is selected as the device it cancels out any other audio. I think I changed some settings somewhere one day but I can't remember what or if I actually did? Could any give advice or some tips on what could be causing this? I messed around with the settings in FL, Maschine, and Windows audio settings but with no luck. I'm sure it's something simple that I'm overlooking but it's driving me crazy!

    Thanks in advance
     
  2. Bernard Tran

    Bernard Tran New Member

    Messages:
    4
    Hi adic27,

    I just received my Komplete Audio 2 yesterday and had the same sound muting issue.
    Every time I launched Komplete Kontrol or my DAW (actually any audio softwares set on Audio 2), all other audio sources suddenly stopped running and I had to disconnect and reconnect the Komplete Audio 2 each time in order to have the sound back again on Windows.
    However, I was unable to have sound on both at the same time...

    Finally after hours of research and testing, it appears it's a matter of SAMPLE RATE !
    On my Kompplete Kontrol Audio Panel, it was set on 48000 Hz, while on Komplete Kontrol and my DAW, it was set on 44100 Hz.
    This is the reason why the Komplete Audio 2 kept muting Windows sound when I launched Komplete Kontrol or my DAW. The audio interface was just switching from a sample rate to another one...

    All we have to do is to set the same sample rate on everything (48000 Hz for my case), and it works like a charm now !
    Another option is to right click on the speakers icon in the task bar, on "solve sound problems" or something, select the Komplete Audio 2 and then follow the procedure. It will temporarily get back the sound on Windows while still able to use Komplete Kontrol or your DAW.
    But I suggest you just follow the 1st option by setting the same sample rate once for all.
     
  3. adic27

    adic27 NI Product Owner

    Messages:
    338
    Thanks for reaching out! However, I already figured that out a while back and thought I posted my solution, which is what you just posted. Maybe it was a different forum. Probably the FL forum lol
    Thanks again!
     
  4. Bernard Tran

    Bernard Tran New Member

    Messages:
    4
    You're welcome. ;)

    I have no more sound muting issues with everything set on 48000 Hz.
    But now, I can hear a small crackling sound each time I PLAY or STOP patterns on my DAW (FL Studio)...

    DId you experience the same ?
     
  5. adic27

    adic27 NI Product Owner

    Messages:
    338
    No. Is it like one pop/crackle when u start and then another when you stop? Or repeatedly popping/crackling during playback? You could try changing the buffer length to a higher number in the audio settings for the audio 2
     
  6. Bernard Tran

    Bernard Tran New Member

    Messages:
    4
    It's only one crackling when I push PLAY or STOP, it doesn't repeat.
    Usually I keep a buffer size 256 samples (6ms), so as you suggested, I increased it until the cracling disappear and I had to make it to the highest size of 2048 samples (43ms). No more crackling, but the latency is way too high...
    Well I just set the buffer size to 512 samples (11ms), it's a bit better with less crackling while preserving a good latency.
    Thanks for your help. :)
     
  7. adic27

    adic27 NI Product Owner

    Messages:
    338
    Try messing around with these options (See image)
     

    Attached Files:

  8. Bernard Tran

    Bernard Tran New Member

    Messages:
    4
    Yeah I already tried all these options, but I can still hear the crackling under 2048 samples...
    I'll try to find out a way to get rid of this and will let you know if I succeed.
    Thanks again ! ;)
     
  9. adic27

    adic27 NI Product Owner

    Messages:
    338

    Hey! Still having that crackling issue? I had a weird kind of delay popping sound at the start of playback but I found that unchecking the "Reset plugins on transport" option in the bottom left of the settings in that same screenshot I posted before. Note that this works with one project of mines and is irrelevant for a different project, as there was no crackling or popping either way so this may or may not work for you. Maybe it's a certain plugin causing it for me since it only happens in that one project, that I know of.