1. Please do not install macOS 10.15 Catalina yet, as Native Instruments software and hardware products are not supported under macOS 10.15 yet. For more info, please go HERE!
    Dismiss Notice

Kontakt 5.8.1: certain factory instruments are receiving from all MIDI channels by default

Discussion in 'KONTAKT' started by DMalley, Jul 11, 2018.

  1. DMalley

    DMalley New Member

    Messages:
    2
    I'm on Windows 10 using Cakewalk (BandLab edition, version 24.04.1), although I've also reproduced the issue in Reaper 5.92 so I don't think it's DAW-specific.

    Ever since updating to Kontakt 5.8.1, I've noticed certain factory instruments - all of them percussion - will receive from all MIDI channels when you first add them to the sampler, much as though they were set to receive from MIDI omni instead of a specific channel. Some examples include the Central Stage Kit, the Suburban Kit, and the Bongos. I've been using these instruments for many years and they've never behaved this way by default. Right after updating, I loaded a bunch of the working files for my current project and noticed they were all playing tons of random percussion notes - this turned out to be the cause.

    Some further info: all the instruments I've seen this happen with show their input MIDI channels in the instruments pane as "1 + Groups", "2 + Groups" etc. I found I can work around the issue by going to the Group Editor -> Edit All Groups -> and then changing the MIDI port in the Source section from "omni" to "MIDI: default". But I'd rather not go back through dozens of my old projects to make this change on every instrument that presents this problem, and it seems like a strange step to have to take in order to have these instruments behave as they used to.

    I first noticed this issue on my laptop (also Windows 10, and same software version for Cakewalk) after updating both the Kontakt 5 application and the Factory Library to 5.8.1 and 1.3.0 respectively. I then updated the library on my desktop, didn't notice the issue, but DID see it crop up again once I updated Kontakt 5 itself. So it seems to me that the application update is what's causing this. I then tried wiping out both the application and the library completely and reinstalling each from scratch; no dice, the issue was still there.

    Has anyone seen this behavior yet or have any thoughts on potential causes, or perhaps a simpler workaround? I'm assuming it's not intentional functionality but maybe there's something I'm missing. Thanks!
     
  2. soundtrax

    soundtrax NI Product Owner

    Messages:
    116
    I think your issue is a result of a bugfix.

    “KONTAKT 5.8.1 FIX:
    FIXED Group MIDI input channel settings are now recalled correctly after saving and reloading an NKI”

    I recently tried to create a multitimbral nki in 5.7. (multiple groups, each having their own MIDI channel, all in one instrument) and noticed that the MIDI setting wasn’t loaded correctly - only one MIDI channel was responding.

    Your libraries are probably multitimbral nkis but you never noticed until 5.8.1...
     
  3. EvilDragon

    EvilDragon Moderator Moderator

    Messages:
    15,186
    Yes those NKIs were made to have some groups respond to different MIDI channels, that is by design, but as soundtrax mentions, there was a bug in recalling the group MIDI input setting.
     
  4. Midnight Music

    Midnight Music NI Product Owner

    Messages:
    3
    Yes, I too have encountered this problem since the last Kontakt 5 update. The instruments that do not have the word "group" after their midi track number in the instrument channel pane work properly, the instruments that have the word "group" after the midi channel number are causing the problems. Is there a way to remove "group" in that window or is it a fix NI hast to provide.

    Lee
     
  5. EvilDragon

    EvilDragon Moderator Moderator

    Messages:
    15,186
    There's no fix necessary, this is how those instruments were designed to work.
     
  6. Midnight Music

    Midnight Music NI Product Owner

    Messages:
    3
    They were never like that before, they always worked fine for all the years I've been using them, why the midi bleed now? It's not all the Kontakt 5 instruments, just a few of them.
     
  7. EvilDragon

    EvilDragon Moderator Moderator

    Messages:
    15,186
    That's because per group MIDI input channel functionality was a bit bugged (it didn't work correctly when reopening the NKIs). Now with 5.8.1 they work as they should.

    If you don't want this behavior, OP of this thread mentioned how to undo it.
     
  8. Midnight Music

    Midnight Music NI Product Owner

    Messages:
    3
    Thank you, I do appreciate your input and willingness to help me. I read the OP solution, but what I am doing with my 10 or so specifically designed orchestral templates is to just gradually replace those particular instruments, mostly percussion, with other samples.
     
  9. DMalley

    DMalley New Member

    Messages:
    2
    Thanks very much for the replies, everyone. EvilDragon, if you wouldn't mind clarifying a thing or two for me -

    I suspected maybe this was intentional functionality rather than a bug, but I'm not sure if what you describe here seems quite like what I'm observing. Let's use the Suburban Kit as an example.

    In one of my projects, the Suburban Kit is set to channel 10 (which is displayed in the instrument panel as "10 + Groups"). For my purposes, I only want the instrument to be receiving MIDI notes from channel 10. However, if in my DAW I go to all my other tracks on different MIDI channels, when I press D4 on my MIDI keyboard I always get the "Snare Drum 3" sound on the Suburban Kit. Doesn't matter which channel I'm sending on - 7, 8, 9 etc. This seems a little weird.

    Looking at Snare Drum 3 in the group editor, it appears to be due to the fact that its Source is set to "omni". If I select this particular sound and set its Source to "MIDI: default", then it only responds if I'm playing the note on the track in my DAW sending to channel 10 (as I would prefer). Looking at the other sounds for this kit, I see they're all set to Source "omni" - my question is, what functional purpose does this serve? An NKI set up, as you described, to have "some groups respond to different MIDI channels" than others makes sense to me; you could be controlling the kick and snare from one channel for instance, and the hi-hats from another. But why would it ever be useful to have every sound in the kit respond to MIDI notes from every single channel?

    Another interesting wrinkle is that I still have my old Kontakt 4 library, which also has the Suburban Kit (and most of the others I've observed presenting this behavior). If I replace my Kontakt 5 instruments in this project with the old Kontakt 4 ones, the problem is totally resolved. I would imagine this is because they were in some way scripted differently, but even the old Kontakt 4 NKIs still say "10 + Groups" etc. in the instrument panel, and in the Group Editor all their individual sounds are still set to Source: omni. This strikes me as particularly strange - in light of that, would you still say the Kontakt 5 NKIs are behaving as they should be?
     
  10. deadhorse6666

    deadhorse6666 New Member

    Messages:
    2
    Have the same issue too,the instrument with +group midi ch always receive omni midi ch after upgrading 5.81
     
  11. EvilDragon

    EvilDragon Moderator Moderator

    Messages:
    15,186
    If one, some or all of the groups within the instrument are set to individually receive MIDI from omni, that is not a bug.

    If I had to reply, it's so that the drums come out no matter what MIDI channel you're on, and there's no way to save the NKI with instrument header MIDI channel information (as this is handled by Kontakt automatically depending on the preference in Options->Handling->MIDI channel assignment for loaded patches). So if a developer wants to ensure that there's ALWAYS sound coming out from the instrument regardless of MIDI channel the user is using, the only way would be to set all groups MIDI input to "omni".
     
  12. r stevenson

    r stevenson NI Product Owner

    Messages:
    12
    Regardless of whether or not it is working "as expected" this is an utter disaster!!!

    Most of my patches in a template of thousands of patches are set like this (omni set underneath DFD or sampler). This means I have to go through and change each patch individually!! Some patches are locked as well - though I haven;t come to them yet. I'm right in the middle of a project as well...frankly throwing myself in front of a bus is sounding welcoming right now.
     
  13. EvilDragon

    EvilDragon Moderator Moderator

    Messages:
    15,186
    By and large, majority of 3rd party sample libraries that I've come across (and I've come across a LOT of them) don't even touch the group MIDI input dropdown menu below the sampler mode menu. So which libraries are we talking about, apart from just Kontakt factory library?
     
  14. r stevenson

    r stevenson NI Product Owner

    Messages:
    12
    Jesus! this is an absolute disaster. I am completely screwed.

    Is there a way to roll back to a version with the bug? This is going to take me a week to individually go through and switch midi; omni to midi default. Does anyone know how to code a script for Windows 7? I'd pay someone to sort this out - let me know here how I can contact you.
     
  15. EvilDragon

    EvilDragon Moderator Moderator

    Messages:
    15,186
    Rolling back the version won't change anything in your DAW projects, as NKIs get stored INTO the DAW project in their current state.
     
  16. r stevenson

    r stevenson NI Product Owner

    Messages:
    12
    So far all the Spitfire ones and some of the Kontakt Factory ones. Not all of them have it on, but most do.

    What do you mean? I ma not using the instruments in a DAW like logic - I have them set up in a standalone version of vienna ensemble. I updated because of a memory leak in kontakt which hangs if I leave it on for more than 24 hours - which I do because it takes a long time to load the template even with SSDs and 128 GB of RAM.
     
    Last edited by a moderator: Aug 22, 2018
  17. EvilDragon

    EvilDragon Moderator Moderator

    Messages:
    15,186
    I'm looking at random Albion 1, 2, 3, 4 and 5 patches, SCS, SSS, SSB and SSW, and they all have that group MIDI input set to "default", not "omni" (the MIDI channel dropdown in instrument header doesn't say "+ Groups" in any patch I opened so far, which means internal group MIDI input settings are not used anywhere in the patch)...

    That doesn't matter. Vienna Ensemble is also a "host", so when you save all your routing in a VE "frame" or however they call it, that stores current states of NKI files alongside. It doesn't reference to them on the hard drive. So just rolling back Kontakt to an earlier version won't do anything to remedy this.
     
  18. r stevenson

    r stevenson NI Product Owner

    Messages:
    12
    Seriously this is an absolute disaster.

    A solution would be a preference somewhere to switch "omni" to "default"....or something. Because obviously this will effect all my previous templates as well. My templates can be 1000s of patches! If I want to recall something for a previous mix - say an old track I need access too, it may use a legacy template which will now be completely screwed.

    No. That's not so. I use VE standalone anyway, and the patches are saved AS THEY ARE. So the new behaviour in Kontakt will affect all subsequent patches.

    By "not so" I mean the patches I have in the template that were set to omni (and never by me - I have never touched that) are saved with the VE template file. The new "fixed" behaviour will affect them all.
     
    Last edited by a moderator: Aug 22, 2018
  19. r stevenson

    r stevenson NI Product Owner

    Messages:
    12
    So far MOST of the percussion in Spitfire and Factory are affected. It's a relief if you've checked other patches...hopefully it might only affect percussion patches....not such a great disaster but still - that is getting up to a hundred pacthes in some templates.
     
  20. EvilDragon

    EvilDragon Moderator Moderator

    Messages:
    15,186
    OK I checked out SSP as well... same thing. No "omni" in groups MIDI input anywhere. You might have an older version?

    Proof:

    upload_2018-8-22_14-59-57.png