1. Please do not install macOS 10.15 Catalina yet, as Native Instruments software and hardware products are not supported under macOS 10.15 yet. For more info, please go HERE!
    Dismiss Notice

Kontrol S2 Mk2 random crashes: a very simple possible solution

Discussion in 'KONTROL S2 / KONTROL S3 / KONTROL S4' started by Nico_Tf, Jan 28, 2014.

  1. Nico_Tf

    Nico_Tf NI Product Owner

    Messages:
    213
    So, like everyone else, I've been plagued with random crashes with the new S2. The kind of problem I have is the one where the S2 soundcard stop outputting sound and sound output reverts to the internal audio of the Mac.

    I think the answer is ridiculously simple: the USB cable given with the S2 is too loose. Try it yourself, if you jiggle it a bit, pulling it off without completely removing it, you get the same symptom: the sound revert to internal audio. Now push it back in and it should go back to the S2. It's not too much of a stretch to imagine that the vibrations from a sound system can over time jig it off a bit.

    I'm asking people in here to verify I'm correct: Next time your S2 crash, try to push the usb back in. Meanwhile I'm using the USB from my Audio 6, which has a tighter fit. Haven't had any crash so far.

    If it is confirmed, then it's good news for NI: They'll only have to send us new USB cables :p
     
  2. Nico_Tf

    Nico_Tf NI Product Owner

    Messages:
    213
    Ok, I've tried to crash it by wiggling, and I get the same error message in console than Dimitri:

    28/01/2014 10:53:41,762 NIHardwareAgent[239]: IOHIDDeviceRegisterInputReportCallback called with a null context

    Re inserting it didn't work this time. I still do think it is a USB port on the S2 / USB cable combination that is causing the problem. The fact that many people have trouble when using it intensely, point to this direction too: vibrations.
     
  3. Devon Damnit

    Devon Damnit NI Product Owner

    Messages:
    55
    initially I thought it to be what u described, but I have been using the usb cables from my audio 6 and F1 controller and its the same problem .. think its a firmware issue . me and my friend interchange our controllers he have the mk1 and I the 2 and we both experience the same issues .. he with a mac and me with a win 8.1 machine
     
  4. Iain Simpson

    Iain Simpson New Member

    Messages:
    11
    I had a wiggle and couldn't repro. In fact, on my MBA, the sound cut to the laptop speaker and then recovered when I plugged back in the S2.