1. Hi everyone,

    Apple just released Logic Pro 10.5 for MacOS 10.15. We found out that Massive X, Crush Pack, Mod Pack, Replika, and Replika XT will crash.

    Our teams are currently working on a fix, and we hope to have this out to you as soon as we can!

    Best wishes, 
    The NI Team

    Dismiss Notice

Logic 10.4.6 still not accepting Komplete Control automation?

Discussion in 'KOMPLETE KONTROL SERIES' started by dov waterman, Sep 5, 2019.

  1. dov waterman

    dov waterman New Member

    Messages:
    3
    This is very frustrating. I am on Loic 10.4.6, and Komplete 2.1.4. Still there is no Host automation. Could this being an apple thing have anything to do with the OS that I'm on, which is High Sierra?
    I'm reluctant to upgrade yet, but also reluctant to revert back to Logic 10.4.4 which was very buggy.

    Your support NI would be very helpful thanks!

    Dov
     
  2. Adil @ NI

    Adil @ NI KOMPLETE TEAM NI Team

    Messages:
    497
    Hi Dov,

    The issue with recording automation from hardware controllers was inadvertently introduced by Apple in version 10.4.5. We are in touch with Apple and have been informed that they will release a fix in a future update, but there is no timeframe for this just yet.

    Best,
    Adil
     
  3. davemacp

    davemacp NI Product Owner

    Messages:
    368
    I can't understand why there isnt more of an uproar about this. Do the majority of the users not record automation? It's crazy, it completely destroys any workflow. Also, the finger pointing between NI and Apple is tiring. This should be priority no 1 between both companies to get fixed.

    It makes you realise just how held to ransom and worthless todays software is. Im THIS close to going back to hardware, this is a complete joke.
     
  4. davemacp

    davemacp NI Product Owner

    Messages:
    368
    Also, why is there not a sticky at the top of this forum to let prospective buyers know the hardware doesnt work with logic since the last 2 release versions, and might never work again? Oh, we all know why...
     
  5. Adil @ NI

    Adil @ NI KOMPLETE TEAM NI Team

    Messages:
    497
    Hello,

    Apple have acknowledged that the issue was introduced on their end, and will be fixed in the next update to Logic Pro X.

    Best,
    Adil
     
  6. davemacp

    davemacp NI Product Owner

    Messages:
    368
    With all due respect. that isn't any help to those of us who have the issue today, and have done for months. When will the update be? They've known since 10.4.5 and didnt fix it in 10.4.6. It's been half a year now and I'm not confident the buck won't get passed around again.
     
  7. Adil @ NI

    Adil @ NI KOMPLETE TEAM NI Team

    Messages:
    497
    Apple do not communicate their release plans, so I'm afraid we do not know any more than what we have stated publicly.

    Best,
    Adil
     
  8. davemacp

    davemacp NI Product Owner

    Messages:
    368
    Yeah, it was a rhetorical question. They said they'd fix it once already, they didn't. I'm not convinced they ever will and if they do, it could be another 6, 12, 18 months away? Crazy.
     
  9. pranaearth

    pranaearth NI Product Owner

    Messages:
    233
    Through the Logic app itself you can send feedback to Apple. Every day I've been sending in a request for them to fix the NI problem. Extreme? Maybe, but I want my hardware to work with my software, and losing functionality is not a viable option.
     
  10. Stormchild

    Stormchild NI Product Owner

    Messages:
    367
    They will fix it, I’m sure, but they might be working on a major update that makes it hard to apply fixes to the current version (it could be months behind the current version). That’s not to say this situation is acceptable (it’s not), only that it’s probably part of an update that isn’t ready to ship yet. The fact that there’s no way to revert to previous versions of Logic makes it especially annoying. I guess we’ll see if the the next update is a big one or not. If not, I have no idea why it took so long or why they thought it was okay to just leave it broken for several months.
     
  11. davemacp

    davemacp NI Product Owner

    Messages:
    368
    I've just sent another bug report into apple, for all the good it'll do. Not sure I have the patience to do it every day, so good on you pranaearth!
     
  12. Tony Jones

    Tony Jones NI Product Owner

    Messages:
    271
    10.4.7 was released yesterday and includes some automation fixes - I can't test myself but it looks like good news!
     
  13. rob63

    rob63 New Member

    Messages:
    1
    Yep, can confirm that automation now works with 10.4.7 release. Good news people.
     
  14. davemacp

    davemacp NI Product Owner

    Messages:
    368
  15. Daniel Sykes

    Daniel Sykes NI Product Owner

    Messages:
    58
    Yes, finally!
     
  16. Kymeia

    Kymeia NI Product Owner

    Messages:
    5,963
    Yeah but does it require Mohave or higher now?
     
  17. prjkt

    prjkt NI Product Owner

    Messages:
    49
    No, just installed on 10.13.6 now.
     
  18. Chris W

    Chris W New Member

    Messages:
    1
    I've just downloaded 10.4.7 and still can't get it working. My S88 knobs don't register any automation through KK (when switched into normal MIDI mode they work fine) My M32 sometimes sends Sys Ex messages which record into Logic but no control comes back to KK. Any Ideas?