Mac OS-X DFD extension doesn't work

Discussion in 'KOMPAKT' started by tmax, Apr 13, 2004.

Thread Status:
Not open for further replies.
  1. tmax

    tmax New Member

    Messages:
    1
    Just installed EWQLSO Gold as Kompakt plug-in with Logic Pro 6.4.1 on a dual 1.8 GHz G5 (OS 10.3.2). The Mac OS-X DFD Extension V1.28 makes so much noise it is unusable. That means I have to turn it off, loading the instruments into RAM. But even 2 GB of RAM won't let me load more than a dozen instruments. I'm not at all happy about this. What should I do?
     
  2. j33pd0g

    j33pd0g New Member

    Messages:
    8
    Really... when I downloaded the OS-X DFD Extension V1.28, it installed, but DFD still didn't show up as an option. I have since deleted DFH2 from my hard drive, as it was useless. Support has been horrible for this product.
     
  3. trouble

    trouble NI Product Owner

    Messages:
    1
    DFD extention for DRUM KIT FROM HELL

    I am in the same boat as you. I love the samples and feel there is a very realistic element to them, especially with the mic bleed from other drums, but the product is useless without the DFD extention. It's so taxing on you're computer that it simply won't run clean without the direct from disk option. I too downloaded and installed it several times, and my DFD button on my KOMPACT sampler is still greyed out. Tech support for this problem is worthless. I even called them and they haven't called back. I also bought the ADRENALINE with the INTAKT sampler and it won't recognize more than 75 percent of the samples it shipped with. I'm working on my third major label release and I was looking for a little inspiration and I got a huge headache instead. If anyone at NI is reading this, I'm hanging in there as long as I can, but if I don't get some help, it will be the difference between me buying more of these or throwing the ones I have in the trash and telling my freinds not to buy them.
     
  4. hacked_to_pieces

    hacked_to_pieces NI Product Owner

    Messages:
    3
    DFD extension does not work on OSX 10.3

    I just got DFH2 today and the fu%kin DFD extension does not work on OSX 10.3 (loads but the DFD option in Kompakt is still greyed out) which renders the program useless.
     
  5. Gren

    Gren NI Product Owner

    Messages:
    4
    My DFD works fine standalone but not as an RTAS. Im running 10.2.8 and Pro Tools 6.1.2. I dont have the awesome results tmax is so annoyingly displeased with! My Scarbee W.E.P just wont load without DFD.
     
  6. Bjerlancer

    Bjerlancer New Member

    Messages:
    7
    There is hope!

    Regarding the DFD extension, this is what I found out so far:

    It works find with OSX and KONTAKT. For those who only have the KOMPAKT player version, there are problems running it on OSX Mac G5 double processors. This is th email I recieved from support:

    Hello,
    according to the latest information the update is going to be sent out to the OEM partners by end of this week. As experience has shown, they do not hestitate very long to release the updates, so it should be available next week.

    We are also aware of issues with Logic when using mulitple outputs. The process buffer should be set to \"large\" when using Kompakt as multi. If you want to use smaller process buffers (set in Logic Audio hardware driver window in the CoreAudio area) you will have to select the instrument channel in the arrange window where the multi instrument sits in. this prevents possible distortion which might occur in the aux track (the multi outs aux tracks) Does not help if you have several multi instruments in your song, of course.

    Best regards

    Stephan Sippel
     
  7. Gren

    Gren NI Product Owner

    Messages:
    4
    Is there an issue with G4 dual processors (1.25) ? Because thats what I have. (OSX 10.2.8 Pro Tools 6.1.2).
     
  8. Bjerlancer

    Bjerlancer New Member

    Messages:
    7
    ...

    I don´t know about the G4...
    På 26. apr. 2004 kl. 13.13 skrev Native Instruments forum:

     
  9. j33pd0g

    j33pd0g New Member

    Messages:
    8
    Definite problem with my G4 1.25 DP. Also, to say that the DFD extension and kontakt works fine with OSX is skirting the issue because Kontakt and Kompakt are 2 different plug-ins. I have kompakt. That's what needs a fix.
    At least someone is aware of the problem. Hope the fix comes soon.
     
  10. Stephan @ NI

    Stephan @ NI NI Team NI Team

    Messages:
    223
    Hello RTAS users,


    on the support page of EW you can download an DFD package 1.2.9 which includes the necessary DFD. However, the DFD Kompakt uses is still 1.2.8, but its also in that package. After installing this package DFD should be available in the RTAS plug-in as well.

    We are aware of issues with the 1.2.8 version on multi-processor Macs. We are currently still working on updates of all Kompakt version, as a result Kompakt will also use the latest DFD. This DFD should wipe away the remaining issues (as it did in Kontakt 1.5.2).

    BTW in my support query response (quoted above) I refered to a problem with mulitple outs in Logic. In the meantime I was told that this problem also occurs with other instruments, including EXS. So it seems that the larger process buffer is mandatory when using instruments with multiple outs in Logic. This problem is independent from DFD.

    RTAS (and HTDM) in general unfortunately do not provide a possibility of mulitple outs (at this moment), they have stereo outs at maximum.
     
  11. Stephan @ NI

    Stephan @ NI NI Team NI Team

    Messages:
    223
    Hello,

    to avoid confusion:

    the used DFD extension depends on the Kompakt version. As Kompakt was constantly developed and improved the release of Kompakt Instrument "Drumkit from hell" already uses the latest DFD 1.2.9.

    You can find the DFD version displayed of each Kompakt by opening the about window of the standalone version.

    Again: the DFD extension installer on the EastWest support page which is described "for RTAS users" includes all DFD versions available so far. Download this installer to make sure that you are up-to-date.
     
  12. Bjerlancer

    Bjerlancer New Member

    Messages:
    7
    ...

    Hello Stephan,

    I see RTAS DFD has a 1.29 uppdate, but that will not work in a Logic
    enviroment Mac G5 2x2 will it....?


    Best

    Trond

    På 30. apr. 2004 kl. 18.23 skrev Native Instruments forum:

     
Thread Status:
Not open for further replies.