Mapping not working in 2.6 (beat jump)

Discussion in 'TRAKTOR PRO / TRAKTOR SCRATCH PRO' started by Comme Erçial, Oct 27, 2012.

  1. Comme Erçial

    Comme Erçial New Member

    Messages:
    16
    Hello.

    Just upgraded to 2.6 from 2.51 and now the custom mapping for my 4Trak is not working.

    I have a rotary push encoder mapped with beatjump, 4bar loop and release loop when pushed and move loop when in loop and adjust loop length when shift pressed. It's good to have as it allows me to scroll through the song, set a loop, move loop and release it with one button.

    After upgrading to 2.6 the beatjump transport doesn't work (just stutters a little), the loop release sets a new outpoint instead (shortening the loop) and other weird behavior.

    The mapping is the same as in 2.51 and when starting up 2.51 it works great.

    Do you have any insight as to why this has happened?

    Sincerely Comme.
     
  2. Comme Erçial

    Comme Erçial New Member

    Messages:
    16
    Solved the mess by using Seek Position instead of Beatjump and ad a condition to Loop out so it only works when in a loop. Don't know why it all went bananas from 2.5 to 2.6, but this seems to work.
     
  3. asha.dan

    asha.dan New Member

    Messages:
    6
    Yup Beatjump is stuttering when using a Button type map. I have a rotary knob that sends a note mapped to +4 and another to -4. If I turn the knob really slow it still works, but as soon as I go faster it stops responding....

    Back to using Seek Position to jump around my tracks.
     
  4. asha.dan

    asha.dan New Member

    Messages:
    6
    Arrgh... and of course Seek position does not actually follow beats. Back to 2.5.1!
     
  5. Kensic

    Kensic Forum Member

    Messages:
    79
    yup experienced the same problem with beat jump after going to 2.6.
    i use beatjump alot too.

    where can i submit a ticket to NI?

    for the mean time, let me try seek position like you guys are suggesting
     
  6. Comme Erçial

    Comme Erçial New Member

    Messages:
    16
    Yeah, with quantize on its ok for me.
     
  7. asha.dan

    asha.dan New Member

    Messages:
    6
    I figured out the problem, for me at least.

    In 2.5.1 when I set up my controller Interaction Mode under the Type of Controller [button] is Direct.
    In 2.6 the Interaction Mode has been changed to Hold.

    So i think when I turn my controller knob fast it is sending the midi Note ON signals one after the other really fast, and Traktor is not beat jumping to each one, its only when there is enough time for it to come 'off hold' before another one is sent.

    Anyway I logged a support issue.

    D
     
  8. Comme Erçial

    Comme Erçial New Member

    Messages:
    16
    Mine is mapped to a rotary endless encoder with push functionality. Rotate for transport, rotate with shift for loop length, push for set and release loop, rotate in a loop for loop move.

    Tried to set the encoder to Direct and Relative, none worked.

    An awesome thing to have, don't really understand why it went bananas in 2.6 but seems to work with Seek Position
     
  9. djindica

    djindica NI Product Owner

    Messages:
    33
    little question about s4 mapping

    it is just me or the loop beat indicator on S4 dont show the info anymore, i have no number at all . also when pressing shift on left , make the play button on right turn green but doest start the deck (thank God) . also my cue point was normaly a blue led on the S4 , now i still have cue point in the software but on the S4 no light on , kinda confuse. Shift button on left act very weird (i was using alots Shift + cuepoint button to delete cue , now i have to redo the cue to get blue led and then i can delete it the same way as usual )

    did you experience these thing or i just have an unlucky experience , im a user for over 10 years so you can bypass all question regarding if my upgrade was done correctly lol
     
  10. Kensic

    Kensic Forum Member

    Messages:
    79
    yup exactly the same to me...the beatjump only moves when i turn the knob FAST. and it only jump once with 5-10 fast turns.

    but the weird thing is that is only moves backward lol.
     
  11. Comme Erçial

    Comme Erçial New Member

    Messages:
    16
    Same strange behavior here...
     
  12. Kensic

    Kensic Forum Member

    Messages:
    79
    hey can you change the title of this post to "beat jump" not working?

    to draw attention of NI so they can fix it.
     
  13. DJ Freshfluke

    DJ Freshfluke Traktor Mod Moderator

    Messages:
    26,751
    i can change the thread title for you but that doesnt mean that NI will look into this thread.
    this is the user forum.

    to get this tracked, you have to contact NI support.
     
  14. asha.dan

    asha.dan New Member

    Messages:
    6
    I already contacted support and mentioned this thread. I will let you all know what the answer is.
     
  15. angelxp

    angelxp New Member

    Messages:
    1
    Oh,thank you for the Post, this can be a great help.
     
  16. mecha76

    mecha76 NI Product Owner

    Messages:
    28
    Broken Beatjump Functionality

    Same Bug within Beatjump here :confused:

    It no longer works correct when mapping it to a Rotary Control.
    I use the Rotary for other Functions in my Mapping too but these work like ever.
     
  17. asha.dan

    asha.dan New Member

    Messages:
    6
    Hi all,

    NI support is still looking into this, but I have found a work around in the mean time.

    Its copied from the way the X1 controller beatjumps:
    Create a Deck Common>Move>Size Selector - Button/Direct to the size you want
    Create a Deck Common>Move>Mode Selector - Button/Direct to Beatjump
    Create a Deck Common>Move>Move - set up the same way as Beatjump was
    Map all these to the same control as Beatjump was mapped to, and it works just like 2.5

    There you go....
    Dan
     
  18. Kensic

    Kensic Forum Member

    Messages:
    79
    ok i can confirm that it doesn't work. i think you need to be more clear then that.

    im interpreting the best of ability on what you put.

    and why is it "button"? doesnt work at all on "button" as type of controller

    we are using the "fader/knob" to beat jump....and with ur mapping with "fader/knob" it only does ONE forward jump....then you MUST do ONE backward jump. then ONE forward jump...and so on

    so it wont keep going forward if or keep going backward as the user desier.
    ---
    ok finally got it to work.

    this is what you do

    1) add in - deck common - move - move - *learn the kmob* - fader/knob - direct - check invert

    2) add in - deck common - move - beatjump - *learn the SAME knob* - fader/knob - direct - check invert

    so it works just like how it was. use a different knob to select the length of beat jump. and rotate the knob above to jump around

    YAY! THANKS ASHA.DAN for planting the seed in my head.
     
  19. mastermc

    mastermc NI Product Owner

    Messages:
    3,143
    so it does work now ?
     
  20. Kensic

    Kensic Forum Member

    Messages:
    79
    yea if you follow the mapping I said above