Maschine dont register first note

Discussion in 'MASCHINE Area' started by dabb, Sep 24, 2016.

  1. dabb

    dabb Active Member

    Messages:
    396
    Maschine don't play first note (kick) when i open it VST in Ableton and change scenes with PC message.
    I remember there was a thread like this but i couldn't find it.

    I made a blank scene and when it comes maschine plays first kick this time.
    Looks like it is always playing last scenes last note. Not the new one.
    I tried to move the first note very slightly but still same. That wont work for the blank scene already..

    Is there a solution for that?
     
  2. dabb

    dabb Active Member

    Messages:
    396
  3. CakeAlexS

    CakeAlexS NI Product Owner

    Messages:
    5,262
    Bump the thread I suggest. We are supposed to be part of a two way communication with NI nowadays (all part of the agile thing). If this is a reproducible issue NI should acknowledge.
     
    • Like Like x 1
  4. Mystic38

    Mystic38 NI Product Owner

    Messages:
    2,281
    When are you sending the PC messages for a scene change?.. at beginning of new scene? at end of last scene or somewhere in the middle?..

    mebbe try moving the timing of the scene change PC rather than the notes, ?
     
  5. dabb

    dabb Active Member

    Messages:
    396
    Beginning of the first scene.
    In Ableton arrange mode i change Abletons scenes and maschine scene together. That is how arrange mode works. How can i change maschine scene before? Its not practical.

    @CakeAlexS can you add this to your bug list? It is very easy to repro. In Ableton at least, i don't know other DAWs..
     
  6. CakeAlexS

    CakeAlexS NI Product Owner

    Messages:
    5,262
    Responded here. Ta.
     
  7. Mystic38

    Mystic38 NI Product Owner

    Messages:
    2,281
    Well, if in session mode i agree with you, as you would be changing scenes in Live and Maschine on an ad hoc basis..but if you are running to the timeline of the arrangement, ie a linear running DAW, you can move the scene changes for Maschine to a slightly earlier time given that scene changes are quantised.

    Up to you, but even if this is not convenient to your workflow, its a useful experiment to make... not saying this is great, or ideal, or even that it will work, but it doesn't work now, and you don't wish to move notes, so its worth a shot.

    fwiw, its not exactly an uncommon issue with (normal) midi gear.. as you cannot simultaneously changes patches, programs or multis and reasonably expect 100% reliable playing of a note timed at exactly the same time as the changes, and the default fix has always been to delay first notes by a few ticks.

     
    • Like Like x 1
  8. CakeAlexS

    CakeAlexS NI Product Owner

    Messages:
    5,262
  9. detech

    detech NI Product Owner

    Messages:
    195
  10. dabb

    dabb Active Member

    Messages:
    396
    People says this wasnt issue in 1x maschine
    so that means it is solvable

    please solve it NI

    x0x0
     
  11. CakeAlexS

    CakeAlexS NI Product Owner

    Messages:
    5,262
  12. Mr36

    Mr36 NI Product Owner

    Messages:
    7,807
    Just been investigating this a little and it doesn't work if retrigger is off in Live (the first 1/128 or less is missed), but works fine if retrigger is on, seemingly regardless of other Scene sync settings (i.e., it can be left on Scene or 1-bar for Scene sync). This was tested with a snare on the 1.1.1 in Maschine and a PC message for Scene 1 (i.e., PC1) sent from a Live clip placed on the 1.1.1.
     
    • Informative Informative x 1
  13. CakeAlexS

    CakeAlexS NI Product Owner

    Messages:
    5,262
    Still an issue?