maschine in reaper as vst

Discussion in 'MASCHINE Area' started by dippy, Jun 14, 2011.

  1. dippy

    dippy NI Product Owner

    Messages:
    794
    I've followed the instructions on the vid for how to use maschine simply as a vst with reaper actually recording the midi notes. However, despite having a signal (midi and audio) from the maschine controller, no notes actually record. (blank midi clip when recording)

    Close, but no cigar........
    ---
    Hmmmmm. Selecting "record midi out" in reaper seems to be the only way it works.

    Seems complicated to me though.
     
  2. Mark1

    Mark1 NI Product Owner

    Messages:
    34
    Hi dippy, this had me stumped for a while when I first tried to do it but thankfully I managed to figure it out. You need to go into Sound Midi Batch Setup in the group options and choose 'Sounds to midi notes'. Then put Maschine into midi mode by pressing Shift and Control. The root key option in the Sound Midi Batch Setup defaults to C3 which corresponds to Group E pad 1. You can now use the Group buttons to move up and down the keyboard range and if you left the root key at C3 your dums start on Group E pad 1. Now you should be able to record your pad playing as midi in Reaper.
     
  3. dippy

    dippy NI Product Owner

    Messages:
    794
    Hmmmmmmm. I'm warmer, but I cannot get the sounds to come through. Changing the C3 to something else doesn't do anything that I can see.

    My oxygen 61 comes through though :roll:
     
  4. Mark1

    Mark1 NI Product Owner

    Messages:
    34
    This is the quickest way of testing it out.

    1. Open a fresh Reaper project and open Maschine in a new track and click 'No' when it asks if you want all outputs automatically set up.

    2. Load some drums into a bank.

    3. Go into sound Midi Batch Setup in the group menu and choose Sounds to Midi Notes. You can leave the root key set to C3.

    4. Make sure the Maschine track is record armed and set to record input and moniter input and to recieve midi from all midi inputs.

    5. Now on the Maschine controller press the Control button while holding shift which will put it into midi mode, and then choose group E. You should now be able to hear your drum kit when you play the pads.

    7. Make sure you have an empty pattern selected in Maschine and start recording in Reaper. Now your pad playing should record as midi.

    I hope this works for you.


    I've just thought, have you enabled the Maschine controller in the Midi Devices tab in Reaper preferences?
     
    Last edited: Jun 15, 2011
  5. dippy

    dippy NI Product Owner

    Messages:
    794
    that seems to have got it :)

    question though, any reason why the pads don't respond the same in midi mode?
     
  6. Mark1

    Mark1 NI Product Owner

    Messages:
    34
    Yeah you're right, I'd not noticed that before. In midi mode I'm having to hit the pads a littled harder before they produce any sound. Is that the way you see it?
    I've no idea why to be honest. Anyway glad you've got midi recording working.
     
  7. dippy

    dippy NI Product Owner

    Messages:
    794
    that's exactly what I'm experiencing.

    Oh well, thanks for your help!
     
  8. Mark1

    Mark1 NI Product Owner

    Messages:
    34
    You're welcome.
     
  9. smithwessen

    smithwessen NI Product Owner

    Messages:
    1,177
    open up controller editor

    go to prefrences

    controller

    and adjust sensitivity to liking
     
  10. Mark1

    Mark1 NI Product Owner

    Messages:
    34
    Thanks, but I already know about that. I've got it set to full sensitivity but you still need to hit the pads a little harder in midi mode than normal mode before they trigger. Its no biggie for me really but it seems to respond differently in midi mode.
     
  11. dippy

    dippy NI Product Owner

    Messages:
    794
    Correct

    I like the pads the way they are when not in midi mode. In fact, I can use the oxygen 61 to trigger maschine sounds better. I find that odd. Why would my 61 key controller work and work better when trying to record directly to the daw?

    Anyways, it's just a mystery I'm trying to solve.