Maschine Jam - How to disable the On Screen Overlay?

Discussion in 'MASCHINE Area' started by Silvano Lotze, Mar 9, 2019.

  1. Silvano Lotze

    Silvano Lotze New Member

    Messages:
    4
    how do i turn off the pop up that happens when i for instance press the note repeat button or the swing button on my maschine jam?
    it keeps changing my screen from traktor to the maschine software or ableton (when using vst) which is really annoying while performing because i have to reach for my laptop to change it back..
     
  2. Uwe303

    Uwe303 NI Product Owner

    Messages:
    4,928
    Have you tried to minimize the windows you don't want to pop-up?

    Uwe
     
  3. D-One

    D-One Moderator Moderator

    Messages:
    7,212
    Pop up!? On Screen Overlay?
    I don't have a Jam so i cant check, try the hardware settings and see if theres an option to disable OSO.
    [​IMG]
     
    • Like Like x 1
  4. Silvano Lotze

    Silvano Lotze New Member

    Messages:
    4
    that would seem like the setting im looking for but unfortunately it isnt anywhere in my settings. not in the vst or standalone version... :(
     
  5. D-One

    D-One Moderator Moderator

    Messages:
    7,212
    Windows or Mac? Are you using the applications in full screen? Does each have a desktop? (not sure if multi desktops are a thing in Windows)
     
  6. van Grieg

    van Grieg NI Product Owner

    Messages:
    230
    There’s no such setting for Jam. I only see it with devices that DON’T have an overlay.
     
    • Informative Informative x 1
  7. Silvano Lotze

    Silvano Lotze New Member

    Messages:
    4
    Mac, ive tried multiple desktops and full screen nothing seems to stop maschine from taking over my screen :(
     
  8. D-One

    D-One Moderator Moderator

    Messages:
    7,212
    Full Screen and separate desktops are worst, OSX is designed to re-focus on the app that requests your attention.

    Try this, move the Jam Overlay outside of the visible screen space, I don't think you can put it 100% off screen, a little bit will always show but at least it won't get in the way as much.

    You can also try SIMBL + Afloat.bundle, it can force a window to always stay on top. I have tried it before for other purposes and it worked for me, however, it requires you to disable SIP (System Integrity Protection) so do it at your own risk.
    https://www.perfectlyrandom.org/2016/10/23/always-on-top-in-macos-sierra/
     
    • Like Like x 1
  9. Silvano Lotze

    Silvano Lotze New Member

    Messages:
    4
    "Try this, move the Jam Overlay outside of the visible screen space, I don't think you can put it 100% off screen, a little bit will always show but at least it won't get in the way as much."

    thanks mate !!
    this seems to do the trick: minimize ableton and then move maschine and the overlay as far of screen as possible. they are just barely visable to the point you wouldnt even notice them :D
     
  10. D-One

    D-One Moderator Moderator

    Messages:
    7,212
    No problem, glad to help. It's not perfect but does the job. :thumbsup:
     
    • Like Like x 1