1. Please do not install macOS 10.15 Catalina yet, as Native Instruments software and hardware products are not supported under macOS 10.15 yet. For more info, please go HERE!
    Dismiss Notice

Solved Maschine mk3 and Live

Discussion in 'MASCHINE Area' started by kb420, Sep 28, 2019.

  1. kb420

    kb420 NI Product Owner

    Messages:
    534
    I've followed the directions for how to setup the mk3 in Live, but no matter what I do, Maschine mk3 does not show up in the list of possible controllers. Anyone have any ideas? Has anyone else ran in to this problem?
     
  2. Uwe303

    Uwe303 NI Product Owner

    Messages:
    4,867
  3. kb420

    kb420 NI Product Owner

    Messages:
    534
    Believe me, it's in the right directory. I placed the legacy controller script in the same folder, and that shows up, but the new mk3 does not show up in Live.
     
  4. Uwe303

    Uwe303 NI Product Owner

    Messages:
    4,867
    You mean the midi port?
     
  5. kb420

    kb420 NI Product Owner

    Messages:
    534
    No. I mean the ""Control Surface" list. The midi ports show up.
     
  6. Uwe303

    Uwe303 NI Product Owner

    Messages:
    4,867
    Maybe delete the legacy folder? In the manual it says you should delete all other scripts from maschine.

    Uwe
     
  7. kb420

    kb420 NI Product Owner

    Messages:
    534
    Where does it say that in the manual? The only reason I installed the legacy script was because I could never get the mk3 script to work. Page 69 in the manual is where the integration instructions for Live begins. It doesn't mention anything about deleting legacy scripts there.
     
  8. Uwe303

    Uwe303 NI Product Owner

    Messages:
    4,867
  9. D-One

    D-One Moderator Moderator

    Messages:
    7,056
  10. kb420

    kb420 NI Product Owner

    Messages:
    534
    Well, I went back and deleted it. Now I'm back to square one. It still doesn't show up in the list. Here is what the list looked like before I deleted the legacy folder. I'm only posting this to show that I definitely installed everything in the correct folder.
     

    Attached Files:

  11. D-One

    D-One Moderator Moderator

    Messages:
    7,056
    Either go to your recycle bin and restore it or copy it again as it says in guide Uwe posted (for the legacy script), dont delete anything.
    Then copy the folders as instructed in the guide I posted in post #9.
     
  12. kb420

    kb420 NI Product Owner

    Messages:
    534
    You don't understand. I don't want to use the legacy script. I want to use the newest latest mk3 script. The problem is, it will not show up in Live's Control Surface List. I have the regular version of Live and the latest Beta. I have the correct script in the correct respective folders, but it still doesn't show up in either version.
     

    Attached Files:

  13. D-One

    D-One Moderator Moderator

    Messages:
    7,056
    I do understand that. I just instructed so you can have both.

    I have both working on Beta and Current release of Live, the question is did you copy the "_NativeInstruments" folder or not? It's required for the newest script to work... Otherwise, we will keep going in circles.

    It's two folders, not just one.

    [​IMG]
     
    • Like Like x 1
  14. kb420

    kb420 NI Product Owner

    Messages:
    534
    That did it!!!! That was the missing piece of the puzzle!!! Thanks!!!
     
    • Like Like x 1
  15. themixtape

    themixtape NI Product Owner

    Messages:
    260
    Sadly I don't know why anyone would want to use this newer "Integration" script. It's missing nearly everything. It has a beautiful mixer GUI on the screens, and you can adjust pan.. use the transport, toggle the click on/off, etc. But beyond that, no clip-launching? Is this newer script only designed for volume tweaking mostly... but assuming the user has a Launchpad, too? Seems redundant. The older Legacy script gives you a 4x4 grid for launching clips, everything else, plus scene launching. It's missing some stuff but mostly complete.

    Spent most of last night into this morning just researching and testing... sucks that nothing re: the MK3 is complete enough to use with Ableton 10.