1. Hi everyone,

    This forum is now closed for posting. If you require technical support from NI or have a questions about activating your product, please head over to our new Support Community!


    The Support Community is the new location where you can expect to receive assistance and feedback on technical support, sales or installation issues from our Support Agents and other users.

    Please also note, questions about the status of an order should always be directly sent to our Order Support team HERE.

    Best wishes, 
    The NI Team

Massive presets not loading in maschine project

Discussion in 'Technical Issues (Archive)' started by aporia, May 15, 2012.

  1. aporia

    aporia Forum Member

    Normally when I do anything in massive (as a VST inside maschine) and save it as a preset, the maschine project seems to embed the saved preset, so its there everytime I load the project. This is intuitive and worked great for me.

    until now.

    I was moving my massive patches around, and accidentally ended up deactiving massive in the plugin-ins manager in maschine.

    when i reloaded it as a plugin, none of my maschine project files could find any of my massive presets. all other VST/AU plugins would load normally.

    But with massive, I could find the presets I had used in the bank library, but they would not load by default when opening the maschine project. I'm seeing an "untitled sound" for all instances of massive in all of my projects. I've tried dialing in all the presets (again) and saving as a new filename, but to no avail. Everytime I reload any of these files, massive defaults to 'untitled sound'! grrrr

    (Strantely, this feature works if I make a new sound in a new project, insert a massive synth, save it and reload it, but it won't work with any of my existing projects).

    I hoped into time machine on my mac and grabbed the .mprj files from two days ago (before I noticed the problem)... when I open these files, the massive presets load correctly, even though the .nmsv patches are in a new location from where they were in that version of the file. So I guess the file path of the VST preset doesn't matter? As long as you have something in your library with the same name? I still can't explain what caused this and why I can't save newly dialed in presets in my own projects.

    I'm totally boggled - and what's worse I have no idea what happened and no reason not to expect it to happen again.

    I looked inside the .mprj files to see if something was amiss, and it first looked to be XML, but the metadata for Massive is all encoded and impossible to read.

    Does anyone know how this feature (VST presets being stored inside maschine) really works, or have any info on what may have caused the problem?

    I've been doing work on tunes for the past while and would prefer not to replace the my current .mprjs with old ones from TM, but I'll have to if I can't get the VST presets to save inside maschine again.

    Happy to upload one of the projects if anyone knows how to read those files without maschine...

    until then, I'm just clueless and frustrated. Any ideas as to why this might be occuring?

    Is the preset metadata from massive actually stored in the .mprj, or is it just telling it to look in a location to find the preset?

    Like - in theory - could I delete my massive preset library and still have massive load those settings when its bunded in a .mprj?



    edit: tried reinstalling maschine and massive, but this did not fix the problem.
  2. aporia

    aporia Forum Member

    really? No one has had this problem?

    What's weird now is that anytime I create a new project, load a massive preset inside a group, save the project, and the reload it (by opening it again while its open) the massive preset keeps defaulting to "untitled sound" rather than the preset I previously selected. grrrr.... in this state massive is completely unusable inside maschine.

    it's weird this is only happening with massive. No other plugins seem to be affected.

    (I made a video that demonstrates exactly what I'm talking about... and is perhaps easier to follow... at this point I'd be happy to just solve this issue, not worry about the old MPRJ files)

  3. shootdaj

    shootdaj New Member

    Has anyone found a solution to this problem? It's very frustrating. I have to go to each instance of Massive in my project and set the preset for each of them manually.
  4. aporia

    aporia Forum Member

    I've noticed in only happens on certain sound slots ... not with any predictability, but for whatever reason when certain projects load sounds in certain slots, it initializes the plugin rather than remembering the settings it was at the last time it was played.

    Probably a bug, but I'm still on 10.6.8
  5. aporia

    aporia Forum Member

    this bug is created when you have conflicts with your standalone/plugin version number. Like a preset made in massive 1.2 will not open properly if the plugin is on a different version (1.1).

    Forward-compatibility issues make sense to me, but this can be a backwards compatibility thing too (preset made in 1.1, will not initialize in plugin 1.2).

    No solution, but I'm pretty sure version conflicts is the disease behind the system, in case anyone is still curious.
  6. sowari

    sowari Moderator Moderator

    Maschine needs the latest version of Massive - currently 1.3.1. sometimes the plugin version is not updated, and if this is the case, you will get errors.

    so - please update to Massive 1.3.1 and check that the plugin is the same version.

    very importantly: run Massive in Standalone Mode after the update before you use it in Maschine or a DAW.