Master deck jumps around while mixing

Discussion in 'Technical Issues (Archive)' started by mest42085, Aug 20, 2010.

Thread Status:
Not open for further replies.
  1. mest42085

    mest42085 NI Product Owner

    Messages:
    368
    Hoping you guys can help me out with this one. I've been running TSP on my new i7 MBP for a couple months now and am really enjoying the solid performance. But one thing that has been driving me crazy is that while I am playing with Timecodes CDs, the "master" deck will jump around between the decks playing as I am mix.

    Let me try to explain as detailed as possible, as this happens randomly, but happens countless times throughout every set. I am usually only mixing back and forth between deck A & B, and very rarely will use a loop on deck C over the top. The master deck status does not ping pong back and forth rapidly, but rather when I am in the middle of a mix (usually a long one, but not always,) the master deck will just suddenly switch to the newer deck being mixed in. It does this for no apparent reason, as I have not stopped playback @ all or slowed it down significantly. It's as if TSP gets confused about which track has been playing longer. Then, and only when, I nudge the newly-appointed "master" deck to keep things in time, will the master status jump back to the deck it should be. It is also not uncommon for this to happen twice in the same mix if it is a long one or mashup. That being said, it does not happen on every mix. Strange.

    This never happened to me when I was running the same version of TSP on my HP Core 2 Duo PC. The only difference now (besides the OS) is I am running @ 2.5 ms latency instead of 5 ms, and a sample rate of 48k instead of 44.1k hz. I thought perhaps that might be affecting things somehow so I tried messing about with the settings (raising & lowering) and it didn't seem to make much difference. I have also burned brand new copies of the latest version of the timecode - no help there either. Anyone know what might be causing this? Thanks for any helpful input in advance!
     
  2. lethal_pizzle

    lethal_pizzle NI Product Owner

    Messages:
    10,600
    With timecode, I run it in 'manual' mode and switch the master over myself tbh.

    In fact, I have a macro that selects the other deck as master whenever I load a track into a deck.
     
  3. mest42085

    mest42085 NI Product Owner

    Messages:
    368
    Thanks for the tip Lethal, but I never had this poblem until I started using tsp on my mac. Is this a problem u encountered as well, prompting u to use manual mode, or just personal pref?
     
  4. Steinz

    Steinz Forum Member

    Messages:
    265
    Problem in manual mode is if you forget to switch master and you stop the deck , which the other one was sync'd to the sync deck will play at -8 pitch. I decided Id rather live with the random changes than risk the sudden meltdown by accident
     
  5. mest42085

    mest42085 NI Product Owner

    Messages:
    368
    Ok so this IS a known issue in TSP? Just curious what kind of computer ur on and what latency / sample rate ur running @ Steinz? Like I said I never had this problem on my PC running @ the specs I mentioned, ever. Only now. I'm going to forward this thread to support. Hopefully they can suss it out.
     
  6. Steinz

    Steinz Forum Member

    Messages:
    265
  7. mest42085

    mest42085 NI Product Owner

    Messages:
    368
    Yes I feel like I can remember having this problem pre-1.1.2, but never on 1.2.6. And even then it was different. The Auto Master would jump to the wrong deck and then STAY there until u manually fixed it. Now it just moves backs and forth between decks randomly as I adjust the jogs on my cdjs.

    I was using the lastest version prior to swtiching to Mac and never had this problem. The only dif now is 1) OSX instead of Vista 2) Lower latency & 3) Higher sample rate.
    I have created a ticket with support (Ticket#2010082410000475) so hopefully they can help although I am not holding my breath. Unfortunately I have not had the best of luck with NI support. Though to their credit - while the last ticket I filed I never received a reply, they did wind up issuing a hotfix for the dragging to playlist bug.

    I am most interested in hearing from other users on Mac using Timecode and the latest version. Even if its just a simple yes or no, are you also getting this behavoir? And if it's not too much trouble could you please list your settings? Thank you! :cool:
     
  8. jaygrow

    jaygrow New Member

    Messages:
    3
    same problem

    Im running Traktor Scratch Duo and am having the same issues, jumping master. Im running a new pc and have the same set up - when new track loads it automatically switches master to track running. I at first thought it was my turntable connection, Im glad to hear that there are others with this problem. However, Im really surprised that this would be an issue with no solution?
     
  9. mest42085

    mest42085 NI Product Owner

    Messages:
    368
    Jaygrow- What latency/sample rate are you running at?

    ----------

    This is the response I got from support, which to their credit came very promptly, although not really what I was hoping to hear:

    "When using Traktor Scratch Pro with Timecode CD's or Vinyl control, the DECK
    MASTER's Master/Sync mode on the deck's does NOT work by design. The tempo of both songs being played must still be matched by ear, just like using normal cds or
    Vinyl records. There is not a way to hide this feature. At top left under DECK MASTER keep the MAN button selected.

    TRAKTOR MANUAL ENGLISH located under HELP, click OPEN MANUAL."

    I always beat match myself, but I do like to use the phase meter feature also. Its just strange that Auto mode has always worked perfectly until now that I'm on a different laptop...

    If this is a known issue and according to support this feature does not work, is it that hard to make it work? Would this entail any more than just writing a code that says to make the master deck the one thats been playing longest in relation to the others?
     
  10. mest42085

    mest42085 NI Product Owner

    Messages:
    368
    So I had a look around in the manual tonight regarding this issue since Tech support made it a point to tell me to RTFM. Under the deck master modes it does not say that Auto mode doesn't work with timecode. In fact it says -

    Deck Master – Automated Mode (AUTO)
    This is the most common and practical mode. Use this mode if you want to have no hassle – TRAKTOR will take care of syncing tracks for you.
    ► One of the playing Decks is automatically chosen as MASTER.
    ► If you stop the MASTER Deck, TRAKTOR automatically switches the MASTER state
    to the next best candidate.
    ► Engage SYNC on all decks and simply load and play the tracks.

    While I do not use sync, I do use the fx a lot, and when the master deck jumps around, this can cause off-timed fx. In fact, if we're supposed to just leave it on manual, wouldn't we risk syncing the fx to a stopped deck if we forgot to change it ourselves? I'm sorry but this answer from support seems like weak advice. Am I missing something?

    Sorry for all the complaining on this but, I just want Traktor to behave the way it always did when I was on a slower and less stable computer! I feel like support did not take this as an opportunity to fix something strange about the software, but rather took an "It doesnt work and thats the way it is attitude." This is obviously affecting more than just me! What can I do to initiate some kind of motivation on NI's part to care about this?
     
  11. jaygrow

    jaygrow New Member

    Messages:
    3
    seems odd

    Im running about 100us (0.1ms) latency.

    It does seem like a very odd response from NI. Is there a way to get a moderator on the thread?
     
Thread Status:
Not open for further replies.