MIDI timing using Reaktor Sequencers VST in Ableton

Discussion in 'REAKTOR' started by adg672, Jan 16, 2014.

  1. adg672

    adg672 New Member

    Messages:
    11
    First post so hi to everyone in the forum.

    Using Ableton, I've been trying to control non-Reaktor (virtual and external) devices via Reaktor sequencers, specifically 'euclidean seq demo v1.3' in the user library and Spiral (I've tried others too with similar issues).

    Can get MIDI to the non-Reaktor device channel no problem, however the timing is all over the place. Changing the buffer size has some effect but nothing I've tried has fixed it.

    Read around and see some similar problems but couldn't find a solution.

    If anyone could help it'd be greatly appreciated.

    Thanks!
     
  2. adg672

    adg672 New Member

    Messages:
    11
    on osx 10.6.8

    thanks
     
  3. sowari

    sowari Moderator Moderator

    Messages:
    27,839
    i loaded Reaktor VST in Albleon Live 9.1 and loaded the Euclidean Sequncer - just the sequencer - into the instance of Reaktor.

    i sent MIDI from that instance of Reaktor into a second Reaktor instance loaded with SteamPipe.

    the timing was fine for me. i played it along side a minimal techno beat in Maschine 2 and there were no problems.

    sowari
     
  4. adg672

    adg672 New Member

    Messages:
    11
    thanks for the reply. here's a screen shot of the sequencer sending midi to an empty midi channel. you can see in the clip the timing's off.
    any ideas how to fix it?

    cheers

    Screen shot 2014-01-16 at 17.29.07.png
     
  5. sowari

    sowari Moderator Moderator

    Messages:
    27,839
    here is one of the preset sequences - mine looks fine to me.

    i can't suggest anything, all i can tell you is that i am running Reaktor 5.9, Ableton 9.1 on a Mac.

    sowari
     

    Attached Files:

  6. adg672

    adg672 New Member

    Messages:
    11
    thanks anyway

    anyone else got an idea?

    Cheers
     
  7. sowari

    sowari Moderator Moderator

    Messages:
    27,839
    i'll try with other sequencers.

    sowari
     
  8. sowari

    sowari Moderator Moderator

    Messages:
    27,839
    you have a point.

    this is a screen shot of Spiral 'quantized' to 1/4 beats. the placement of the chords in Ableton is consistently early - see screenshot.

    sowari
     

    Attached Files:

  9. sowari

    sowari Moderator Moderator

    Messages:
    27,839
    here is another Sequencer - notice how every event is a little early.

    sowari
     

    Attached Files:

  10. sowari

    sowari Moderator Moderator

    Messages:
    27,839
    possible workaround for this issue

    adg672, so after doing more detailed research, i agree with your findings.

    it seems that the timing issue does have a connection with the audio buffer size in the DAWs settings. you could try reducing the buffer size for when you are recording Reaktor Sequencers - of course this could cause problems if you have a complex project.

    i suppose another workaround could be using Input Quantize when you are recording into Ableton.

    fwiw, i noticed a much 'tighter' recording in Pro Tools 11 - but it still was not 100% perfect.

    cheers

    sowari
     
  11. ~Pd~

    ~Pd~ Forum Member

    Messages:
    569
    Did some testing myself in Ableton and Reaper and it's a problem the Reaktor devs will have to address.

    I do hope this gets resolved soon as I have some Reaktor sequenced projects in the works that I'd like to use with MIDI out to drive other plugins. Recording with quantizing, or quantizing afterwards is a workaround, I suppose, but not the same as recording audio live with tweaks on the fly.
     
  12. adg672

    adg672 New Member

    Messages:
    11
    Cheers sowari and ~PD~ for the replies and the effort looking into it. Hope it gets fixed soon - agree with the recording/playing live comment ~PD~

    Thanks
     
  13. panlogik

    panlogik New Member

    Messages:
    2
    I have similar problem but in Reaper. Listening or rendering audio with REAKTOR as VSTi instruments inside project makes all its tracks out of sync. Some tracks play note to early and other to late. There is no such problem in v5.8.
     
  14. John6455

    John6455 Member

    Messages:
    104
    If the delay is a constant amount of time, how about adjusting the track delay for the offending track? I use Live 8.4.1, though that feature should still be around.
     
  15. John6455

    John6455 Member

    Messages:
    104
    Having tested the track delay, it seems it will not affect the timing of the midi clips being posted here. The clips are like a pre-fx stage. The track delay will affect the timing of those notes sent to instruments in the effects chain. Even if it doesnt look correct on paper, you should still be able to sync your instruments by ear.
     
  16. Loopy C

    Loopy C NI Product Owner

    Messages:
    1,265
    Agreed, ideally it would just work in realtime and save all these unnecessary multi-pass efforts to get correct timing ;-)
     
  17. ipassenger

    ipassenger Forum Member

    Messages:
    122
    This slight early midi issue is still present on Liv 9.5 and Reaktor 6. Buffer size does effect it but I would have thought this is something that could be fixed. Has anyone contacted NI or Live on this?
     
  18. sowari

    sowari Moderator Moderator

    Messages:
    27,839
    please provide us with a specific example.

    cheers

    sowari
     
  19. ipassenger

    ipassenger Forum Member

    Messages:
    122
    Take the attached patch and load it into an instance of Reaktor in Ableton Live.
    Have another midi channel in Ableton Live record the midi output of the Reaktor channel.
    The notes are consistently early. Changing the buffer size on the audio card changes how early it is.

    I wonder if it relates to Live seeing Reaktor as an audio plugin and not a midi device and thus is applying a pre read buffer on its activities.
     

    Attached Files:

  20. ipassenger

    ipassenger Forum Member

    Messages:
    122
    Actually, it looks like there is a some jitter there too.