1. We're currently conducting systematic tests with the release version of macOS 11 (Big Sur) in order to offer full compatibility of our products as soon as possible. You can find our latest compatibility status - here


    Please note that although announced at the same time as macOS Big Sur, Apple Silicon processors are an independent release with separate compatibility concerns for NI products. Compatibility with macOS Big Sur will not yet ensure compatibility with Apple Silicon processors. At the moment, Native Instruments products are not supported on computers with Apple Silicon processors. Read more - here

    Dismiss Notice

MIDI-triggering of audio module - possible?

Discussion in 'MASCHINE Area' started by Supercreative, Aug 7, 2020.

  1. Supercreative

    Supercreative NI Product Owner

    Messages:
    2,059
    Hey Machines!

    I`m on Logic Pro X right and currently it is not possible for me to trigger the content of audio module (loops) via MIDI.
    I tried Loop- and Gate-mode.

    Anyone here who has been successful doing this?

    No problem to trigger it via the KK-plugin (but that's no what I want to do).


    Thx in advance!
     
  2. Supercreative

    Supercreative NI Product Owner

    Messages:
    2,059
    It would also help when somebody could confirm that it“s not possible... ;)
     
  3. Gidi

    Gidi NI Product Owner

    Messages:
    51
    I think its possible....if i understand what you mean correctly.

    Load Maschine as a plugin, load loops in the soundslots in group A.
    If you dont change any parameters, the selected soundslot loop wil play in pad mode ( the loop changes pitch according to the midi key)
    If you change group/midi routings/drumkit mode, every soundslot plays a different loop, starting at c2
    if you want the start note to be different, change the mode to manual key mode and change the start note.
    You can play the loops now, drawing midi notes in a midi clip, or trigger them thru a master keyboard.
    Inputting the notes thru the maschine hardware is a bit more complicated.... havent worked that out in logic.
    Maybe this isn't possible at all.

    Hope it makes sense!
     
  4. ALDREAD

    ALDREAD NI Product Owner

    Messages:
    5,264
    You have to use maschine hw in midi mode to input notes into logic
     
    • Like Like x 1
  5. Supercreative

    Supercreative NI Product Owner

    Messages:
    2,059
    Thanks for your response.
    Meanwhile I also tested a bit by myself ;)

    Firstly, I have to say that I try to do this primarily by drag & drop of MIIDI and for this I use an already functional MIDI-routing within my setup. I use one (multi output) Maschine instance, each sound slot is routed to it’s own dedicaded MIDI channel.

    However, when it comes to triggering loops (audio module) by MIDI then it seems there is a lack of function.

    If I drag MIDI when audio module is in loop mode, no MIDI note will be transferred to Logic (empty region).

    Finally, I expected it to work after dragging when the sound is in gate mode. Here the event has been created but the sound has not been triggered during playback.
    The odd thing is, I can hear the sound, when klick on this event-note within Logics piano roll.

    Once more (apart fron drag & drop):
    If I activate my A25 keyboard within Maschine (keyboard symbol - when connected), I‘m able to record MIDI-notes / regions within Logics arranger and it works.
    When I didn‘t activate the A25, I‘m able to hear the sound on the focused track but If I start recording, the sound will not bee triggered in Maschine - subsequently there is no result.

    For me this seems to be a bug or lack of integration at least within Logic (10.5.1).

    I appreciate If somebody is able to test / confirm it.
     
  6. ALDREAD

    ALDREAD NI Product Owner

    Messages:
    5,264
    Did you change the group settings- sounds to midi notes /channels
    Right click on group and you can change it , might be that
     
  7. ALDREAD

    ALDREAD NI Product Owner

    Messages:
    5,264
    In case you need more info on midi mode and logic
    https://www.native-instruments.com/...rol-transport-of-logic-x.360759/#post-1834081
     
  8. ALDREAD

    ALDREAD NI Product Owner

    Messages:
    5,264
    This is correct, because in loop mode there is no midi note triggering the audio , afaik
    In gate mode the midi note triggers the audio depending on its length
     
  9. Supercreative

    Supercreative NI Product Owner

    Messages:
    2,059
    yeah, that’s why I wrote this:
    But in my case it doesn’t work. So I need to know if this is caused by the version of Logic or myself or whatever. :eek:
     
  10. ALDREAD

    ALDREAD NI Product Owner

    Messages:
    5,264
    Ok , I’ll test it out asap and let you know
     
    Last edited: Aug 11, 2020
    • Like Like x 1
  11. ALDREAD

    ALDREAD NI Product Owner

    Messages:
    5,264
    Not had chance to test it yet ,
    But try switching the audio module to sampler, see if logic triggers it
     
  12. Blindeddie

    Blindeddie NI Product Owner

    Messages:
    2,807
    OK, I don't have Logic and I am on Windows, but I think I may have figure out the issue based on some tests I did with Ableton Live.

    It appears that in order to play an audio module, there has to be an active pattern in the Group that contains the audio Module(s) with the AM(s) set to Gate Mode, but no events triggered in the sound slot, so basically you see a waveform that looks disabled. Now based on how it is explained that when using Maschine as a Rack or Multi Sound module in order to prevent "Doubling" of sounds, you have to have all patterns disabled or have an empty scene set up, for the audio module, that does not apply. This means you have to have a dedicated group that only uses audio modules.

    Hope that makes sense.
     
    • Informative Informative x 2
  13. Supercreative

    Supercreative NI Product Owner

    Messages:
    2,059
    Yeah, that was the solution! :thumbsup::)
    If there the audio module is being used the dedicated pattern has to be active within Maschine.
    1.) MIDI drag & drop -> check
    2.) MIDI recording in DAW -> check
    3.) Overdubbing in DAW after drag & drop -> check

    That's a bit crazy, because then users are not able to drag MIDI of an expansion (kit) which contains loops with audio modules.
    Maybe that's not desired by NI (bug)?
    Finally, I'm good with it. I just have to remember this :D:p.

    special thanks to: Blindeddie
     
    • Like Like x 1
  14. Supercreative

    Supercreative NI Product Owner

    Messages:
    2,059
    To use this don't for get to use an empty pattern for playback after drag & drop.
    ;)

    I have to correct my last statement.
    To use a whole kit with audio modules and instruments/samples , just use an empty pattern for this kit and set the focus to it (empty pattern is active). Easy. :)

    Bildschirmfoto 2020-08-11 um 21.27.15.png
     
    • Like Like x 2