Mixtrack Not Interfacing with Traktor LE

Discussion in 'TRAKTOR LE / TRAKTOR ME' started by Markt74, Jan 6, 2011.

Thread Status:
Not open for further replies.
  1. Markt74

    Markt74 New Member

    Messages:
    7
    I've just purchased the Numark Mixtrack controller and installed and activated the Traktor LE software that was packaged with the controller. I first installed Traktor LE and updated it through the Service Center, then connected the controller. The light son the controller illuminate, but I am unable to control Traktor LE with the controller.

    I used the Setup Wizard and mapped the software to the controller (USB/Firewall Controller - Yes, Manufacturer/Device - Numark/Mixtrack) and selected "Finish" at the end of the wizard. When I navigate to the Preferences menu and in the Controller Manager section, the default controller selection is "Generic Keyboard". I can change this to "Numark Mixtrack" through a drop-down list but the selection doesn't save (i.e., there is no "Save" button in the Controller Manager, only a "Close" button), and so whenever I close the Controller Manager the selection defaults back to "Generic Keyboard".

    Any advice you could offer to address this would be appreciated.
     
  2. TomDooley0075

    TomDooley0075 NI Product Owner

    Messages:
    3,299
    Hi,

    In the setup wizard you have to choose the "mixtrack LE" setting - not the regular "mixtrack"

    the other issue: what the Display says in the dropdown menue only makes editin possible! Every controller (your mixtrach AND the generic keyboard) is always active!
     
  3. Markt74

    Markt74 New Member

    Messages:
    7
    Thanks for your response. I've made this change in the Setup Wizard, but still no progress. It's strange; when I have Traktor LE loaded and Mixtrack plugged in, the Mixtrack decks light up, but I can't control anything on Traktor LE with Mixtrack. No matter what button I press on Mixtrack, the lights remain illuminated and Traktor LE doesn not respond except to mouse input.
     
  4. Markt74

    Markt74 New Member

    Messages:
    7
    Ok, uninstalled everything and reinstalled. Same issue. This is very frustrating, and am feeling mislead by the ease that the product advertises. Rather than "plug and play," the phrase should be "plug and struggle." I've updated everything for the second time (v. 1.2.7), used the Setup Wizard and selected the correct options as noted above and I am only able to control Traktor LE via my mouse. Furthermore, I have a sound card with 4 stereo outputs (8 channels) and Traktor LE will only allow me to assign 2 stereo outputs between the A and B channel. I assume I should be using External mixer mode, since my goal is to use an external mixer/controller (Mixtrack). Even though I have 4 stereo outputs, I am unable to assign any to the output preview.

    To make matters worse, I called the support line during business hours and was prompted to leave my phone number and a message regarding my issue. Guess what? No call back. in light of all this, I'm having serious misgivings about this product. Is there ANY source of support I can use (note, having to check 4 different sources, both online and in print, to piece together the necessary documentation to get this up and running is poor customer-facing support). Seeing that Mixtrack was packaged with only a minimum set of documentation was a disappointment. Moreover, Traktor's documentation speaks to nothing regarding setting up the software to use with Mixtrack.

    Please, can somebody help?
     
  5. Markt74

    Markt74 New Member

    Messages:
    7
    Was able to reach US technical support today and it turns out that if you have a Logitech Webcam installed on your computer, it can prevent your USB MIDI device (in this case, Mixtrack) from functioning. The technician sent me an email with instructions on how to get rid of the Logitech driver that causes the issue. Thought this would be helpful to anyone that runs into the same problem, since the technician mentioned that it's common. The Zip file mentioned in the text is attached to my post.

    "Various Logitech (and also Labtech made by Logitech) USB cameras interfere with the proper operation of USB audio or MIDI devices which use the USB Audio Codec. This is because when the camera driver is installed, the computer tries to use it for all USB Audio or MIDI devices. This driver is also not properly uninstalled if the Logitech Software is uninstalled by normal means.

    If you have or have ever had a Logitech Camera connected to your computer, use the procedure below to determine if your system is exhibiting the conflict being discussed in this article.


    Windows XP:

    1. Disconnect your Logitech camera from your computer.
    2. Connect the USB Audio or MIDI device which is not working correctly.
    3. Select the Start menu at the bottom-right of your screen.
    4. Choose Control Panel (or Settings, then Control Panel on some computers).
    5. In the window that opens, double-click the control panel titled System. If there is no item titled System listed in the Control Panels window, click the link in the upper-left of the window titled Switch To Classic View. The System Control Panel should now be visible to the right. Double-click it to open the System Properties window.
    6. At the top of the System Properties window that opens, click the tab titled Hardware.
    7. Then click the button labeled Device manager. You will be presented with a list of all the components installed on your computer.
    8. Right+Click the device titled USB Audio Device and select Properties
    9. In the window that opens, select the Driver tab.
    10. Click the button labeled Driver Details
    11. You should see a list of the following 8 drivers:

    C:\WINDOWS\system32\drivers\drmk.sys

    C:\WINDOWS\system32\drivers\ks.sys

    C:\WINDOWS\system32\drivers\portcls.sys

    C:\WINDOWS\system32\drivers\stream.sys

    C:\WINDOWS\system32\drivers\USBAUDIO.sys

    C:\WINDOWS\system32\ksproxy.ax

    C:\WINDOWS\system32\ksuser.sys

    C:\WINDOWS\system32\wdmaud.sys

    12. If there are more than 8 items in your own list, find out which one is not in the above list, and write down it's name, location and any other information displayed. If this driver appears to be a Logitech driver, then your system is exhibiting the conflict covered here. To remove the Logitech driver, proceed with the instructions below:



    The following download contains a registry script (for Windows XP only, not Vista ) which will remove the problematic file. Do NOT use this registry script unless (using the procedure above) you have determined that your system is exhibiting the specific conflict covered by this article. Simply unzip the file and double click the file titled LowerFilters_remove.reg. You will likely be asked by your computer whether or not to allow the action. When asked, choose Allow.

    If, for any reason, you are unable to use the above script, the following procedure will guide you through determining if you have this problematic driver installed, and will show you how to manually remove it.



    1. Open My Computer

    2. Navigate to the Logitech driver's location which you wrote down (see above). On most computers, it is located in the following directory:

    C:\WINDOWS\system32\drivers\
    Note: This may differ on different computers, or with different Logitech cameras.

    3. Locate the file whose name exactly matches the one you wrote down earlier.
    Your search will be easier if you select Details from the View menu at the top of the window.

    4. Right+Click the file and choose Delete.

    5. You will be asked if you are sure you want to delete the file. Choose Yes

    6. Restart your computer.

    Your USB Audio or MIDI device should now be properly recognized by your software."
     

    Attached Files:

  6. 1Life

    1Life New Member

    Messages:
    15
    i've been having similar problems and have read alot of threads related to mixtrack/traktor problems, but they're not quite exactly the same as what i am experiencing.

    here's what happened to me last night. installed Traktor LE last night on my laptop, and i updated both softwares (traktor and control editor) to newest upgrades out there now, i think 1.27 for the traktor one..

    all lights were illuminated on the mixtrack. i loaded in my tracks to the mixtrack, and the hardware seems to work. and the software seems to work too, except that i'm not getting any volume coming out of my laptop! so i decided to run the demo tracks, and still no volume.. but now whenever i hook up the mixtrack, none of the lights illuminate - ever since i loaded the demo tracks, none of the lights illuminate at all. and there is still no volume...

    so i checked these forums for some tips i could do, tried a few, no dice still. no volume, and no lights...

    so i got frustrated and decided to uninstall the mixtrack and traktor... well, that's all well and good, but now whenever i go into iTunes to play a cd or a mp3, i got NO VOLUME! still no volume..

    so then i decided, let me do a temporary restore to an earlier point when my system was running fine and i had volume and the whole 9 yards... i pick a date to do my restore, and then a prompt pops up saying i have to restore the disk containing my windows system files. i click next, another prompt comes up as: windows has detected file system corruption on vista os. you must check the disk for errors before it can be restored. so i check the disk for errors, and it scans, then it says schedule a check upon restart. i restart the laptop, and there is no check popping up, and when i try go back and do a temp restore, i still go thru the same crap - all these prompts are still there.

    i thought i had a virus, so i ran my virus scanner - i have AVG and it's current... i've got no viruses... and i can't do a temp restore.

    the only fix i can think of right now is to re-install traktor LE and talk to tech support for numark and see if they can help me - or i can try and do a restore back to factory settings.. i don't want to do this, cuz i will lose all the time and saved games i have on Dragon Age - but other then that i can back up everything else on my pc... but i'm wondering - if i can't even do a temp restore to an earlier date, how do i even know if i can do a factory restore?

    this is my predicament, all because of installing traktor LE - all i want is my VOLUME BACK! i want to be able to listen to music and watch youtube, etc... i miss my volume. how do i get it back? Help.

    also, i read what you said about the webcams - interesting.. i've got a problem though, my webcam is integrated, built in to my laptop... so how do i get past that?
    ---
    i'm going to wait for you guys to reply, until then i am reinstalling mixtrack and traktor and doing some tips some of the other threads suggested... wish me luck. what's the worst that can happen? i just uninstall everything and be back to where i started w/ no sound - lol
    ---
    i hope this forum didn't delete the new post i started - i really need the help.

    well here's an update:

    i re-installed traktor LE - and chose audio 2 dj (even though i don't own it) cuz i know i sure don't own the other 2 (audio4 and audio8 - and won't, price is too steep for me)...

    anywho, i reinstalled traktor le and i updated both softwares - traktor 1.27, control editor 1.32

    but upon choosing audio 2dj (cuz apparently i have to choose something in order to install it), i hoped for the best while it was updating the software, and opened iTunes and selected any mp3 to play - and I HAD VOLUME! finally! - i have volume... i haven't re-hooked up the mixtrack yet.. i want to enjoy my volume first, lol.

    but i have no clue what i did in order to get it back, other then re-installing traktor le. so now does this mean, if i uninstall traktor le, i'm never going to have volume again?
     
Thread Status:
Not open for further replies.