My workaround for Native Access startup issues in Windows 10

Discussion in 'NATIVE ACCESS' started by Hack-O-Lantern, Jan 23, 2019.

  1. Hack-O-Lantern

    Hack-O-Lantern New Member

    Messages:
    2
    Like many others I have had the issue of not being able to get Native Access started in Windows 10. As others have noted, the icon would appear in the task bar, but the program would never start and the icon would soon disappear. I looked at all the support articles here and around the web, but none of them helped it get started on my computer. After much experimentation, I stumbled on a method that works by accident:

    1. Do a fresh install, right click to run as administrator.
    2. Set your computer to air-plane mode (Or otherwise disable the internet)
    3. Run Native Access (right click to run as admin)
    4. Native Access will hopefully actually load now, but won't be able to connect to the internet
    5. Disable airplaine mode/reconnect to the internet.
    6. Click the retry button in Native Instruments. Hopefully Native instruments will now load as usual and be working properly. Joy.

    After doing this my Native Access loads normally without having to do this trick, until NI update the program. Then when Native Access tries to download the new update, it goes back to its old behaviour of not starting. I then need to download the newest version manually here - https://www.native-instruments.com/en/specials/native-access/ and repeat the process.

    As of the most recent version 1.8.0 I did not have to do this method to start, but who knows what will happen when it updates, I predict it will go back to the behaviour of not starting and I will need to reinstall the newest version manually. I had a further frustration with this yesterday, when Native Access was looking for the recent version 1.8.0, and trying to install it, but the manual install was only of the previous version. As of today the newest version is available for the manual install.

    This is all pretty frustrating to deal with, especially due to the expense of the software that Native Access regulates. I have wasted a lot of time with this, and I get kind of scared every time I load the program that I won't be able to access my software. This has been a long running problem for a lot of people, it seems, and I really hope NI have fixed it with this most recent update, or will fix it ASAP. They could at least put a version number on the download page (https://www.native-instruments.com/en/specials/native-access/) to inform users.

    I hope this helps anyone with the same issue.
     
  2. Simchris

    Simchris NI Product Owner

    Messages:
    845
    Seems to be pc hardware related, as on my machines with intel processors, install aa admin, then launch as admin have worked just fine for install and updates, using windows 10 and logged into my microsoft account.

    Good advice to help those with the n.a. Issues...seems like a lot of folks!
     
  3. Jose Pablo Valle

    Jose Pablo Valle New Member

    Messages:
    2
    Even as admin still didn't work for my Surface Pro 4
     
  4. KarateSnoopy

    KarateSnoopy New Member

    Messages:
    1
    Thanks Hack-O-Lantern. That solved it for me. I'm not on a laptop, so I just disabled my ethernet device, launched Native Access, and renabled and it started working. Prior to that, it would show the login screen but wouldn't respond. I tried various things like disabling the firewall, compat mode, etc and nothing worked. It looks like the app gets hung up doing something at startup like checking for updates and then gets internally hung but when its offline at startup that code is skipped. Whatever...
     
  5. Rottenlv

    Rottenlv New Member

    Messages:
    4
    so I have to do this every time I want to use NI products? This is not what I signed up for.
     
  6. Blindeddie

    Blindeddie NI Product Owner

    Messages:
    3,272
    No you should not have to do this every time (this only applies to Native Access for downloading products and updates)... you need to ask for assistance here and open a support ticket if you cannot get NA working properly from the friendly advice provided here. There are a lot of things that can contribute to the issue, and 90% are "User Computer/Software" related. There is a more recent post where it turns out that a process being run by the "Killer Ethernet" app was causing this issue for the user and even Dual Monitor setups can cause issues. Post a detailed list of your computer Spec including any Virus/firewall/malware apps running.

    Peace,

    Blindeddie
     
  7. Psyearth5

    Psyearth5 NI Product Owner

    Messages:
    146
     
  8. Psyearth5

    Psyearth5 NI Product Owner

    Messages:
    146
    Are you trying to tell us something?some betvine the lines I to have Intel and on win7 it's working, sometimes it have small short stucks but it works but on the win 10 in my point of view it looks like it's delivered by mean...I really don't now what to think, maybe I should bought a few hardware sints and good OLD and always the fresh CUBASE and bag full with mouses...I think that NI have to repair this literally for ever, we are supporting, buying products and there is majority using cracked versions. In the future NI have to made a solid state build quality software and hardware and if they don't than one day we'll now what really happened here because this is no right just isn't right for us to going missled to wrong path in our lives. ...for example if NI tell us that they won't qontinue and that we should go elsewhere I would be thankful to know that and of course I will feel like being let down and will miss NI but if that is the case OK they're humans after all and maybe they decided to stop or whant from us to more apprised fragile knobs-encoders so maybe this is just a jump scare hahaha I hope for the best and it's all about Music and I getting so frustrating solving think about something that is not a creative process ✨ and I to have Intel and I'm happy on win7
     
  9. Psyearth5

    Psyearth5 NI Product Owner

    Messages:
    146
    Sega Mega Chet's codes for Mortar Kombat FINISH now with win 10 and with hidden and very important programs and files processors so we have to discover right combination hahaha in this that I don't want and I don't like I have to find the funny side of this story hahaha and buy the way, if it stops to work I can't do anything about that and we as a human race should be more educated in digital domain but here we are feeling the same and waiting for something to happen and so we can qontinue
     
  10. Yvon BODY

    Yvon BODY New Member

    Messages:
    2
    This I can't believe ! The NI team have "created" a soft wich does not work 7/10 times (check the forums) and you dare to say this is always user/computer related!!! If my car stops breaking, would this be my right foot misuse or a conception issue ???
     
  11. Blindeddie

    Blindeddie NI Product Owner

    Messages:
    3,272
    Didn’t say always... said 90%. And I base my statement on the final resolutions to issues reported. Most are system related... and I am using the exact same software as everyone else, and it works flawlessly for me... so if it works perfectly for me and not someone else, one could only conclude the issue is system related. This is my personal observation... that is all.
     
  12. Martin Mersmann

    Martin Mersmann New Member

    Messages:
    4
    • Like Like x 2
  13. Psyearth5

    Psyearth5 NI Product Owner

    Messages:
    146
    ...on WIN 10 i menage to install Maschine and Kontakt , expansions and massive but I can't install Reaktor player and Reaktor instruments, in native access everything is OK but when I open Maschine there's no Reaktor. I tried many times and finally I decided to go back to WIN 7 as everything works and so far Im happy
     
  14. RodCruz

    RodCruz New Member

    Messages:
    3
    C`mon NI, it´s been more than a year since this thread started, this issue should already be fixed...
     
  15. ShelLuser

    ShelLuser NI Product Owner

    Messages:
    1,307
    What makes you so sure there was an issue with N.A. in the first place? Most people don't have any issue at all with N.A. on Windows 10, and just because the OP had issues doesn't automatically imply that there was actually a problem in the software itself.
     
  16. Nicholas93

    Nicholas93 New Member

    Messages:
    3
    It's just fantastic. NA is either stuck on "Searching for the latest update" or won't let me log in. On a brand new PC with Win 10 Pro here...
    Absolutely zero problems on my iMac Pro on Catalina.
     
  17. mgagne01

    mgagne01 New Member

    Messages:
    2
    It worked for me thanks for the hint :)