1. We're currently conducting systematic tests with the release version of macOS 11 (Big Sur) in order to offer full compatibility of our products as soon as possible. You can find our latest compatibility status - here


    Please note that although announced at the same time as macOS Big Sur, Apple Silicon processors are an independent release with separate compatibility concerns for NI products. Compatibility with macOS Big Sur will not yet ensure compatibility with Apple Silicon processors. At the moment, Native Instruments products are not supported on computers with Apple Silicon processors. Read more - here

    Dismiss Notice

No sound from GR4

Discussion in 'Technical Issues - KOMPLETE (Archive)' started by mjxs, Jun 6, 2010.

Thread Status:
Not open for further replies.
  1. mjxs

    mjxs New Member

    Messages:
    3
    Hi there,

    Last night I installed Guitar Rig 4. I attached my guitar straight via the Line In jack and it worked no problem via WASAPI.

    This morning I tried again, and it won't pick up anything. My guitar will play clean out of my speakers so I know the computer is getting a signal.

    I tried installing ASIO4ALL but that didn't work either. I'm stuck and rather upset.

    I don't have any hardware, and considering it worked straight via Line In last night I assume it should today too.

    Edit: Oh, and I'm on Windows Vista 64 bit, on a (shitty) Dell Studio 1555 running IDT hidef. I do get output like when I load a file on the tapdeck, but naughtta in.
     
    Last edited: Jun 6, 2010
  2. ew

    ew Moderator Moderator

    Messages:
    21,328
    Welcome =)

    What are your settings in both the audio and routing tabs in audio/MIDI settings?
    Also, a guitar's an instrument level device- not line or mic level. Use a preamp of some form if you're using line ins.

    ew
     
  3. mjxs

    mjxs New Member

    Messages:
    3
    Hi, thanks for the speedy reply. I hit on an earlier post by a guy who had the exact same problem but it never seems to have been solved (he just disappeared).

    Yeah I get the whole thing about impedence matching. What's a fairly cost effective solution, or perhaps USB interface? Barring this working I suppose that's what I'll have to do.

    Audio
    Driver WASAPI (Shared Mode)
    Device IDT High Def Audio Codec (4In, 4Out)
    Status Running
    Sample Rate 48000
    Latency 480 Samples

    Routing
    Outputs
    GR4 Out1+2L 1: Speakers/Headphones Out 0
    GR4 Out1+2R 2: Speakers/Headphones Out 1
    GR4 In1+2L 1: Mic/Line In In 0
    GR4 ln1+2R 2: Mc/Line In in 1

    IDT hi-def audio lets me change the input pin between Line In and Mic if that makes a difference. Also a while ago, the Audio Device said IDT High Def but with 6IN, 4OUT... confusingly. Not too sure what all that means... I'm a total damn newb
     
  4. ew

    ew Moderator Moderator

    Messages:
    21,328
  5. mjxs

    mjxs New Member

    Messages:
    3
    Hi there,

    I did download that yesterday and installed it, but when I switch to it, the inputs are chosen as "Not connected" with no other options. As well, the output is set to "HDMI Audio OUt" which is think is my external monitor speakers, with no other options. In any event, no sound comes out anyway.
    ---
    Oh wow, so, I think I found a way that it accepts sound in now - it had to do with disabling the exclusivity option in Sound->Speakers->Advanced in the control panel with ASIO4ALL. BUt I'm still not getting any sound out. It says my speakers are unavailable.
    ---
    Okay, I figured it out. You do indeed need ASIO4ALL. I have no idea why it worked the first night, but here's what I did.

    Got ASIO4ALL.

    Go to control panel->sound->speakers->advanced and disable all the exclusive options.
    Then, right click on the volume icon and go to Playback Devices. Right click on the output device you want and disable it.

    Then reopen Guitar Rig, use ASIO4ALL, select the right inputs and outputs, and all's well that ends well.

    Thanks for your help - really glad I finally got this working!
     
Thread Status:
Not open for further replies.