1. Hi everyone,

    This forum is now closed for posting! If you require technical support from NI or have a questions about activating your product, please head over to our new Support Community!

    NATIVE INSTRUMENT SUPPORT COMMUNITY

    The Support Community is the new location where you can expect to receive assistance and feedback on technical support, sales or installation issues from our Support Agents and other users.

    Please also note, questions about the status of an order should always be directly sent to our Order Support team HERE.

    Best wishes, 
    The NI Team

No sound when using Midi keyboard in Kontakt 5

Discussion in 'Technical Issues - KOMPLETE (Archive)' started by haydendavenport, Sep 25, 2012.

  1. haydendavenport

    haydendavenport New Member

    Messages:
    6
    Hello everyone,

    I'm using Kontakt 5, and I'm having a strange problem. I have a sound loaded, and it is for sure working. I opened up the "piano roll" or whatever you might call it, where you can click on the keys. Sound is played. But whenever I play a note using the midi keyboard I have, the sound does not play.

    But when I press the key, the levels act as if a note sounded, and the virtual "piano roll" keyboard's key(s) are depressed. So the midi keyboard is recognized. I tried two different keyboards, and the problem persisted.

    I'm using Windows 7.

    Could anyone remedy this issue?

    Thank you in advance!
     
  2. cocorico

    cocorico New Member

    Messages:
    9
    Hi,

    I have the same problem: when I use the internal keyboard of kontakt I get sound in my speakers (I use a digi 002R), but when I play the midi external keyboard I get no sound. In my case, when I press the external keys I see no changes in kontack.

    Did you resolved this issue?

    Thanks
     
  3. haydendavenport

    haydendavenport New Member

    Messages:
    6
    Hey,

    Unfortunately no, I haven't gotten any responses for possible solutions. I have no idea how to fix it at all. My friend and I tried everything we could think of.
     
  4. cocorico

    cocorico New Member

    Messages:
    9
    Do you use kontakt as an instrument in a daw or in standalone mode?
     
  5. haydendavenport

    haydendavenport New Member

    Messages:
    6
    I'm using it in standalone mode
     
  6. cocorico

    cocorico New Member

    Messages:
    9
    Yeah, me too. Did you tried in a daw? did it work? I didn't tried yet. I use pro tools 10, 8 core windows 7 64 bits.

    Thanks for sharing your experience :)
     
  7. haydendavenport

    haydendavenport New Member

    Messages:
    6
    I haven't tried it in a daw either... I just wanted to use it for live applications.
     
  8. DarkStar

    DarkStar NI Product Owner

    Messages:
    1,993
    @haydendavenport

    Let me summarize my understanding
    -- If an instrument is loaded and the virtual MIDI keyboard is clicked (on a "blue note") then the note is shown as depressed, the instrument's meter shows the audio level and you can hear the sound.
    -- If your external MIDI keyboard is then played, then the notes are shown as depressed (they should be the blue notes), the instrument's meter shows the audio level but there is no sound to hear.

    Is that right? If so, that's very odd.


    @ cocorico
    That sounds like you have not configured Kontakt standalone to use your keyboard as the MIDI input device. Or, when you use it as a plug-in, no MIDI is being sent to it.
     
  9. haydendavenport

    haydendavenport New Member

    Messages:
    6
    @DarkStar

    Yes, that's absolutely correct. I think it's really odd too!
     
  10. cocorico

    cocorico New Member

    Messages:
    9
    @DarkStar

    Thanks for the answer.

    (I'm talking about standalone mode)
    In my case, when I use the internal keyboard I hear the sound, but when I press the external keys, nothing happens, no sound, no blue keys pressed in the internal keyboard.

    I use a keyboard through my digi 002R harware. This is my File-Options-MIDI-Inputs configuration:

    All devices (FW 002 MIDI1 (In/Out) and the two others) are assigned to port A :confused: - may be this is the problem?

    Do you know how to fix this?
     
  11. DarkStar

    DarkStar NI Product Owner

    Messages:
    1,993
    @haydendavenport
    -- does it happen with one / several / many / all instruments?
    -- does it happen if you load Kontakt plug-in in a DAW?

    @ cocorico
    -- from what you have said, the MIDI is not reaching Kontakt
    -- I do not know which MIDI devices form the Digi 002 should be selected in Kontakt standalone
    -- do you have any other standalone products that you can try?

    Otherwise, I'm stumped - time for Support Tickets.
     
  12. stephen23

    stephen23 NI Product Owner

    Messages:
    346
    That just doesn't make sense. There are 847 reasons why pressing keys might not produce sound, but if the audio meter for the instrument is registering (see jpeg) and no sound is audible, the fault lies in your audio routing. There is no way simply changing the MIDI source could affect that.

    (Let me know if I'm wrong - I'd love to know the explanation)
     

    Attached Files:

  13. haydendavenport

    haydendavenport New Member

    Messages:
    6
    @DarkStar

    I only have one virtual instrument (Alicia's Keys), so I don't know if it happens with other instruments. I guess I can download something free out there. I also haven't tried it in a DAW, I'll have to do that as well.
     
  14. DarkStar

    DarkStar NI Product Owner

    Messages:
    1,993
    How about the Factory content?
     
  15. jkrupa

    jkrupa New Member

    Messages:
    1
    Hey, I was having the same problem... Not on Windows though. I'm using a Macbook Pro 2.6 Ghz quad core i7. The solution for me was simple, and I'm not sure if this is the fix for you or not... But check your midi input within Kontakt 5. You'll see it in the upper left hand corner of whatever instrument you have loaded. Kontakt 5 was defaulting to midi channel "Port A" for some odd reason. Just select "omni" and you should be good to go. Like I said, I was having the same issue and this fixed it for me. Hope this helps!
     
  16. Faiss09

    Faiss09 New Member

    Messages:
    1
    I have the same problem. kontakt internal keyboard makes sound. Midi keyboard does not give sound, but sound level meters show that there is sound. I tried to change channels from "port A" to "Omni" . It does not work. You can see the sound levels going up and down, but no sound.
     
  17. nyssabox

    nyssabox New Member

    Messages:
    1
    I had the same problem with no sound from Kontakt 5.


    It turned out it was my Kontakt default settings, a user setting I had created that always worked was now causing a conflict after an update. (I assume the update was the cause of the conflict...maybe the I/O settings had changed)


    I found that existing Kontact tracks still worked on previous sessions I had made before the problem started. A Kontakt piano track, for example, still played and I was still able to still use my midi device to play the plug in with no problems. However, when creating a brand new Kontakt track on the same session there would be no sound, even though I could clearly see by the meter readings Kontakt was seeing my midi device.

    If you check the drop down box (where you can load different templates/settings try loading a few different ones, if you find one where Kontak still works set that one as your default.


    So in a nutshell, this is what I did.
    Load a previous session where a track using Kontact still works.
    Close what ever plug in Kontakt is using (i.e Session Strings..unless you want it to load everytime) and then save as a new default setting.
    So now when loading Kontakt on a new session it should use this new default setting.

    Or

    Select different settings from the drop down section (where you can save your own default settings)
    Find one where Kontakt still works then save that as your default.

    I hope that helped anyone having this problem.
     
  18. Mosfmhos

    Mosfmhos New Member

    Messages:
    2
    I still have the same problem! The only thing I've noticed is that Kontakt didn't recognize my output connections! None of them! If I click on the "Output" button on the top and try to configure, on the "physical out", it doesn't show any of my connections, even my speakers.

    When I play a note on the virtual keyboard, the note is shown as depressed, the audio meter goes up, and I listen it.
    When I play a note then on my MIDI external keyboard, the note is shown as depressed, the audio meter goes up, but I don't listen anything.

    I think it could be a problem on the output connection, it only shows "Not Connected", like this picture!
    Please, help me!!!

    [​IMG]
     
  19. eclecticrenegade

    eclecticrenegade New Member

    Messages:
    4
    are you using "wasapi" for your driver mode if your trying to use your computer speakers
     
    • Like Like x 1
  20. eclecticrenegade

    eclecticrenegade New Member

    Messages:
    4
    under the audio tab in options. make sure your using the right driver for your computer speakers which should be "wasapi"
    in the driver drop down box. then in the device drop down box make sure you have your computer speakers selected. then go back to the channel output configuration "box shown above" and your speakers should show up, you might actually have to select them, ch. 1 and ch. 2 left and right, and it should work
     
    • Like Like x 1